]> git.pld-linux.org Git - packages/qemu.git/blame_incremental - qemu.spec
- up to qemu-0.14.0
[packages/qemu.git] / qemu.spec
... / ...
CommitLineData
1# TODO:
2# - update patches
3# - qemu-system-ppc -hda ac-ppc.img says:
4# qemu: could not open disk image ac-ppc.img: Success
5# qemu-0.12.2-2.x86_64.rpm - broken
6# qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
7# qemu-0.11.1-7k.x86_64.rpm - OK
8#
9# Conditional build:
10%bcond_with cflags_passing # with passing rpmcflags to Makefiles
11%bcond_with dosguest # add special patch when use with DOS as guest os
12%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
13
14Summary: QEMU CPU Emulator
15Summary(pl.UTF-8): QEMU - emulator procesora
16Name: qemu
17Version: 0.14.0
18Release: 1
19License: GPL
20Group: Applications/Emulators
21# Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
22Source0: http://download.savannah.gnu.org/releases/qemu/%{name}-%{version}.tar.gz
23# Source0-md5: f9d145d5c09de9f0984ffe9bd1229970
24Patch0: %{name}-ncurses.patch
25Patch6: %{name}-nosdlgui.patch
26# Proof of concept, for reference, do not remove
27Patch8: %{name}-kde_virtual_workspaces_hack.patch
28#Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
29Patch13: %{name}-dosguest.patch
30Patch14: %{name}-ppc_old_binutils.patch
31Patch15: %{name}-isa-bios-ram.patch
32# below one fixes problems with passing ram size to bios/bootloader
33# which affects coreboot/linuxbios
34Patch16: %{name}-piix-ram-size.patch
35Patch17: %{name}-whitelist.patch
36URL: http://wiki.qemu.org/Index.html
37BuildRequires: SDL-devel >= 1.2.1
38BuildRequires: alsa-lib-devel
39BuildRequires: bluez-libs-devel
40BuildRequires: gnutls-devel
41BuildRequires: ncurses-devel
42BuildRequires: perl-Encode
43BuildRequires: perl-tools-pod
44BuildRequires: pkgconfig
45BuildRequires: sed >= 4.0
46BuildRequires: texi2html
47BuildRequires: which
48BuildRequires: xorg-lib-libX11-devel
49Requires: SDL >= 1.2.1
50# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
51ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54# some PPC/SPARC boot image in ELF format
55%define _noautostrip .*%{_datadir}/qemu/openbios-.*
56
57%description
58QEMU is a FAST! processor emulator. By using dynamic translation it
59achieves a reasonnable speed while being easy to port on new host
60CPUs. QEMU has two operating modes:
61
62- User mode emulation. In this mode, QEMU can launch Linux processes
63 compiled for one CPU on another CPU. Linux system calls are converted
64 because of endianness and 32/64 bit mismatches. Wine (Windows
65 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
66
67- Full system emulation. In this mode, QEMU emulates a full system,
68 including a processor and various peripherials. It can also be used to
69 provide virtual hosting of several virtual PC on a single server.
70
71%description -l pl.UTF-8
72QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
73tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
74aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
75
76- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
77 procesy linuksowe skompilowane dla jednego procesora na innym
78 procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
79 niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
80 słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
81 cele QEMU.
82
83- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
84 włączając w to procesor i różne urządzenia peryferyjne. Może być także
85 używane do wirtualnego hostowania kilku wirtualnych pecetów na
86 pojedynczym serwerze.
87
88%prep
89%setup -q
90%patch0 -p1
91%{?with_nosdlgui:%patch6 -p1}
92#patch8 -p1
93%patch17 -p0
94
95%{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
96%{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
97
98# cannot use optflags on x86 - they cause "no register to spill" errors
99%if %{with cflags_passing}
100%{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
101%else
102%{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
103%endif
104
105%build
106# --extra-cflags don't work (overridden by CFLAGS in Makefile*)
107# they can be passed if the cflags_passing bcond is used
108./configure \
109 --prefix=%{_prefix} \
110 --cc="%{__cc}" \
111 --host-cc="%{__cc}" \
112 --enable-mixemu \
113 --audio-drv-list="alsa" \
114 --interp-prefix=%{_libdir}/%{name}
115%{__make}
116
117%install
118rm -rf $RPM_BUILD_ROOT
119
120%{__make} install \
121 DESTDIR=$RPM_BUILD_ROOT
122
123install -d $RPM_BUILD_ROOT%{_sysconfdir}
124cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
125#!/bin/sh
126
127EOF
128
129# already packaged
130rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%files
136%defattr(644,root,root,755)
137%doc README qemu-doc.html qemu-tech.html
138%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
139%attr(755,root,root) %{_bindir}/*
140%{_datadir}/qemu
141%{_mandir}/man1/qemu.1*
142%{_mandir}/man1/qemu-img.1*
143%{_mandir}/man8/qemu-nbd.8*
This page took 0.04443 seconds and 4 git commands to generate.