]> git.pld-linux.org Git - packages/python3-setuptools.git/blame_incremental - python-setuptools.spec
- BR: python-modules, rpm-pythonprov
[packages/python3-setuptools.git] / python-setuptools.spec
... / ...
CommitLineData
1%define module setuptools
2%define subver c11
3%define rel 3
4Summary: A collection of enhancements to the Python distutils
5Summary(pl.UTF-8): Zestaw rozszerzeń dla pythonowych distutils
6Name: python-setuptools
7Version: 0.6
8Release: 2.%{subver}.%{rel}
9Epoch: 1
10License: GPL
11Group: Development/Languages/Python
12Source0: http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}%{subver}.tar.gz
13# Source0-md5: 7df2a529a074f613b509fb44feefe74e
14URL: http://peak.telecommunity.com/DevCenter/setuptools
15BuildRequires: python-devel
16BuildRequires: python-modules
17BuildRequires: rpm-pythonprov
18BuildArch: noarch
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22setuptools is a collection of enhancements to the Python distutils
23that allow you to more easily build and distribute Python packages,
24especially ones that have dependencies on other packages.
25
26This package contains the runtime components of setuptools, necessary
27to execute the software that requires pkg_resources.py.
28
29%description -l pl.UTF-8
30setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
31łatwiejsze budowanie i rozprowadzanie pakietów Pythona, szczególnie
32tych mających zależności od innych pakietów.
33
34Ten pakiet zawiera składniki uruchomieniowe setuptools, potrzebne do
35uruchamiania kodu wymagającego pkg_resources.py.
36
37%package devel
38Summary: Download, install, upgrade, and uninstall Python packages
39Summary(pl.UTF-8): Ściąganie, instalacja, uaktualnianie i usuwanie pakietów Pythona
40Group: Development/Languages
41Requires: %{name} = %{epoch}:%{version}-%{release}
42Requires: python-devel
43
44%description devel
45setuptools is a collection of enhancements to the Python distutils
46that allow you to more easily build and distribute Python packages,
47especially ones that have dependencies on other packages.
48
49This package contains the components necessary to build and install
50software requiring setuptools.
51
52%description devel -l pl.UTF-8
53setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
54łatwiejsze budowanie i rozprowadzanie pakietów Pythona, szczególnie
55tych mających zależności od innych pakietów.
56
57Ten pakiet zawiera składniki potrzebne do budowania i instalacji
58oprogramowania wymagającego setuptools.
59
60%prep
61%setup -q -n %{module}-%{version}%{subver}
62
63%build
64%{__python} ./setup.py build
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69%{__python} ./setup.py install \
70 --single-version-externally-managed \
71 --optimize 2 \
72 --root=$RPM_BUILD_ROOT
73
74rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/*/*.exe
75
76%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
77%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
78%py_postclean
79install site.py $RPM_BUILD_ROOT%{py_sitescriptdir}
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%files
85%defattr(644,root,root,755)
86%doc pkg_resources.txt setuptools.txt
87%{py_sitescriptdir}/%{module}*
88%{py_sitescriptdir}/pkg_resources.py[co]
89%{py_sitescriptdir}/site.py[co]
90%{py_sitescriptdir}/site.py
91
92%files devel
93%defattr(644,root,root,755)
94%doc EasyInstall.txt README.txt api_tests.txt
95%attr(755,root,root) %{_bindir}/easy_install*
96%{py_sitescriptdir}/easy_install.py[co]
This page took 0.02624 seconds and 4 git commands to generate.