]> git.pld-linux.org Git - packages/python-psycopg2.git/blame_incremental - python-psycopg2.spec
rebuild with python 3.10
[packages/python-psycopg2.git] / python-psycopg2.spec
... / ...
CommitLineData
1# TODO:
2# - lib64 patch
3
4# Conditional build:
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8%define module psycopg2
9Summary: psycopg is a PostgreSQL database adapter for Python
10Summary(pl.UTF-8): psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
11Name: python-%{module}
12Version: 2.8.4
13Release: 4
14License: GPL
15Group: Libraries/Python
16Source0: http://initd.org/psycopg/tarballs/PSYCOPG-2-8/%{module}-%{version}.tar.gz
17# Source0-md5: dbb5a67dd57cfa905de37ab9678a92f6
18#Patch0: %{name}-lib64.patch
19URL: http://www.initd.org/software/psycopg/
20BuildRequires: rpmbuild(macros) >= 1.710
21BuildRequires: autoconf
22BuildRequires: postgresql-backend-devel
23BuildRequires: postgresql-devel
24%{?with_python2:BuildRequires: python-devel >= 2.5}
25%{?with_python3:BuildRequires: python3-devel}
26BuildRequires: rpm-pythonprov
27Requires: postgresql-libs
28Requires: python-modules
29Requires: python-pytz
30%if "%{pld_release}" == "ac"
31BuildRequires: python-mx-DateTime-devel
32Requires: python-mx-DateTime
33%else
34# if somebody really needs mx.DateTime, then one can request mx.Datetime
35# usage on runtime;
36# it is pointless to use 'Requires' or 'Suggest' field because
37# - python provides its own datetime implementation
38# - one can request it on runtime (as said above)
39# - usage of mx.DateTime type is application specific
40# Sure, but make mx-DateTime conditional build work
41BuildConflicts: python-egenix-mx-base
42%endif
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45%description
46psycopg is a PostgreSQL database adapter for the Python programming
47language (just like pygresql and popy.) It was written from scratch
48with the aim of being very small and fast, and stable as a rock. The
49main advantages of psycopg are that it supports the full Python
50DBAPI-2.0 and being thread safe at level 2.
51
52%description -l pl.UTF-8
53psycopg jest przeznaczonym dla Pythona interfejsem do bazy danych
54PostgreSQL (tak jak pygresql i popy). Został zakodowany od początku z
55założeniem że ma być bardzo mały, szybki i stabilny. Główna zaletą
56psycopg jest, że w jest pełni zgodny z standardem DBAPI-2.0 i jest
57'thread safe' na poziomie 2.
58
59%package -n python3-%{module}
60Summary: psycopg is a PostgreSQL database adapter for Python
61Summary(pl.UTF-8): psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
62Group: Libraries/Python
63Requires: python3-modules
64Requires: python3-pytz
65
66%description -n python3-%{module}
67psycopg is a PostgreSQL database adapter for the Python programming
68language (just like pygresql and popy.) It was written from scratch
69with the aim of being very small and fast, and stable as a rock. The
70main advantages of psycopg are that it supports the full Python
71DBAPI-2.0 and being thread safe at level 2.
72
73%description -n python3-%{module} -l pl.UTF-8
74psycopg jest przeznaczonym dla Pythona interfejsem do bazy danych
75PostgreSQL (tak jak pygresql i popy). Został zakodowany od początku z
76założeniem że ma być bardzo mały, szybki i stabilny. Główna zaletą
77psycopg jest, że w jest pełni zgodny z standardem DBAPI-2.0 i jest
78'thread safe' na poziomie 2.
79
80%prep
81%setup -q -n %{module}-%{version}
82#%if "%{_lib}" == "lib64"
83#%patch0 -p1
84#%endif
85
86%build
87%if %{with python2}
88%py_build
89%endif
90%if %{with python3}
91%py3_build
92%endif
93
94%install
95rm -rf $RPM_BUILD_ROOT
96%if %{with python2}
97%py_install
98
99%py_postclean
100%endif
101%if %{with python3}
102%py3_install
103%endif
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%if %{with python2}
109%files
110%defattr(644,root,root,755)
111%doc NEWS AUTHORS doc/SUCCESS
112%dir %{py_sitedir}/%{module}
113%attr(755,root,root) %{py_sitedir}/%{module}/*.so
114%{py_sitedir}/%{module}/*.py[co]
115%if "%{pld_release}" != "ac"
116%{py_sitedir}/*.egg-info
117%endif
118%endif
119
120%if %{with python3}
121%files -n python3-%{module}
122%defattr(644,root,root,755)
123%doc NEWS AUTHORS doc/SUCCESS
124%dir %{py3_sitedir}/%{module}
125%dir %{py3_sitedir}/%{module}/__pycache__
126%attr(755,root,root) %{py3_sitedir}/%{module}/*.so
127%{py3_sitedir}/%{module}/*.py
128%{py3_sitedir}/%{module}/__pycache__/*.py*
129%{py3_sitedir}/*.egg-info
130%endif
This page took 0.085062 seconds and 4 git commands to generate.