]> git.pld-linux.org Git - packages/phpMyAdmin.git/blame_incremental - phpMyAdmin.spec
- up to 3.3.1 (bugfixes)
[packages/phpMyAdmin.git] / phpMyAdmin.spec
... / ...
CommitLineData
1# TODO
2# - add codepress (http://codepress.org/index.php) patch
3Summary: phpMyAdmin - web-based MySQL administration
4Summary(pl.UTF-8): phpMyAdmin - administracja bazami MySQL przez WWW
5Name: phpMyAdmin
6Version: 3.3.1
7Release: 1
8License: GPL v2
9Group: Applications/Databases/Interfaces
10Source0: http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
11# Source0-md5: f4f9b7b8398bfaaa7235e01cc0a89a79
12Source1: %{name}.conf
13Source2: %{name}-lighttpd.conf
14Patch0: %{name}-config.patch
15Patch1: %{name}-ServerSelectDisplayName.patch
16Patch2: %{name}-ServerSelectDisplayName-config.patch
17URL: http://www.phpmyadmin.net/
18BuildRequires: rpmbuild(macros) >= 1.268
19Requires(triggerpostun): sed >= 4.0
20Requires: php-common >= 4:5.2
21Requires: php-ctype
22Requires: php-mbstring
23Requires: php-mcrypt
24Requires: php-mysql
25Requires: php-pcre
26Requires: php-session
27Requires: webapps
28Requires: webserver(access)
29Requires: webserver(alias)
30Suggests: php-mysqli
31Suggests: webserver(indexfile)
32Suggests: webserver(php)
33BuildArch: noarch
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%define _appdir %{_datadir}/%{name}
37%define _webapps /etc/webapps
38%define _webapp %{name}
39%define _sysconfdir %{_webapps}/%{_webapp}
40
41%description
42phpMyAdmin can administer a whole MySQL-server (needs a super-user)
43but also a single database. To accomplish the latter you'll need a
44properly set up MySQL-user who can read/write only the desired
45database. It's up to you to look up the appropiate part in the MySQL
46manual. Currently phpMyAdmin can:
47- create and drop databases
48- create, copy, drop and alter tables
49- delete, edit and add fields
50- execute any SQL-statement, even batch-queries
51- manage keys on fields
52- load text files into tables
53- create (*) and read dumps of tables
54- export (*) and import data to CSV values
55- administer multiple servers and single databases
56- check referencial integrity
57- create complex queries automatically connecting required tables
58- create PDF graphics of your database layout
59- communicate in more than 50 different languages
60
61%description -l pl.UTF-8
62phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
63uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
64Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
65baz, którymi chcemy administrować (więcej informacji w odpowiedniej
66podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
67- tworzyć i usuwać bazy
68- wykonywać create, copy, drop oraz alter na tabelach
69- dodawać, usuwać i modyfikować pola
70- wykonywać dowolne zapytania SQL
71- zarządzać kluczami na rekordach
72- wczytywać tekst z plików do tabel
73- obsługiwać ponad 20 języków
74- zarządzać wieloma serwerami i pojedynczymi bazami danych
75- eksportować i importować dane do wartości CSV
76- tworzyć i czytać zrzuty tabel
77
78%prep
79%setup -q -n %{name}-%{version}-all-languages
80%patch0 -p1
81%patch1 -p0
82%patch2 -p0
83
84%install
85rm -rf $RPM_BUILD_ROOT
86install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{js,lang,libraries/{auth/swekey,dbg,dbi,engines,export,tcpdf/font,import,transformations}}}
87
88install *.php *.html *.css $RPM_BUILD_ROOT%{_appdir}
89install lang/*.php $RPM_BUILD_ROOT%{_appdir}/lang
90cp -rf pmd $RPM_BUILD_ROOT%{_appdir}
91cp -rf themes $RPM_BUILD_ROOT%{_appdir}
92cp -rf js $RPM_BUILD_ROOT%{_appdir}
93install libraries/*.php $RPM_BUILD_ROOT%{_appdir}/libraries
94install libraries/auth/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/auth
95install libraries/auth/swekey/*.{php,crt} $RPM_BUILD_ROOT%{_appdir}/libraries/auth/swekey
96install libraries/dbg/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbg
97install libraries/dbi/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbi
98install libraries/engines/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/engines
99install libraries/export/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/export
100install libraries/import/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/import
101install libraries/tcpdf/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf
102install libraries/tcpdf/font/*.{php,z} $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf/font
103install libraries/transformations/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/transformations
104
105install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
106ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
107
108install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
109install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
110install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
111
112cp -f libraries/import/README{,-import}
113cp -f libraries/transformations/README{,-transformations}
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%triggerin -- apache1 < 1.3.37-3, apache1-base
119%webapp_register apache %{_webapp}
120
121%triggerun -- apache1 < 1.3.37-3, apache1-base
122%webapp_unregister apache %{_webapp}
123
124%triggerin -- apache < 2.2.0, apache-base
125%webapp_register httpd %{_webapp}
126
127%triggerun -- apache < 2.2.0, apache-base
128%webapp_unregister httpd %{_webapp}
129
130%triggerin -- lighttpd
131%webapp_register lighttpd %{_webapp}
132
133%triggerun -- lighttpd
134%webapp_unregister lighttpd %{_webapp}
135
136%files
137%defattr(644,root,root,755)
138%doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh lang/*.sh
139%dir %attr(750,root,http) %{_sysconfdir}
140%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
141%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
142%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
143%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
144%dir %{_appdir}
145%{_appdir}/js
146%{_appdir}/lang
147%{_appdir}/libraries
148%{_appdir}/pmd
149%{_appdir}/themes
150%{_appdir}/*.css
151%{_appdir}/*.html
152%{_appdir}/*.php
This page took 0.027224 seconds and 4 git commands to generate.