]> git.pld-linux.org Git - packages/perl.git/blame_incremental - perl.spec
- with recent gcc it builds, works fine and passes tests on ppc without forcing -O1
[packages/perl.git] / perl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4%bcond_without threads # build without support for threads
5%bcond_without gdbm # build without the GDBM_File module
6%bcond_without microperl # build microperl (needs fixing)
7#
8# TODO:
9# - fix "FIXME"s, review "XXX"s
10# - add the {O,N}DBM_File modules
11# - review the perldiag.pod issue
12# - consider disabling ithreads by default
13# - consider introducing perl-dirs
14# - what about "prove" (binary+manual)? (conflicts with standalone Test-Harness)
15# - patch MakeMaker to get rid of empty *.bs files (MM_Unix::dynamic_bs())
16#
17# TODO for perl-dependent packages:
18# - change all "R/BR: perl" to one of perl-{base,modules,devel}
19#
20
21%define _abi 5.8.0
22
23%define perlthread %{?with_threads:-thread-multi}
24
25%define perl_privlib %{_datadir}/perl5/%{version}
26%define perl_archlib %{_libdir}/perl5/%{version}/%{_target_platform}%{perlthread}
27%define perl_sitelib %{_usr}/local/share/perl5
28%define perl_sitearch %{_usr}/local/lib/perl5/%{_abi}/%{_target_platform}%{perlthread}
29%define perl_vendorlib %{_datadir}/perl5/vendor_perl
30%define perl_vendorarch %{_libdir}/perl5/vendor_perl/%{_abi}/%{_target_platform}%{perlthread}
31
32%define _rel 7
33Summary: Practical Extraction and Report Language (Perl)
34