]> git.pld-linux.org Git - packages/perl.git/blame_incremental - perl.spec
- forced not calling the perl.prov script (by undefining __perl_requires)
[packages/perl.git] / perl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3# _without_tests - do not perform "make test"
4# _without_threads - build without support for threads
5# _without_largefiles - build without large file support
6# _without_gdbm - build without the GDBM_File module
7#
8# TODO:
9# - Think about unicore. If uf8*.pm, encode.pm, charnamess.pm (and
10# probably others) are in the perl-base package, unicore should also
11# be there. But it's 5MB...
12# - Think about the package separation. Split between perl, perl-base
13# and perl-modules is far from obvius.
14# - fix "FIXME"s, review "XXX"s
15# - fix perl.prov's handling in rpm -- it should use the __perl macro
16# - fix some duplicate files
17# - add the {O,N}DBM_File modules
18# - *TESTING*
19#
20
21%undefine __perl_requires
22%define __perl_provides %{_builddir}/%{name}-%{version}/find-perl-provides.sh
23#%%define __find_provides %{_builddir}/%{name}-%{version}/find-perl-provides.sh
24
25%define perlthread %{?!_without_threads:-thread-multi}
26
27%define perl_privlib %{_datadir}/perl5/%{version}
28%define perl_archlib %{_libdir}/perl5/%{version}/%{_target_platform}%{perlthread}
29%define perl_sitelib %{_usr}/local/share/perl5
30%define perl_sitearch %{_usr}/local/lib/perl5/%{version}/%{_target_platform}%{perlthread}
31%define perl_vendorlib %{_datadir}/perl5/vendor_perl
32%define perl_vendorarch %{_libdir}/perl5/vendor_perl/%{version}/%{_target_platform}%{perlthread}
33
34Summary: Practical Extraction and Report Language (Perl)
35