]> git.pld-linux.org Git - packages/perl-YAML-Tiny.git/blame_incremental - perl-YAML-Tiny.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-YAML-Tiny.git] / perl-YAML-Tiny.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir YAML
6%define pnam Tiny
7Summary: YAML::Tiny - Read/Write YAML files with as little code as possible
8Summary(pl.UTF-8): YAML::Tiny - odczyt i zapis plików YAML z użyciem jak najmniejszego kodu
9Name: perl-YAML-Tiny
10Version: 1.73
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/YAML/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: d1bb2525e4ab46bfab4b22842c467529
17URL: http://search.cpan.org/dist/YAML-Tiny/
18BuildRequires: perl-devel >= 1:5.8.1
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl(File::Spec) >= 0.80
22BuildRequires: perl-File-Temp >= 0.19
23BuildRequires: perl-JSON-PP
24BuildRequires: perl-Test-Simple >= 0.88
25%endif
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30YAML::Tiny is a Perl class for reading and writing YAML-style files,
31written with as little code as possible, reducing load time and memory
32overhead.
33
34%description -l pl.UTF-8
35YAML::Tiny to klasa Perla od odczytu i zapisu plików w stylu YAML,
36napisana z użyciem jak najmniejszej ilości kodu, tym samym
37zmniejszając narzut czasowy i pamięciowy.
38
39%prep
40%setup -q -n %{pdir}-%{pnam}-%{version}
41
42%build
43%{__perl} Makefile.PL \
44 INSTALLDIRS=vendor
45%{__make}
46
47%{?with_tests:%{__make} test}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51
52%{__make} pure_install \
53 DESTDIR=$RPM_BUILD_ROOT
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files
59%defattr(644,root,root,755)
60%doc Changes README
61%{perl_vendorlib}/YAML/Tiny.pm
62%{_mandir}/man3/YAML::Tiny.3pm*
This page took 0.096348 seconds and 5 git commands to generate.