]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blame_incremental - perl-Net-DNS.spec
- updated to 1.33
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
... / ...
CommitLineData
1# TODO: verify ignore-resolv_conf-open-errors patch (remove or update)
2#
3# Conditional build:
4%bcond_with tests # perform "make test"
5#
6%define pdir Net
7%define pnam DNS
8Summary: Net::DNS - Perl interface to the DNS resolver
9Summary(pl.UTF-8): Net::DNS - interfejs perlowy do resolvera DNS
10Name: perl-Net-DNS
11Version: 1.33
12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: f3ba5295ee588d25dabc74a2ecda296a
18Patch0: %{name}-ignore-resolv_conf-open-errors.patch
19URL: https://metacpan.org/dist/Net-DNS
20BuildRequires: perl-ExtUtils-MakeMaker >= 6.66
21BuildRequires: perl-devel >= 1:5.8.8
22BuildRequires: sed >= 4.0
23%if %{with tests}
24BuildRequires: perl(Exporter) >= 5.56
25BuildRequires: perl(File::Spec) >= 0.86
26BuildRequires: perl(IO::File) >= 1.08
27BuildRequires: perl(IO::Select) >= 1.14
28BuildRequires: perl(IO::Socket) >= 1.26
29BuildRequires: perl(IO::Socket::IP) >= 0.38
30BuildRequires: perl(PerlIO) >= 1.05
31BuildRequires: perl(Time::Local) >= 1.19
32BuildRequires: perl-Carp >= 1.10
33BuildRequires: perl-Digest-BubbleBabble >= 0.01
34BuildRequires: perl-Digest-HMAC >= 1.03
35BuildRequires: perl-Digest-MD5 >= 2.13
36BuildRequires: perl-Digest-SHA >= 5.23
37BuildRequires: perl-Encode >= 2.26
38BuildRequires: perl-IO-Socket-INET6 >= 2.51
39BuildRequires: perl-MIME-Base64 >= 2.13
40BuildRequires: perl-Scalar-List-Utils >= 1.25
41BuildRequires: perl-Test-Pod >= 0.95
42BuildRequires: perl-Test-Simple >= 0.52
43%endif
44BuildRequires: rpm-perlprov >= 4.1-13
45BuildRequires: rpmbuild(macros) >= 1.745
46Requires: perl-Digest-HMAC >= 1.03
47Requires: perl-Digest-MD5 >= 2.13
48Requires: perl-Digest-SHA >= 5.23
49Requires: perl-MIME-Base64 >= 2.13
50Requires: perl(Time::Local) >= 1.19
51# not autodetected
52Provides: perl(Net::DNS::DomainName1035) = 1813
53Provides: perl(Net::DNS::DomainName2535) = 1813
54Conflicts: perl-Net-DNS-SEC < 1.14
55BuildArch: noarch
56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58%description
59Net::DNS is a DNS resolver implemented in Perl. It allows the
60programmer to perform nearly any type of DNS query from a Perl script.
61
62%description -l pl.UTF-8
63Net::DNS jest resolverem DNS, zaimplementowanym w Perlu. Pozwala
64programiście na wykonanie niemal każdego typu zapytania DNS ze skryptu
65Perla.
66
67%prep
68%setup -q -n %{pdir}-%{pnam}-%{version}
69#patch0 -p1
70
71%{__sed} -i -e 's#/''usr/local/bin/perl#/''usr/bin/perl#' demo/* contrib/*
72
73%build
74%{__perl} Makefile.PL </dev/null \
75 --no-online-tests \
76 INSTALLDIRS=vendor
77%{__make}
78
79%{?with_tests:%{__make} test}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84
85%{__make} pure_install \
86 DESTDIR=$RPM_BUILD_ROOT
87
88cp -a demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
89cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
90
91# get rid of pod documentation
92%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Net/DNS/*.pod
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%files
98%defattr(644,root,root,755)
99%doc Changes README
100%{perl_vendorlib}/Net/DNS.pm
101%{perl_vendorlib}/Net/DNS/*.pm
102%{perl_vendorlib}/Net/DNS/RR
103%{perl_vendorlib}/Net/DNS/Resolver
104%{_mandir}/man3/Net::DNS*.3pm*
105%{_examplesdir}/%{name}-%{version}
This page took 0.082638 seconds and 5 git commands to generate.