]> git.pld-linux.org Git - packages/perl-Math-PRSG.git/blame_incremental - perl-Math-PRSG.spec
perl 5.38.0 rebuild
[packages/perl-Math-PRSG.git] / perl-Math-PRSG.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Math
6%define pnam PRSG
7Summary: Math::PRSG - Perl interface to pseudo random sequence generator function
8Summary(pl.UTF-8): Math::PRSG - interfejs Perla do funkcji generatora ciągów pseudolosowych
9Name: perl-Math-PRSG
10Version: 1.0
11Release: 26
12# if used in a product, Systemics should be given attribution as the author
13License: free use, distributable
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: 4f0c32973d5b03d2a665b6ac6ec04b9c
17Patch0: %{name}-paths.patch
18URL: http://search.cpan.org/dist/Math-PRSG/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Math::PRSG is a Perl interface to pseudo random sequence generator
25function. It implements a (159, 31, 0) LFSR, giving a period of 160
26bits. This can then be used as a RNG if seeded well (ie. with 160 bits
27of entropy) and if the output is fed through a message digest function
28(in order to prevent any prediction).
29
30%description -l pl.UTF-8
31Math::PRSG to perlowy interfejs do funkcji generatora ciągów
32pseudolosowych. Implementuje funkcję LFSR (159, 31, 0) mającą okres
33160-bitowy. Może być używany jako generator liczb losowych jeśli
34zostanie dobrze zasilony (160 bitami entropii), a wyjście jest
35przekazywane przez funkcję skrótu (w celu uniknięcia
36przewidywalności).
37
38%prep
39%setup -q -n %{pdir}-%{pnam}-%{version}
40%patch0 -p1
41
42%build
43%{__perl} Makefile.PL \
44 INSTALLDIRS=vendor
45%{__make} \
46 CC="%{__cc}" \
47 OPTIMIZE="%{rpmcflags}"
48
49%{?with_tests:%{__make} test}
50
51%install
52rm -rf $RPM_BUILD_ROOT
53
54%{__make} install \
55 DESTDIR=$RPM_BUILD_ROOT
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
62%doc examples/prsg_driver.pl
63%{perl_vendorarch}/Math/PRSG.pm
64%dir %{perl_vendorarch}/auto/Math/PRSG
65%attr(755,root,root) %{perl_vendorarch}/auto/Math/PRSG/PRSG.so
66%{_mandir}/man3/*
This page took 0.094429 seconds and 5 git commands to generate.