]> git.pld-linux.org Git - packages/perl-Linux-Pid.git/blame_incremental - perl-Linux-Pid.spec
- release 5
[packages/perl-Linux-Pid.git] / perl-Linux-Pid.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Linux
7%define pnam Pid
8Summary: Linux::Pid - get the native PID and the PPID on Linux
9Summary(pl.UTF-8): Linux::Pid - uzyskiwanie natywnych PID i PPID pod Linuksem
10Name: perl-Linux-Pid
11Version: 0.04
12Release: 5
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/Linux/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: 130c4d299f827abf1f2285fddf03fccb
18URL: http://search.cpan.org/dist/Linux-Pid/
19BuildRequires: perl-devel >= 1:5.8.0
20%if %{with tests}
21BuildRequires: perl-Inline-C
22%endif
23BuildRequires: rpm-perlprov >= 4.1-13
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Linux::Pid gets the native PID and the PPID on Linux. It's useful with
28multithreaded programs. Linux's C library returns different values of
29the PID and the PPID from different threads. This module forces Perl
30to call the underlying C functions getpid() and getppid().
31
32%description -l pl.UTF-8
33Linux::Pid odczytuje natywne PID i PPID pod Linuksem. Jest przydatny w
34programach wielowątkowych. Linuksowa biblioteka C zwraca różne
35wartości PID i PPID dla różnych wątków. Ten moduł zmusza Perla do
36wywołania funkcji C getpid() i getppid().
37
38%prep
39%setup -q -n %{pdir}-%{pnam}-%{version}
40
41%build
42%{__perl} Makefile.PL \
43 INSTALLDIRS=vendor
44%{__make}
45
46%{?with_tests:%{__make} test}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51%{__make} install \
52 DESTDIR=$RPM_BUILD_ROOT
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(644,root,root,755)
59%{perl_vendorarch}/%{pdir}/*.pm
60%dir %{perl_vendorarch}/auto/%{pdir}/%{pnam}
61%attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/%{pnam}/*.so
62%{_mandir}/man3/*
This page took 0.040848 seconds and 4 git commands to generate.