]> git.pld-linux.org Git - packages/perl-Inline.git/blame_incremental - perl-Inline.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Inline.git] / perl-Inline.spec
... / ...
CommitLineData
1%define pdir Inline
2Summary: Inline Perl module - write Perl subroutines in other programming languages
3Summary(pl.UTF-8): Moduł Perla Inline - tworzenie funkcji perlowych w innych językach programowania
4Name: perl-Inline
5Version: 0.80
6Release: 1
7Epoch: 1
8# same as perl
9License: GPL v1+ or Artistic
10Group: Development/Languages/Perl
11Source0: http://www.cpan.org/modules/by-module/Inline/%{pdir}-%{version}.tar.gz
12# Source0-md5: 510bbac46e727bcaf240b7feac2646c9
13URL: http://search.cpan.org/dist/Inline/
14BuildRequires: perl-devel >= 1:5.8.1
15BuildRequires: perl(File::Spec) >= 0.8
16BuildRequires: perl-Digest-MD5 >= 2.09
17BuildRequires: perl-Parse-RecDescent >= 1.80
18BuildRequires: perl-Test-Simple >= 0.88
19BuildRequires: perl-Test-Warn >= 0.23
20BuildRequires: rpm-perlprov >= 4.1-13
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25The Inline module allows you to put source code from other programming
26languages directly "inline" in a Perl script or module. The code is
27automatically compiled as needed, and then loaded for immediate access
28from Perl.
29
30%description -l pl.UTF-8
31Moduł Inline pozwala umieszczać kod źródłowy w innych językach
32programowania bezpośrednio wewnątrz skryptu lub modułu perlowego. Kod
33jest w razie potrzeby automatycznie kompilowany, a następnie ładowany
34w celu bezpośredniego dostępu z poziomu Perla.
35
36%prep
37%setup -q -n %{pdir}-%{version}
38
39%{__mv} lib/Inline/MakeMaker/Changes Changes.Inline_MakeMaker
40
41%build
42echo "y" | perl Makefile.PL \
43 INSTALLDIRS=vendor
44%{__make}
45
46%install
47rm -rf $RPM_BUILD_ROOT
48
49%{__make} install \
50 DESTDIR=$RPM_BUILD_ROOT
51
52%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/*.pod \
53 $RPM_BUILD_ROOT%{perl_vendorlib}/Inline/*.pod
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files
59%defattr(644,root,root,755)
60%doc Changes Changes.Inline_MakeMaker README
61%{perl_vendorlib}/Inline.pm
62%{perl_vendorlib}/Inline/denter.pm
63%{perl_vendorlib}/Inline/Foo.pm
64%{perl_vendorlib}/Inline/MakeMaker.pm
65%{_mandir}/man3/Inline.3pm*
66%{_mandir}/man3/Inline::API.3pm*
67%{_mandir}/man3/Inline::FAQ.3pm*
68%{_mandir}/man3/Inline::Support.3pm*
This page took 0.138896 seconds and 4 git commands to generate.