]> git.pld-linux.org Git - packages/perl-IO-Multiplex.git/blame_incremental - perl-IO-Multiplex.spec
- tabs in preamble
[packages/perl-IO-Multiplex.git] / perl-IO-Multiplex.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir IO
7%define pnam Multiplex
8Summary: IO::Multiplex - manage IO on many file handles
9Summary(pl.UTF-8): IO::Multiplex - zarządzanie operacjami we/wy na wielu uchwytach plików
10Name: perl-IO-Multiplex
11Version: 1.08
12Release: 1
13License: Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: b27e0eb03f85cfd04b3e29953cfd4444
17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
19BuildArch: noarch
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23IO::Multiplex is designed to take the effort out of managing multiple
24file handles. It is essentially a really fancy front end to the select
25system call. In addition to maintaining the select loop, it buffers
26all input and output to/from the file handles. It can also accept
27incoming connections on one or more listen sockets.
28
29%description -l pl.UTF-8
30Moduł IO::Multiplex został zaprojektowany jako próba zarządzania
31wieloma uchwytami plików. Jest przede wszystkim naprawdę fantazyjnym
32frontendem do wywołania systemowego select. Oprócz zarządzania pętlą
33wywołań select, buforuje całe wejście i wyjście do/z uchwytów plików.
34Może także akceptować przychodzące połączenia z jednego lub więcej
35nasłuchujących gniazd.
36
37%prep
38%setup -q -n %{pdir}-%{pnam}-%{version}
39
40%build
41%{__perl} Makefile.PL \
42 INSTALLDIRS=vendor
43%{__make}
44
45%{?with_tests:%{__make} test}
46
47%install
48rm -rf $RPM_BUILD_ROOT
49
50%{__make} install \
51 DESTDIR=$RPM_BUILD_ROOT
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(644,root,root,755)
58%doc Changes README TODO
59%{perl_vendorlib}/IO/Multiplex.pm
60%{_mandir}/man3/*
This page took 0.034067 seconds and 4 git commands to generate.