]> git.pld-linux.org Git - packages/perl-Gnome2.git/blame_incremental - perl-Gnome2.spec
- rebuild with perl 5.30.0
[packages/perl-Gnome2.git] / perl-Gnome2.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # perform "make test" (requires X server)
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Gnome2
7Summary: Perl interface to the 2.x series of the GNOME libraries
8Summary(pl.UTF-8): Interfejs perlowy do bibliotek GNOME 2.x
9Name: perl-Gnome2
10Version: 1.046
11Release: 6
12License: LGPL v2.1+
13Group: Development/Languages/Perl
14Source0: http://download.sourceforge.net/gtk2-perl/%{pdir}-%{version}.tar.gz
15# Source0-md5: abb820a474237f6c8d6c2dc19ba3c1e6
16URL: http://gtk2-perl.sourceforge.net/
17BuildRequires: libbonoboui-devel >= 2.0.0
18BuildRequires: libgnomeui-devel >= 2.14.1
19BuildRequires: perl-ExtUtils-Depends >= 0.201
20BuildRequires: perl-ExtUtils-PkgConfig >= 1.03
21BuildRequires: perl-Glib-devel >= 1.140
22BuildRequires: perl-Gnome2-Canvas-devel >= 1.002
23BuildRequires: perl-Gnome2-VFS-devel >= 1.060
24BuildRequires: perl-Gtk2-devel >= 1.140
25BuildRequires: perl-devel >= 1:5.8.0
26%if %{with tests}
27BuildRequires: perl-Test-Number-Delta >= 1.0
28%endif
29BuildRequires: rpm-perlprov >= 4.1-13
30Requires: libbonoboui >= 2.0.0
31Requires: libgnomeui >= 2.14.1
32Requires: perl-Glib >= 1.140
33Requires: perl-Gnome2-Canvas >= 1.002
34Requires: perl-Gnome2-VFS >= 1.060
35Requires: perl-Gtk2 >= 1.140
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39The Gnome2 Perl module allows a Perl developer to use the GNOME 2
40libraries.
41
42%description -l pl.UTF-8
43Moduł Perla Gnome2 pozwala programistom perlowym na używanie bibliotek
44środowiska GNOME 2.
45
46%package devel
47Summary: Development files for Perl Gnome2 bindings
48Summary(pl.UTF-8): Pliki programistyczne wiązań Gnome2 dla Perla
49Group: Development/Languages/Perl
50Requires: %{name} = %{version}-%{release}
51Requires: libbonoboui-devel >= 2.0.0
52Requires: libgnomeui-devel >= 2.14.1
53Requires: perl-Glib-devel >= 1.140
54Requires: perl-Gnome2-Canvas-devel >= 1.002
55Requires: perl-Gnome2-VFS-devel >= 1.060
56Requires: perl-Gtk2-devel >= 1.140
57
58%description devel
59Development files for Perl Gnome2 bindings.
60
61%description devel -l pl.UTF-8
62Pliki programistyczne wiązań Gnome2 dla Perla.
63
64%prep
65%setup -q -n %{pdir}-%{version}
66
67%build
68%{__perl} Makefile.PL \
69 INSTALLDIRS=vendor
70
71%{__make} \
72 CC="%{__cc}" \
73 OPTIMIZE="%{rpmcflags}"
74
75%{?with_tests:%{__make} test}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80%{__make} install \
81 DESTDIR=$RPM_BUILD_ROOT
82
83%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Gnome2/{*,*/*}.pod
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files
89%defattr(644,root,root,755)
90%doc AUTHORS README TODO
91%{perl_vendorarch}/Gnome2.pm
92%attr(755,root,root) %{perl_vendorarch}/auto/Gnome2/Gnome2.so
93%{_mandir}/man3/Gnome2.3pm*
94%{_mandir}/man3/Gnome2::*.3pm*
95
96%files devel
97%defattr(644,root,root,755)
98%{perl_vendorarch}/Gnome2/Install
This page took 0.032504 seconds and 4 git commands to generate.