]> git.pld-linux.org Git - packages/perl-Crypt-Twofish.git/blame_incremental - perl-Crypt-Twofish.spec
- fix building with perl 5.26
[packages/perl-Crypt-Twofish.git] / perl-Crypt-Twofish.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # Do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Crypt
7%define pnam Twofish
8Summary: Crypt::Twofish Perl module - the Twofish encryption algorithm
9Summary(pl.UTF-8): Moduł Perla Crypt::Twofish - algorytm szyfrowania Twofish
10Name: perl-Crypt-Twofish
11Version: 2.14
12Release: 10
13License: Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: 295c059d18f9a46dd14bd765fc465318
17Patch0: no-dot-in-inc.patch
18URL: http://search.cpan.org/dist/Crypt-Twofish/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24This module implements Twofish encryption. It supports the Crypt::CBC
25interface. Twofish is a 128-bit symmetric block cipher with a variable
26length (128, 192, or 256-bit) key, developed by Counterpane Labs. It
27is unpatented and free for all uses, as described at
28<http://www.counterpane.com/twofish.html>.
29
30%description -l pl.UTF-8
31Ten moduł jest implementacją szyfrowania Twofish. Obsługuje interfejs
32Crypt::CBC. Twofish jest 128-bitowym symetrycznym szyfrem blokowym ze
33zmienną długością klucza (128, 192 lub 256 bitów), opracowanym przez
34Counterpane Labs. Nie jest opatentowany i można go swobodnie używać
35do dowolnych celów, zgodnie z opisem pod adresem
36<http://www.counterpane.com/twofish.html>.
37
38%prep
39%setup -q -n %{pdir}-%{pnam}-%{version}
40%patch0 -p1
41
42%build
43%{__perl} Makefile.PL \
44 INSTALLDIRS=vendor
45%{__make} \
46 CC="%{__cc}" \
47 OPTIMIZE="%{rpmcflags}"
48
49%{?with_tests:%{__make} test}
50
51%install
52rm -rf $RPM_BUILD_ROOT
53
54%{__make} install \
55 DESTDIR=$RPM_BUILD_ROOT
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
62%doc Changes README
63%{perl_vendorarch}/Crypt/Twofish.pm
64%dir %{perl_vendorarch}/auto/Crypt/Twofish
65%attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Twofish/*.so
66%{_mandir}/man3/*
This page took 0.052378 seconds and 4 git commands to generate.