]> git.pld-linux.org Git - packages/perl-BDB.git/blame_incremental - perl-BDB.spec
- perl req/prov fix
[packages/perl-BDB.git] / perl-BDB.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pnam BDB
7Summary: BDB - Asynchronous Berkeley DB access
8Summary(pl.UTF-8): BDB - asynchroniczny dostęp do Berkeley DB
9Name: perl-BDB
10Version: 1.91
11Release: 3
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pnam}-%{version}.tar.gz
16# Source0-md5: b337bb3a52d911b9024b0587b2589dcb
17URL: http://search.cpan.org/dist/BDB/
18BuildRequires: db-devel >= 4.3
19BuildRequires: perl-devel >= 1:5.8.8
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl-common-sense
23%endif
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27BDB - Asynchronous Berkeley DB access.
28
29%description -l pl.UTF-8
30BDB - asynchroniczny dostęp do Berkeley DB.
31
32%prep
33%setup -q -n %{pnam}-%{version}
34
35%build
36%{__perl} Makefile.PL \
37 INSTALLDIRS=vendor
38%{__make} \
39 CC="%{__cc}" \
40 OPTIMIZE="%{rpmcflags}"
41
42%{?with_tests:%{__make} test}
43
44%install
45rm -rf $RPM_BUILD_ROOT
46
47%{__make} pure_install \
48 DESTDIR=$RPM_BUILD_ROOT
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(644,root,root,755)
55%doc Changes README
56%{perl_vendorarch}/BDB.pm
57%dir %{perl_vendorarch}/auto/BDB
58%attr(755,root,root) %{perl_vendorarch}/auto/BDB/BDB.so
59%{_mandir}/man3/BDB.3pm*
This page took 0.056056 seconds and 4 git commands to generate.