]> git.pld-linux.org Git - packages/perl-Algorithm-Huffman.git/blame_incremental - perl-Algorithm-Huffman.spec
- formatting
[packages/perl-Algorithm-Huffman.git] / perl-Algorithm-Huffman.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Algorithm
7%define pnam Huffman
8Summary: Algorithm::Huffman - implementation of the Huffman algorithm
9Summary(pl): Algorithm::Huffman - implementacja algorytmu Huffmana
10Name: perl-Algorithm-Huffman
11Version: 0.09
12Release: 3
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: dd5c0360357dcb0807e9ac2e49b2e746
18BuildRequires: perl-devel >= 1:5.8.0
19%if %{with tests}
20BuildRequires: perl-Heap
21BuildRequires: perl-Scalar-List-Utils
22BuildRequires: perl-String-Random
23BuildRequires: perl-Test-Exception
24BuildRequires: perl-Test-ManyParams
25BuildRequires: perl-Test-Simple
26BuildRequires: perl-Tree-DAG_Node
27%endif
28BuildRequires: rpm-perlprov >= 4.1-13
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33This modules implements the huffman algorithm. The aim is to create
34a good coding scheme for a given list of different characters (or even
35strings) and their occurence numbers.
36
37%description -l pl
38