]> git.pld-linux.org Git - packages/performous.git/blame_incremental - performous.spec
- disable Werror to prevent benign warning breaking build on non x86_64 archs
[packages/performous.git] / performous.spec
... / ...
CommitLineData
1Summary: Performous - The All-in-One Music Game
2Summary(pl.UTF-8): Performous - wiele gier muzycznych w jednej
3Name: performous
4Version: 1.3.0
5Release: 1
6License: GPL v2+
7Group: Applications/Sound
8#Source0Download: https://github.com/performous/performous/releases
9Source0: https://github.com/performous/performous/archive/refs/tags/%{version}/%{name}-%{version}.tar.gz
10# Source0-md5: 1579905ea88e09611e90b737e9417895
11Source1: compact_enc_det.tar.xz
12# Source1-md5: c4af58e784fe054b787254acf5c1af12
13Patch0: ced-no-forced-cxx11.patch
14Patch1: find-ced.patch
15Patch2: no-Werror.patch
16URL: http://performous.org/
17BuildRequires: ImageMagick-c++-devel
18BuildRequires: SDL2-devel >= 2
19BuildRequires: aubio-devel
20BuildRequires: boost-devel >= 1.36
21BuildRequires: cmake >= 2.8
22# avformat avresample swscale
23BuildRequires: ffmpeg-devel
24BuildRequires: fontconfig-devel
25BuildRequires: gettext-tools
26BuildRequires: glew-devel
27BuildRequires: glibmm-devel
28BuildRequires: gmock-devel
29BuildRequires: help2man
30BuildRequires: libepoxy-devel >= 1.2
31BuildRequires: libfmt-devel
32BuildRequires: libjpeg-devel
33BuildRequires: libpng-devel
34BuildRequires: librsvg-devel
35BuildRequires: libsigc++-devel
36BuildRequires: libstdc++-devel >= 6:4.6
37BuildRequires: libxml2-devel >= 2.0
38BuildRequires: libxml++2-devel >= 2.6
39BuildRequires: nlohmann-json-devel >= 3.10.5
40BuildRequires: opencv-devel
41BuildRequires: pango-devel >= 1:1.12
42BuildRequires: pkgconfig
43BuildRequires: portaudio-devel
44BuildRequires: portmidi-devel
45BuildRequires: rpmbuild(macros) >= 1.605
46BuildRequires: zlib-devel
47Obsoletes: %{name}-tools < 1.3.0
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51An open-source karaoke, band and dancing game where one or more
52players perform a song and the game scores their perform ances.
53Supports songs in UltraStar, Frets on Fire and StepMania formats.
54Microphones and instruments from SingStar, Guit ar Hero and Rock Band
55as well as some dance pads are autodetected.
56
57%description -l pl.UTF-8
58Karaoke, gitara i taniec w jednej grze. Obsługuje utwory w formatach
59UltraStar, Frets on Fire i StepManii. Mikrofony i kontrolery z gier
60SingStar, Guitar Hero i Rock Band oraz maty do tańca są automatycznie
61wykrywane.
62
63%prep
64%setup -q -a1
65%patch0 -p1
66%patch1 -p1
67%patch2 -p1
68
69%build
70cd compact_enc_det
71install -d build
72cd build
73%cmake .. \
74 -DBUILD_SHARED_LIBS=OFF
75%{__make} ced
76cp -p lib/libced.a ../compact_enc_det
77cd ../..
78
79SRC=$(pwd)
80install -d build/game
81cd build
82%cmake .. \
83 -DCMAKE_INSTALL_MANDIR=%{_mandir}/man6 \
84 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
85 -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags}" \
86 -DCMAKE_DEBUG_FLAGS_RELEASE="%{debugcflags}" \
87 -DMagick_LIBRARY="$(echo %{_libdir}/libMagickCore-*.so)" \
88 -DMagick++_LIBRARY="$(echo %{_libdir}/libMagick++-*.so)" \
89 -DSELF_BUILT_CED=NEVER \
90 -DCed_INCLUDE_DIRS="$SRC/compact_enc_det" \
91 -DCed_LIBRARIES="-L$SRC/compact_enc_det/compact_enc_det $SRC/compact_enc_det/compact_enc_det/libced.a"
92
93%{__make}
94
95%install
96rm -rf $RPM_BUILD_ROOT
97install -d $RPM_BUILD_ROOT%{_mandir}/man1
98
99%{__make} -C build install \
100 DESTDIR=$RPM_BUILD_ROOT
101
102%{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_CN}
103
104%find_lang %{name} --all-name
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%files -f %{name}.lang
110%defattr(644,root,root,755)
111%doc README.md docs/{Authors,instruments}.txt
112%attr(755,root,root) %{_bindir}/performous
113%{_datadir}/games/%{name}
114%{_mandir}/man6/performous.6*
115%{_desktopdir}/performous.desktop
116%{_pixmapsdir}/performous.svg
This page took 0.147491 seconds and 5 git commands to generate.