]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- removed accidental CFLAGS change
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1# TODO:
2# - add trigger to enable this:
3# * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4# new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5#
6# Conditional build:
7%bcond_without audit # sshd audit support
8%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
9%bcond_without gtk # without GTK+ (2.x)
10%bcond_without ldap # with ldap support
11%bcond_without libedit # without libedit (editline/history support in sftp client)
12%bcond_without kerberos5 # without kerberos5 support
13%bcond_without selinux # build without SELinux support
14%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
15%bcond_without tests
16
17# gtk2-based gnome-askpass means no gnome1-based
18%{?with_gtk:%undefine with_gnome}
19
20%if "%{pld_release}" == "ac"
21%define pam_ver 0.79.0
22%else
23%define pam_ver 1:1.1.8-5
24%endif
25Summary: OpenSSH free Secure Shell (SSH) implementation
26Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
27Summary(es.UTF-8): Implementación libre de SSH
28Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
29Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
30Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
31Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
32Summary(pt_BR.UTF-8): Implementação livre do SSH
33Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
34Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
35Name: openssh
36Version: 6.8p1
37Release: 2
38Epoch: 2
39License: BSD
40Group: Applications/Networking
41Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
42# Source0-md5: 08f72de6751acfbd0892b5f003922701
43Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
44# Source1-md5: 66943d481cc422512b537bcc2c7400d1
45Source2: %{name}d.init
46Source3: %{name}d.pamd
47Source4: %{name}.sysconfig
48Source5: ssh-agent.sh
49Source6: ssh-agent.conf
50Source7: %{name}-lpk.schema
51Source8: %{name}d.upstart
52Source9: sshd.service
53Source10: sshd-keygen
54Source11: sshd.socket
55Source12: sshd@.service
56Patch0: %{name}-no_libnsl.patch
57Patch2: %{name}-pam_misc.patch
58Patch3: %{name}-sigpipe.patch
59# http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
60Patch4: %{name}-ldap.patch
61Patch5: %{name}-ldap-fixes.patch
62Patch6: ldap.conf.patch
63Patch7: %{name}-config.patch
64Patch8: ldap-helper-sigpipe.patch
65# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
66# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
67Patch9: %{name}-5.2p1-hpn13v6.diff
68Patch10: %{name}-include.patch
69Patch11: %{name}-chroot.patch
70
71Patch14: %{name}-bind.patch
72Patch15: %{name}-disable_ldap.patch
73Patch16: libseccomp-sandbox.patch
74URL: http://www.openssh.com/portable.html
75BuildRequires: %{__perl}
76%{?with_tests:BuildRequires: %{name}-server}
77%{?with_audit:BuildRequires: audit-libs-devel}
78BuildRequires: autoconf >= 2.50
79BuildRequires: automake
80%{?with_gnome:BuildRequires: gnome-libs-devel}
81%{?with_gtk:BuildRequires: gtk+2-devel}
82%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
83%{?with_libedit:BuildRequires: libedit-devel}
84BuildRequires: libseccomp-devel
85%{?with_selinux:BuildRequires: libselinux-devel}
86%{?with_ldap:BuildRequires: openldap-devel}
87BuildRequires: openssl-devel >= 0.9.8f
88BuildRequires: pam-devel
89%{?with_gtk:BuildRequires: pkgconfig}
90BuildRequires: rpm >= 4.4.9-56
91BuildRequires: rpmbuild(macros) >= 1.627
92BuildRequires: sed >= 4.0
93BuildRequires: zlib-devel >= 1.2.3
94Requires: zlib >= 1.2.3
95%if "%{pld_release}" == "ac"
96Requires: filesystem >= 2.0-1
97Requires: pam >= 0.79.0
98%else
99Requires: filesystem >= 3.0-11
100Requires: pam >= %{pam_ver}
101Suggests: xorg-app-xauth
102%endif
103Obsoletes: ssh
104BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106%define _sysconfdir /etc/ssh
107%define _libexecdir %{_libdir}/%{name}
108%define _privsepdir /usr/share/empty
109%define schemadir /usr/share/openldap/schema
110
111%description
112Ssh (Secure Shell) a program for logging into a remote machine and for
113executing commands in a remote machine. It is intended to replace
114rlogin and rsh, and provide secure encrypted communications between
115two untrusted hosts over an insecure network. X11 connections and
116arbitrary TCP/IP ports can also be forwarded over the secure channel.
117
118OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
119it up to date in terms of security and features, as well as removing
120all patented algorithms to seperate libraries (OpenSSL).
121
122This package includes the core files necessary for both the OpenSSH
123client and server. To make this package useful, you should also
124install openssh-clients, openssh-server, or both.
125
126%if %{with hpn}
127This release includes High Performance SSH/SCP patches from
128http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
129increase throughput on fast connections with high RTT (20-150 msec).
130See the website for '-w' values for your connection and /proc/sys TCP
131values. BTW. in a LAN you have got generally RTT < 1 msec.
132%endif
133
134%description -l de.UTF-8
135OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
136ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
137verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
138über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
139andere TCP/IP Ports können ebenso über den sicheren Channel
140weitergeleitet werden.
141
142%description -l es.UTF-8
143SSH es un programa para accesar y ejecutar órdenes en computadores
144remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
145seguro entre dos servidores en una red insegura. Conexiones X11 y
146puertas TCP/IP arbitrárias también pueden ser usadas por el canal
147seguro.
148
149OpenSSH es el resultado del trabajo del equipo de OpenBSD para
150continuar la última versión gratuita de SSH, actualizándolo en
151términos de seguridad y recursos,así también eliminando todos los
152algoritmos patentados y colocándolos en bibliotecas separadas
153(OpenSSL).
154
155Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
156también el paquete openssh-clients u openssh-server o ambos.
157
158%description -l fr.UTF-8
159OpenSSH (Secure Shell) fournit un accès à un système distant. Il
160remplace telnet, rlogin, rexec et rsh, tout en assurant des
161communications cryptées securisées entre deux hôtes non fiabilisés sur
162un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
163arbitraires peuvent également être transmis sur le canal sécurisé.
164
165%description -l it.UTF-8
166OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
167Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
168sicure e crittate tra due host non fidati su una rete non sicura. Le
169connessioni X11 ad una porta TCP/IP arbitraria possono essere
170inoltrate attraverso un canale sicuro.
171
172%description -l pl.UTF-8
173Ssh (Secure Shell) to program służący do logowania się na zdalną
174maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
175zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
176pomiędzy dwoma hostami.
177
178Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
179klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
180co najmniej jeden z pakietów: openssh-clients lub openssh-server.
181
182%if %{with hpn}
183Ta wersja zawiera łaty z projektu High Performance SSH/SCP
184http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
185zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
186RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
187danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
188TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
189%endif
190
191%description -l pt.UTF-8
192OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
193telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
194cifradas entre duas máquinas sem confiança mútua sobre uma rede
195insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
196reenviados pelo canal seguro.
197
198%description -l pt_BR.UTF-8
199SSH é um programa para acessar e executar comandos em máquinas
200remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
201seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
202TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
203
204OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
205última versão gratuita do SSH, atualizando-o em termos de segurança e
206recursos, assim como removendo todos os algoritmos patenteados e
207colocando-os em bibliotecas separadas (OpenSSL).
208
209Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
210também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
211
212%description -l ru.UTF-8
213Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
214машину и для выполнения команд на удаленной машине. Она предназначена
215для замены rlogin и rsh и обеспечивает безопасную шифрованную
216коммуникацию между двумя хостами в сети, являющейся небезопасной.
217Соединения X11 и любые порты TCP/IP могут также быть проведены через
218безопасный канал.
219
220OpenSSH - это переделка командой разработчиков OpenBSD последней
221свободной версии SSH, доведенная до современного состояния в терминах
222уровня безопасности и поддерживаемых возможностей. Все патентованные
223алгоритмы вынесены в отдельные библиотеки (OpenSSL).
224
225Этот пакет содержит файлы, необходимые как для клиента, так и для
226сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
227openssh-server, или оба пакета.
228
229%description -l uk.UTF-8
230Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
231машини та для виконання команд на віддаленій машині. Вона призначена
232для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
233між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
234довільні порти TCP/IP можуть також бути проведені через безпечний
235канал.
236
237OpenSSH - це переробка командою розробників OpenBSD останньої вільної
238версії SSH, доведена до сучасного стану в термінах рівня безпеки та
239підтримуваних можливостей. Всі патентовані алгоритми винесені до
240окремих бібліотек (OpenSSL).
241
242Цей пакет містить файли, необхідні як для клієнта, так і для сервера
243OpenSSH. Вам потрібно буде ще встановити openssh-clients,
244openssh-server, чи обидва пакети.
245
246%package clients
247Summary: OpenSSH Secure Shell protocol clients
248Summary(es.UTF-8): Clientes de OpenSSH
249Summary(pl.UTF-8): Klienci protokołu Secure Shell
250Summary(pt_BR.UTF-8): Clientes do OpenSSH
251Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
252Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
253Group: Applications/Networking
254Requires: %{name}
255Provides: ssh-clients
256Obsoletes: ssh-clients
257%requires_eq_to openssl openssl-devel
258
259%description clients
260Ssh (Secure Shell) a program for logging into a remote machine and for
261executing commands in a remote machine. It is intended to replace
262rlogin and rsh, and provide secure encrypted communications between
263two untrusted hosts over an insecure network. X11 connections and
264arbitrary TCP/IP ports can also be forwarded over the secure channel.
265
266OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
267it up to date in terms of security and features, as well as removing
268all patented algorithms to seperate libraries (OpenSSL).
269
270This package includes the clients necessary to make encrypted
271connections to SSH servers.
272
273%description clients -l es.UTF-8
274Este paquete incluye los clientes que se necesitan para hacer
275conexiones codificadas con servidores SSH.
276
277%description clients -l pl.UTF-8
278Ssh (Secure Shell) to program służący do logowania się na zdalną
279maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
280zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
281pomiędzy dwoma hostami.
282
283Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
284
285%description clients -l pt_BR.UTF-8
286Esse pacote inclui os clientes necessários para fazer conexões
287encriptadas com servidores SSH.
288
289%description clients -l ru.UTF-8
290Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
291машину и для выполнения команд на удаленной машине.
292
293Этот пакет содержит программы-клиенты, необходимые для установления
294зашифрованных соединений с серверами SSH.
295
296%description clients -l uk.UTF-8
297Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
298машини та для виконання команд на віддаленій машині.
299
300Цей пакет містить програми-клієнти, необхідні для встановлення
301зашифрованих з'єднань з серверами SSH.
302
303%package clients-agent-profile_d
304Summary: OpenSSH Secure Shell agent init script
305Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
306Group: Applications/Networking
307Requires: %{name}-clients = %{epoch}:%{version}-%{release}
308
309%description clients-agent-profile_d
310profile.d scripts for starting SSH agent.
311
312%description clients-agent-profile_d -l pl.UTF-8
313Skrypty profile.d do uruchamiania agenta SSH.
314
315%package clients-agent-xinitrc
316Summary: OpenSSH Secure Shell agent init script
317Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
318Group: Applications/Networking
319Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
320Requires: xinitrc
321
322%description clients-agent-xinitrc
323xinitrc scripts for starting SSH agent.
324
325%description clients-agent-xinitrc -l pl.UTF-8
326Skrypty xinitrc do uruchamiania agenta SSH.
327
328%package server
329Summary: OpenSSH Secure Shell protocol server (sshd)
330Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
331Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
332Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
333Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
334Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
335Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
336Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
337Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
338Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
339Group: Networking/Daemons
340Requires(post): /sbin/chkconfig
341Requires(post): grep
342Requires(post,preun): /sbin/chkconfig
343Requires(postun): /usr/sbin/userdel
344Requires(pre): /bin/id
345Requires(pre): /usr/sbin/useradd
346Requires(post,preun,postun): systemd-units >= 38
347Requires: %{name} = %{epoch}:%{version}-%{release}
348Requires: pam >= %{pam_ver}
349Requires: rc-scripts >= 0.4.3.0
350Requires: systemd-units >= 38
351Requires: util-linux
352%{?with_ldap:Suggests: %{name}-server-ldap}
353Suggests: /bin/login
354Suggests: xorg-app-xauth
355Provides: ssh-server
356Provides: user(sshd)
357%requires_eq_to openssl openssl-devel
358
359%description server
360Ssh (Secure Shell) a program for logging into a remote machine and for
361executing commands in a remote machine. It is intended to replace
362rlogin and rsh, and provide secure encrypted communications between
363two untrusted hosts over an insecure network. X11 connections and
364arbitrary TCP/IP ports can also be forwarded over the secure channel.
365
366OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
367it up to date in terms of security and features, as well as removing
368all patented algorithms to seperate libraries (OpenSSL).
369
370This package contains the secure shell daemon. The sshd is the server
371part of the secure shell protocol and allows ssh clients to connect to
372your host.
373
374%description server -l de.UTF-8
375Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
376
377%description server -l es.UTF-8
378Este paquete contiene el servidor SSH. sshd es la parte servidor del
379protocolo secure shell y permite que clientes ssh se conecten a su
380servidor.
381
382%description server -l fr.UTF-8
383Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
384
385%description server -l it.UTF-8
386Questo pacchetto installa sshd, il server di OpenSSH.
387
388%description server -l pl.UTF-8
389Ssh (Secure Shell) to program służący do logowania się na zdalną
390maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
391zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
392pomiędzy dwoma hostami.
393
394Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
395ssh).
396
397%description server -l pt.UTF-8
398Este pacote intala o sshd, o servidor do OpenSSH.
399
400%description server -l pt_BR.UTF-8
401Esse pacote contém o servidor SSH. O sshd é a parte servidor do
402protocolo secure shell e permite que clientes ssh se conectem ao seu
403host.
404
405%description server -l ru.UTF-8
406Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
407машину и для выполнения команд на удаленной машине.
408
409Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
410часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
411вашим хостом.
412
413%description server -l uk.UTF-8
414Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
415машини та для виконання команд на віддаленій машині.
416
417Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
418частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
419з вашим хостом.
420
421%package server-ldap
422Summary: A LDAP support for open source SSH server daemon
423Summary(pl.UTF-8): Wsparcie LDAP dla serwera OpenSSH
424Group: Daemons
425Requires: %{name} = %{epoch}:%{version}-%{release}
426Requires: openldap-nss-config
427
428%description server-ldap
429OpenSSH LDAP backend is a way how to distribute the authorized tokens
430among the servers in the network.
431
432%description server-ldap -l pl.UTF-8
433Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
434tokenów między serwerami w sieci.
435
436%package server-upstart
437Summary: Upstart job description for OpenSSH server
438Summary(pl.UTF-8): Opis zadania Upstart dla serwera OpenSSH
439Group: Daemons
440Requires: %{name}-server = %{epoch}:%{version}-%{release}
441Requires: upstart >= 0.6
442Conflicts: syslog-ng < 3.2.4-1
443
444%description server-upstart
445Upstart job description for OpenSSH.
446
447%description server-upstart -l pl.UTF-8
448Opis zadania Upstart dla OpenSSH.
449
450%package gnome-askpass
451Summary: OpenSSH GNOME passphrase dialog
452Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
453Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
454Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
455Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
456Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
457Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
458Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
459Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
460Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
461Group: Applications/Networking
462Requires: %{name} = %{epoch}:%{version}-%{release}
463Obsoletes: openssh-askpass
464Obsoletes: ssh-askpass
465Obsoletes: ssh-extras
466
467%description gnome-askpass
468Ssh (Secure Shell) a program for logging into a remote machine and for
469executing commands in a remote machine. It is intended to replace
470rlogin and rsh, and provide secure encrypted communications between
471two untrusted hosts over an insecure network. X11 connections and
472arbitrary TCP/IP ports can also be forwarded over the secure channel.
473
474OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
475it up to date in terms of security and features, as well as removing
476all patented algorithms to seperate libraries (OpenSSL).
477
478This package contains the GNOME passphrase dialog.
479
480%description gnome-askpass -l es.UTF-8
481Este paquete contiene un programa que abre una caja de diálogo para
482entrada de passphrase en GNOME.
483
484%description gnome-askpass -l pl.UTF-8
485Ssh (Secure Shell) to program służący do logowania się na zdalną
486maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
487zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
488pomiędzy dwoma hostami.
489
490Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
491
492%description gnome-askpass -l pt_BR.UTF-8
493Esse pacote contém um programa que abre uma caixa de diálogo para
494entrada de passphrase no GNOME.
495
496%description gnome-askpass -l ru.UTF-8
497Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
498машину и для выполнения команд на удаленной машине.
499
500Этот пакет содержит диалог ввода ключевой фразы для использования под
501GNOME.
502
503%description gnome-askpass -l uk.UTF-8
504Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
505машини та для виконання команд на віддаленій машині.
506
507Цей пакет містить діалог вводу ключової фрази для використання під
508GNOME.
509
510%package -n openldap-schema-openssh-lpk
511Summary: OpenSSH LDAP Public Key schema
512Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
513Group: Networking/Daemons
514Requires(post,postun): sed >= 4.0
515Requires: openldap-servers
516%if "%{_rpmversion}" >= "5"
517BuildArch: noarch
518%endif
519
520%description -n openldap-schema-openssh-lpk
521This package contains OpenSSH LDAP Public Key schema for openldap.
522
523%description -n openldap-schema-openssh-lpk -l pl.UTF-8
524Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
525openldap-a.
526
527%prep
528%setup -q
529%patch0 -p1
530%patch2 -p1
531%patch3 -p1
532%patch4 -p1
533%patch5 -p1
534%patch6 -p1
535%patch7 -p1
536%patch8 -p1
537
538%{?with_hpn:%patch9 -p1}
539%patch10 -p1
540%patch11 -p1
541
542%patch14 -p1
543%{!?with_ldap:%patch15 -p1}
544%patch16 -p1
545
546%if "%{pld_release}" == "ac"
547# fix for missing x11.pc
548%{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
549%endif
550
551# hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
552sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
553
554grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
555%{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
556
557%build
558cp /usr/share/automake/config.sub .
559%{__aclocal}
560%{__autoconf}
561%{__autoheader}
562CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
563%configure \
564 PERL=%{__perl} \
565 --disable-strip \
566 --enable-utmpx \
567 --enable-wtmpx \
568 --with-4in6 \
569 %{?with_audit:--with-audit=linux} \
570 --with-ipaddr-display \
571 %{?with_kerberos5:--with-kerberos5=/usr} \
572 --with-ldap%{!?with_ldap:=no} \
573 %{?with_libedit:--with-libedit} \
574 --with-mantype=man \
575 --with-md5-passwords \
576 --with-pam \
577 --with-pid-dir=%{_localstatedir}/run \
578 --with-privsep-path=%{_privsepdir} \
579%if "%{pld_release}" != "ac"
580 --with-sandbox=libseccomp_filter \
581%endif
582 %{?with_selinux:--with-selinux} \
583%if "%{pld_release}" == "ac"
584 --with-xauth=/usr/X11R6/bin/xauth
585%else
586 --with-xauth=%{_bindir}/xauth
587%endif
588
589echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
590
591%{__make}
592
593%{?with_tests:%{__make} tests}
594
595cd contrib
596%if %{with gnome}
597%{__make} gnome-ssh-askpass1 \
598 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
599%endif
600%if %{with gtk}
601%{__make} gnome-ssh-askpass2 \
602 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
603%endif
604
605%install
606rm -rf $RPM_BUILD_ROOT
607install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
608 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
609install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
610
611%{__make} install \
612 DESTDIR=$RPM_BUILD_ROOT
613
614bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
615
616cp -p %{SOURCE3} sshd.pam
617install -p %{SOURCE2} sshd.init
618
619%if "%{pld_release}" == "ac"
620# not present in ac, no point searching it
621%{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
622# openssl on ac does not have OPENSSL_HAS_ECC
623%{__sed} -i -e '/ecdsa/d' sshd.init
624%endif
625
626%if %{without audit}
627# remove recording user's login uid to the process attribute
628%{__sed} -i -e '/pam_loginuid.so/d' sshd.pam
629%endif
630
631install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
632cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
633cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
634cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
635ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
636cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
637cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
638cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
639
640%{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' %{SOURCE9} >$RPM_BUILD_ROOT%{systemdunitdir}/sshd.service
641cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
642
643cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
644cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
645
646%if %{with gnome}
647install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
648%endif
649%if %{with gtk}
650install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
651%endif
652%if %{with gnome} || %{with gtk}
653cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
654#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
655EOF
656cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
657#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
658EOF
659ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
660%endif
661
662install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
663cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
664
665%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
666echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
667
668touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
669
670cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
671#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
672EOF
673
674%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
675%{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
676
677%clean
678rm -rf $RPM_BUILD_ROOT
679
680%post clients
681%env_update
682
683%postun clients
684%env_update
685
686%post gnome-askpass
687%env_update
688
689%postun gnome-askpass
690%env_update
691
692%pre server
693%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
694
695%post server
696/sbin/chkconfig --add sshd
697%service sshd reload "OpenSSH Daemon"
698NORESTART=1
699%systemd_post sshd.service
700
701%preun server
702if [ "$1" = "0" ]; then
703 %service sshd stop
704 /sbin/chkconfig --del sshd
705fi
706%systemd_preun sshd.service
707
708%postun server
709if [ "$1" = "0" ]; then
710 %userremove sshd
711fi
712%systemd_reload
713
714%triggerpostun server -- %{name}-server < 6.2p1-1
715cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
716sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
717
718%triggerpostun server -- %{name}-server < 2:5.9p1-8
719# lpk.patch to ldap.patch
720if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
721 echo >&2 "Migrating LPK patch to LDAP patch"
722 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
723 %{__sed} -i -e '
724 # disable old configs
725 # just UseLPK/LkpLdapConf supported for now
726 s/^\s*UseLPK/## Obsolete &/
727 s/^\s*Lpk/## Obsolete &/
728 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
729 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
730 ' %{_sysconfdir}/sshd_config
731 if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
732 /bin/systemctl try-restart sshd.service || :
733 else
734 %service -q sshd reload
735 fi
736fi
737%systemd_trigger sshd.service
738if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
739%banner %{name}-server -e << EOF
740!!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
741! Native systemd support for sshd has been installed. !
742! Restarting sshd.service with systemctl WILL kill all !
743! active ssh sessions (daemon as such will be started). !
744!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
745EOF
746fi
747
748%post server-upstart
749%upstart_post sshd
750
751%postun server-upstart
752%upstart_postun sshd
753
754%post -n openldap-schema-openssh-lpk
755%openldap_schema_register %{schemadir}/openssh-lpk.schema
756%service -q ldap restart
757
758%postun -n openldap-schema-openssh-lpk
759if [ "$1" = "0" ]; then
760 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
761 %service -q ldap restart
762fi
763
764%files
765%defattr(644,root,root,755)
766%doc TODO README OVERVIEW CREDITS Change*
767%attr(755,root,root) %{_bindir}/ssh-key*
768#%attr(755,root,root) %{_bindir}/ssh-vulnkey*
769%{_mandir}/man1/ssh-key*.1*
770#%{_mandir}/man1/ssh-vulnkey*.1*
771%dir %{_sysconfdir}
772%dir %{_libexecdir}
773
774%files clients
775%defattr(644,root,root,755)
776%attr(755,root,root) %{_bindir}/ssh
777%attr(755,root,root) %{_bindir}/slogin
778%attr(755,root,root) %{_bindir}/sftp
779%attr(755,root,root) %{_bindir}/ssh-agent
780%attr(755,root,root) %{_bindir}/ssh-add
781%attr(755,root,root) %{_bindir}/ssh-copy-id
782%attr(755,root,root) %{_bindir}/scp
783%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
784%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
785%{_mandir}/man1/scp.1*
786%{_mandir}/man1/ssh.1*
787%{_mandir}/man1/slogin.1*
788%{_mandir}/man1/sftp.1*
789%{_mandir}/man1/ssh-agent.1*
790%{_mandir}/man1/ssh-add.1*
791%{_mandir}/man1/ssh-copy-id.1*
792%{_mandir}/man5/ssh_config.5*
793%lang(it) %{_mandir}/it/man1/ssh.1*
794%lang(it) %{_mandir}/it/man5/ssh_config.5*
795%lang(pl) %{_mandir}/pl/man1/scp.1*
796%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
797
798# for host-based auth (suid required for accessing private host key)
799#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
800#%{_mandir}/man8/ssh-keysign.8*
801
802%files clients-agent-profile_d
803%defattr(644,root,root,755)
804%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
805%attr(755,root,root) /etc/profile.d/ssh-agent.sh
806
807%files clients-agent-xinitrc
808%defattr(644,root,root,755)
809%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
810
811%files server
812%defattr(644,root,root,755)
813%attr(755,root,root) %{_sbindir}/sshd
814%attr(755,root,root) %{_libexecdir}/sftp-server
815%attr(755,root,root) %{_libexecdir}/ssh-keysign
816%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
817%attr(755,root,root) %{_libexecdir}/sshd-keygen
818%{_mandir}/man8/sshd.8*
819%{_mandir}/man8/sftp-server.8*
820%{_mandir}/man8/ssh-keysign.8*
821%{_mandir}/man8/ssh-pkcs11-helper.8*
822%{_mandir}/man5/sshd_config.5*
823%{_mandir}/man5/moduli.5*
824%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
825%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
826%attr(640,root,root) %{_sysconfdir}/moduli
827%attr(754,root,root) /etc/rc.d/init.d/sshd
828%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
829%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
830%{systemdunitdir}/sshd.service
831%{systemdunitdir}/sshd.socket
832%{systemdunitdir}/sshd@.service
833
834%if %{with ldap}
835%files server-ldap
836%defattr(644,root,root,755)
837%doc HOWTO.ldap-keys ldap.conf
838%attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
839%attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
840%{_mandir}/man5/ssh-ldap.conf.5*
841%{_mandir}/man8/ssh-ldap-helper.8*
842%endif
843
844%if %{with gnome} || %{with gtk}
845%files gnome-askpass
846%defattr(644,root,root,755)
847%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
848%dir %{_libexecdir}/ssh
849%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
850%attr(755,root,root) %{_libexecdir}/ssh-askpass
851%endif
852
853%if %{with ldap}
854%files -n openldap-schema-openssh-lpk
855%defattr(644,root,root,755)
856%{schemadir}/openssh-lpk.schema
857%endif
858
859%if "%{pld_release}" != "ti"
860%files server-upstart
861%defattr(644,root,root,755)
862%config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
863%endif
This page took 0.030759 seconds and 4 git commands to generate.