]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- release 3 (rebuild with openssl 1.1.1d)
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1# TODO:
2# - add trigger to enable this:
3# * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4# new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5#
6# Conditional build:
7%bcond_without audit # sshd audit support
8%bcond_with gnome # gnome-askpass (GNOME 1.x) utility
9%bcond_without gtk # gnome-askpass (GTK+ 2.x) utility
10%bcond_without ldap # LDAP support
11%bcond_with ldns # DNSSEC support via libldns
12%bcond_without libedit # libedit (editline/history support in sftp client)
13%bcond_without kerberos5 # Kerberos5 support
14%bcond_without selinux # SELinux support
15%bcond_without libseccomp # use libseccomp for seccomp privsep (requires 3.5 kernel)
16%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
17%bcond_without tests # test suite
18
19# gtk2-based gnome-askpass means no gnome1-based
20%{?with_gtk:%undefine with_gnome}
21
22%if "%{pld_release}" == "ac"
23%define pam_ver 0.79.0
24%else
25%define pam_ver 1:1.1.8-5
26%endif
27Summary: OpenSSH free Secure Shell (SSH) implementation
28Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
29Summary(es.UTF-8): Implementación libre de SSH
30Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
31Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
32Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
33Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
34Summary(pt_BR.UTF-8): Implementação livre do SSH
35Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
36Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
37Name: openssh
38Version: 8.0p1
39Release: 3
40Epoch: 2
41License: BSD
42Group: Applications/Networking
43Source0: http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
44# Source0-md5: bf050f002fe510e1daecd39044e1122d
45Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
46# Source1-md5: 66943d481cc422512b537bcc2c7400d1
47Source2: %{name}d.init
48Source3: %{name}d.pamd
49Source4: %{name}.sysconfig
50Source5: ssh-agent.sh
51Source6: ssh-agent.conf
52Source7: %{name}-lpk.schema
53Source9: sshd.service
54Source10: sshd-keygen
55Source11: sshd.socket
56Source12: sshd@.service
57Patch1: %{name}-tests-reuseport.patch
58Patch2: %{name}-pam_misc.patch
59Patch3: %{name}-sigpipe.patch
60# http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
61Patch4: %{name}-ldap.patch
62Patch5: %{name}-ldap-fixes.patch
63Patch6: ldap.conf.patch
64Patch7: %{name}-config.patch
65Patch8: ldap-helper-sigpipe.patch
66# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
67# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
68Patch9: %{name}-5.2p1-hpn13v6.diff
69Patch10: %{name}-include.patch
70Patch11: %{name}-chroot.patch
71Patch12: openssh-bug-2905.patch
72
73Patch14: %{name}-bind.patch
74Patch15: %{name}-disable_ldap.patch
75URL: http://www.openssh.com/portable.html
76BuildRequires: %{__perl}
77%{?with_audit:BuildRequires: audit-libs-devel}
78BuildRequires: autoconf >= 2.50
79BuildRequires: automake
80%{?with_gnome:BuildRequires: gnome-libs-devel}
81%{?with_gtk:BuildRequires: gtk+2-devel}
82%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
83%{?with_ldns:BuildRequires: ldns-devel}
84%{?with_libedit:BuildRequires: libedit-devel}
85BuildRequires: libseccomp-devel
86%{?with_selinux:BuildRequires: libselinux-devel}
87%{?with_ldap:BuildRequires: openldap-devel}
88BuildRequires: openssl-devel >= 1.1.0g
89BuildRequires: pam-devel
90%{?with_gtk:BuildRequires: pkgconfig}
91BuildRequires: rpm >= 4.4.9-56
92BuildRequires: rpmbuild(macros) >= 1.627
93BuildRequires: sed >= 4.0
94BuildRequires: zlib-devel >= 1.2.3
95%if %{with tests} && 0%(id -u sshd >/dev/null 2>&1; echo $?)
96BuildRequires: %{name}-server
97%endif
98%if %{with tests} && %{with libseccomp}
99# libseccomp based sandbox requires NO_NEW_PRIVS prctl flag
100BuildRequires: uname(release) >= 3.5
101%endif
102Requires: zlib >= 1.2.3
103%if "%{pld_release}" == "ac"
104Requires: filesystem >= 2.0-1
105Requires: pam >= 0.79.0
106%else
107Requires: filesystem >= 3.0-11
108Requires: pam >= %{pam_ver}
109Suggests: xorg-app-xauth
110%endif
111Obsoletes: ssh
112BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114%define _sysconfdir /etc/ssh
115%define _libexecdir %{_libdir}/%{name}
116%define _privsepdir /usr/share/empty
117%define schemadir /usr/share/openldap/schema
118
119%description
120Ssh (Secure Shell) a program for logging into a remote machine and for
121executing commands in a remote machine. It is intended to replace
122rlogin and rsh, and provide secure encrypted communications between
123two untrusted hosts over an insecure network. X11 connections and
124arbitrary TCP/IP ports can also be forwarded over the secure channel.
125
126OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
127it up to date in terms of security and features, as well as removing
128all patented algorithms to seperate libraries (OpenSSL).
129
130This package includes the core files necessary for both the OpenSSH
131client and server. To make this package useful, you should also
132install openssh-clients, openssh-server, or both.
133
134%if %{with hpn}
135This release includes High Performance SSH/SCP patches from
136http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
137increase throughput on fast connections with high RTT (20-150 msec).
138See the website for '-w' values for your connection and /proc/sys TCP
139values. BTW. in a LAN you have got generally RTT < 1 msec.
140%endif
141
142%description -l de.UTF-8
143OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
144ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
145verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
146über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
147andere TCP/IP Ports können ebenso über den sicheren Channel
148weitergeleitet werden.
149
150%description -l es.UTF-8
151SSH es un programa para accesar y ejecutar órdenes en computadores
152remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
153seguro entre dos servidores en una red insegura. Conexiones X11 y
154puertas TCP/IP arbitrárias también pueden ser usadas por el canal
155seguro.
156
157OpenSSH es el resultado del trabajo del equipo de OpenBSD para
158continuar la última versión gratuita de SSH, actualizándolo en
159términos de seguridad y recursos,así también eliminando todos los
160algoritmos patentados y colocándolos en bibliotecas separadas
161(OpenSSL).
162
163Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
164también el paquete openssh-clients u openssh-server o ambos.
165
166%description -l fr.UTF-8
167OpenSSH (Secure Shell) fournit un accès à un système distant. Il
168remplace telnet, rlogin, rexec et rsh, tout en assurant des
169communications cryptées securisées entre deux hôtes non fiabilisés sur
170un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
171arbitraires peuvent également être transmis sur le canal sécurisé.
172
173%description -l it.UTF-8
174OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
175Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
176sicure e crittate tra due host non fidati su una rete non sicura. Le
177connessioni X11 ad una porta TCP/IP arbitraria possono essere
178inoltrate attraverso un canale sicuro.
179
180%description -l pl.UTF-8
181Ssh (Secure Shell) to program służący do logowania się na zdalną
182maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
183zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
184pomiędzy dwoma hostami.
185
186Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
187klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
188co najmniej jeden z pakietów: openssh-clients lub openssh-server.
189
190%if %{with hpn}
191Ta wersja zawiera łaty z projektu High Performance SSH/SCP
192http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
193zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
194RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
195danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
196TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
197%endif
198
199%description -l pt.UTF-8
200OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
201telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
202cifradas entre duas máquinas sem confiança mútua sobre uma rede
203insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
204reenviados pelo canal seguro.
205
206%description -l pt_BR.UTF-8
207SSH é um programa para acessar e executar comandos em máquinas
208remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
209seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
210TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
211
212OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
213última versão gratuita do SSH, atualizando-o em termos de segurança e
214recursos, assim como removendo todos os algoritmos patenteados e
215colocando-os em bibliotecas separadas (OpenSSL).
216
217Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
218também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
219
220%description -l ru.UTF-8
221Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
222машину и для выполнения команд на удаленной машине. Она предназначена
223для замены rlogin и rsh и обеспечивает безопасную шифрованную
224коммуникацию между двумя хостами в сети, являющейся небезопасной.
225Соединения X11 и любые порты TCP/IP могут также быть проведены через
226безопасный канал.
227
228OpenSSH - это переделка командой разработчиков OpenBSD последней
229свободной версии SSH, доведенная до современного состояния в терминах
230уровня безопасности и поддерживаемых возможностей. Все патентованные
231алгоритмы вынесены в отдельные библиотеки (OpenSSL).
232
233Этот пакет содержит файлы, необходимые как для клиента, так и для
234сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
235openssh-server, или оба пакета.
236
237%description -l uk.UTF-8
238Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
239машини та для виконання команд на віддаленій машині. Вона призначена
240для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
241між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
242довільні порти TCP/IP можуть також бути проведені через безпечний
243канал.
244
245OpenSSH - це переробка командою розробників OpenBSD останньої вільної
246версії SSH, доведена до сучасного стану в термінах рівня безпеки та
247підтримуваних можливостей. Всі патентовані алгоритми винесені до
248окремих бібліотек (OpenSSL).
249
250Цей пакет містить файли, необхідні як для клієнта, так і для сервера
251OpenSSH. Вам потрібно буде ще встановити openssh-clients,
252openssh-server, чи обидва пакети.
253
254%package clients
255Summary: OpenSSH Secure Shell protocol clients
256Summary(es.UTF-8): Clientes de OpenSSH
257Summary(pl.UTF-8): Klienci protokołu Secure Shell
258Summary(pt_BR.UTF-8): Clientes do OpenSSH
259Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
260Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
261Group: Applications/Networking
262Requires: %{name}
263Provides: ssh-clients
264Obsoletes: ssh-clients
265%requires_eq_to openssl openssl-devel
266
267%description clients
268Ssh (Secure Shell) a program for logging into a remote machine and for
269executing commands in a remote machine. It is intended to replace
270rlogin and rsh, and provide secure encrypted communications between
271two untrusted hosts over an insecure network. X11 connections and
272arbitrary TCP/IP ports can also be forwarded over the secure channel.
273
274OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
275it up to date in terms of security and features, as well as removing
276all patented algorithms to seperate libraries (OpenSSL).
277
278This package includes the clients necessary to make encrypted
279connections to SSH servers.
280
281%description clients -l es.UTF-8
282Este paquete incluye los clientes que se necesitan para hacer
283conexiones codificadas con servidores SSH.
284
285%description clients -l pl.UTF-8
286Ssh (Secure Shell) to program służący do logowania się na zdalną
287maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
288zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
289pomiędzy dwoma hostami.
290
291Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
292
293%description clients -l pt_BR.UTF-8
294Esse pacote inclui os clientes necessários para fazer conexões
295encriptadas com servidores SSH.
296
297%description clients -l ru.UTF-8
298Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
299машину и для выполнения команд на удаленной машине.
300
301Этот пакет содержит программы-клиенты, необходимые для установления
302зашифрованных соединений с серверами SSH.
303
304%description clients -l uk.UTF-8
305Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
306машини та для виконання команд на віддаленій машині.
307
308Цей пакет містить програми-клієнти, необхідні для встановлення
309зашифрованих з'єднань з серверами SSH.
310
311%package clients-agent-profile_d
312Summary: OpenSSH Secure Shell agent init script
313Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
314Group: Applications/Networking
315Requires: %{name}-clients = %{epoch}:%{version}-%{release}
316
317%description clients-agent-profile_d
318profile.d scripts for starting SSH agent.
319
320%description clients-agent-profile_d -l pl.UTF-8
321Skrypty profile.d do uruchamiania agenta SSH.
322
323%package clients-agent-xinitrc
324Summary: OpenSSH Secure Shell agent init script
325Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
326Group: Applications/Networking
327Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
328Requires: xinitrc
329
330%description clients-agent-xinitrc
331xinitrc scripts for starting SSH agent.
332
333%description clients-agent-xinitrc -l pl.UTF-8
334Skrypty xinitrc do uruchamiania agenta SSH.
335
336%package server
337Summary: OpenSSH Secure Shell protocol server (sshd)
338Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
339Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
340Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
341Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
342Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
343Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
344Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
345Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
346Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
347Group: Networking/Daemons
348Requires(post): /sbin/chkconfig
349Requires(post): grep
350Requires(post,preun): /sbin/chkconfig
351Requires(postun): /usr/sbin/userdel
352Requires(pre): /bin/id
353Requires(pre): /usr/sbin/useradd
354Requires(post,preun,postun): systemd-units >= 38
355Requires: %{name} = %{epoch}:%{version}-%{release}
356Requires: pam >= %{pam_ver}
357Requires: rc-scripts >= 0.4.3.0
358Requires: systemd-units >= 38
359%{?with_libseccomp:Requires: uname(release) >= 3.5}
360Requires: util-linux
361%{?with_ldap:Suggests: %{name}-server-ldap}
362Suggests: /bin/login
363Suggests: xorg-app-xauth
364Provides: ssh-server
365Provides: user(sshd)
366%requires_eq_to openssl openssl-devel
367
368%description server
369Ssh (Secure Shell) a program for logging into a remote machine and for
370executing commands in a remote machine. It is intended to replace
371rlogin and rsh, and provide secure encrypted communications between
372two untrusted hosts over an insecure network. X11 connections and
373arbitrary TCP/IP ports can also be forwarded over the secure channel.
374
375OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
376it up to date in terms of security and features, as well as removing
377all patented algorithms to seperate libraries (OpenSSL).
378
379This package contains the secure shell daemon. The sshd is the server
380part of the secure shell protocol and allows ssh clients to connect to
381your host.
382
383%description server -l de.UTF-8
384Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
385
386%description server -l es.UTF-8
387Este paquete contiene el servidor SSH. sshd es la parte servidor del
388protocolo secure shell y permite que clientes ssh se conecten a su
389servidor.
390
391%description server -l fr.UTF-8
392Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
393
394%description server -l it.UTF-8
395Questo pacchetto installa sshd, il server di OpenSSH.
396
397%description server -l pl.UTF-8
398Ssh (Secure Shell) to program służący do logowania się na zdalną
399maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
400zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
401pomiędzy dwoma hostami.
402
403Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
404ssh).
405
406%description server -l pt.UTF-8
407Este pacote intala o sshd, o servidor do OpenSSH.
408
409%description server -l pt_BR.UTF-8
410Esse pacote contém o servidor SSH. O sshd é a parte servidor do
411protocolo secure shell e permite que clientes ssh se conectem ao seu
412host.
413
414%description server -l ru.UTF-8
415Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
416машину и для выполнения команд на удаленной машине.
417
418Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
419часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
420вашим хостом.
421
422%description server -l uk.UTF-8
423Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
424машини та для виконання команд на віддаленій машині.
425
426Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
427частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
428з вашим хостом.
429
430%package server-ldap
431Summary: A LDAP support for open source SSH server daemon
432Summary(pl.UTF-8): Wsparcie LDAP dla serwera OpenSSH
433Group: Daemons
434Requires: %{name} = %{epoch}:%{version}-%{release}
435Requires: openldap-nss-config
436
437%description server-ldap
438OpenSSH LDAP backend is a way how to distribute the authorized tokens
439among the servers in the network.
440
441%description server-ldap -l pl.UTF-8
442Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
443tokenów między serwerami w sieci.
444
445%package gnome-askpass
446Summary: OpenSSH GNOME passphrase dialog
447Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
448Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
449Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
450Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
451Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
452Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
453Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
454Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
455Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
456Group: Applications/Networking
457Requires: %{name} = %{epoch}:%{version}-%{release}
458Obsoletes: openssh-askpass
459Obsoletes: ssh-askpass
460Obsoletes: ssh-extras
461
462%description gnome-askpass
463Ssh (Secure Shell) a program for logging into a remote machine and for
464executing commands in a remote machine. It is intended to replace
465rlogin and rsh, and provide secure encrypted communications between
466two untrusted hosts over an insecure network. X11 connections and
467arbitrary TCP/IP ports can also be forwarded over the secure channel.
468
469OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
470it up to date in terms of security and features, as well as removing
471all patented algorithms to seperate libraries (OpenSSL).
472
473This package contains the GNOME passphrase dialog.
474
475%description gnome-askpass -l es.UTF-8
476Este paquete contiene un programa que abre una caja de diálogo para
477entrada de passphrase en GNOME.
478
479%description gnome-askpass -l pl.UTF-8
480Ssh (Secure Shell) to program służący do logowania się na zdalną
481maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
482zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
483pomiędzy dwoma hostami.
484
485Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
486
487%description gnome-askpass -l pt_BR.UTF-8
488Esse pacote contém um programa que abre uma caixa de diálogo para
489entrada de passphrase no GNOME.
490
491%description gnome-askpass -l ru.UTF-8
492Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
493машину и для выполнения команд на удаленной машине.
494
495Этот пакет содержит диалог ввода ключевой фразы для использования под
496GNOME.
497
498%description gnome-askpass -l uk.UTF-8
499Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
500машини та для виконання команд на віддаленій машині.
501
502Цей пакет містить діалог вводу ключової фрази для використання під
503GNOME.
504
505%package -n openldap-schema-openssh-lpk
506Summary: OpenSSH LDAP Public Key schema
507Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
508Group: Networking/Daemons
509Requires(post,postun): sed >= 4.0
510Requires: openldap-servers
511%if "%{_rpmversion}" >= "5"
512BuildArch: noarch
513%endif
514
515%description -n openldap-schema-openssh-lpk
516This package contains OpenSSH LDAP Public Key schema for openldap.
517
518%description -n openldap-schema-openssh-lpk -l pl.UTF-8
519Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
520openldap-a.
521
522%prep
523%setup -q
524%patch1 -p1
525%patch2 -p1
526%patch3 -p1
527%patch4 -p1
528%patch5 -p1
529%patch6 -p1
530%patch7 -p1
531%patch8 -p1
532
533%{?with_hpn:%patch9 -p1}
534%patch10 -p1
535%patch11 -p1
536%patch12 -p1
537
538%patch14 -p1
539%{!?with_ldap:%patch15 -p1}
540
541%if "%{pld_release}" == "ac"
542# fix for missing x11.pc
543%{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
544%endif
545
546# hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
547sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh -lopenbsd-compat#g' Makefile*
548
549grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
550%{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
551
552# prevent being ovewritten by aclocal calls
553%{__mv} aclocal.m4 acinclude.m4
554
555%build
556cp /usr/share/automake/config.sub .
557%{__aclocal}
558%{__autoconf}
559%{__autoheader}
560CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
561%configure \
562 PERL=%{__perl} \
563 --disable-strip \
564 --enable-utmpx \
565 --enable-wtmpx \
566 --with-4in6 \
567 %{?with_audit:--with-audit=linux} \
568 --with-ipaddr-display \
569 %{?with_kerberos5:--with-kerberos5=/usr} \
570 --with-ldap%{!?with_ldap:=no} \
571 %{?with_ldns:--with-ldns} \
572 %{?with_libedit:--with-libedit} \
573 --with-mantype=man \
574 --with-md5-passwords \
575 --with-pam \
576 --with-pid-dir=%{_localstatedir}/run \
577 --with-privsep-path=%{_privsepdir} \
578 --with-privsep-user=sshd \
579 %{?with_selinux:--with-selinux} \
580%if "%{pld_release}" == "ac"
581 --with-xauth=/usr/X11R6/bin/xauth
582%else
583 --with-sandbox=seccomp_filter \
584 --with-xauth=%{_bindir}/xauth
585%endif
586
587echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
588
589%{__make}
590
591%if %{with tests}
592%{__make} -j1 tests \
593 TEST_SSH_PORT=$((4242 + ${RANDOM:-$$} % 1000)) \
594 TEST_SSH_TRACE="yes"
595%endif
596
597cd contrib
598%if %{with gnome}
599%{__make} gnome-ssh-askpass1 \
600 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
601%endif
602%if %{with gtk}
603%{__make} gnome-ssh-askpass2 \
604 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
605%endif
606
607%install
608rm -rf $RPM_BUILD_ROOT
609install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
610 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
611install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
612
613%{__make} install \
614 DESTDIR=$RPM_BUILD_ROOT
615
616bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
617
618install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
619cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
620cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
621cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
622ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
623cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
624cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
625
626cp -p %{SOURCE9} %{SOURCE11} %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
627install -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
628
629%{__sed} -i -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' \
630 $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd \
631 $RPM_BUILD_ROOT%{systemdunitdir}/sshd.service \
632 $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
633
634%if %{with gnome}
635install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
636%endif
637%if %{with gtk}
638install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
639%endif
640%if %{with gnome} || %{with gtk}
641cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
642#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
643EOF
644cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
645#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
646EOF
647ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
648%endif
649
650install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
651cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
652
653touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
654
655cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
656#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
657EOF
658
659%if "%{pld_release}" == "ac"
660# not present in ac, no point searching it
661%{__sed} -i -e '/pam_keyinit.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
662# openssl on ac does not have OPENSSL_HAS_ECC
663%{__sed} -i -e '/ecdsa/d' $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
664%endif
665
666%if %{without audit}
667# remove recording user's login uid to the process attribute
668%{__sed} -i -e '/pam_loginuid.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
669%endif
670
671%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
672%{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
673
674%clean
675rm -rf $RPM_BUILD_ROOT
676
677%post clients
678%env_update
679
680%postun clients
681%env_update
682
683%post gnome-askpass
684%env_update
685
686%postun gnome-askpass
687%env_update
688
689%pre server
690%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
691
692%post server
693/sbin/chkconfig --add sshd
694%service sshd reload "OpenSSH Daemon"
695NORESTART=1
696%systemd_post sshd.service
697
698%preun server
699if [ "$1" = "0" ]; then
700 %service sshd stop
701 /sbin/chkconfig --del sshd
702fi
703%systemd_preun sshd.service
704
705%postun server
706if [ "$1" = "0" ]; then
707 %userremove sshd
708fi
709%systemd_reload
710
711%triggerpostun server -- %{name}-server < 2:7.0p1-2
712%banner %{name}-server -e << EOF
713!!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!
714! Starting from openssh 7.0 DSA keys are disabled !
715! on server and client side. You will NOT be able !
716! to use DSA keys for authentication. Please read !
717! about PubkeyAcceptedKeyTypes in man ssh_config. !
718!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
719EOF
720
721%triggerpostun server -- %{name}-server < 6.2p1-1
722cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
723sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
724
725%triggerpostun server -- %{name}-server < 2:5.9p1-8
726# lpk.patch to ldap.patch
727if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
728 echo >&2 "Migrating LPK patch to LDAP patch"
729 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
730 %{__sed} -i -e '
731 # disable old configs
732 # just UseLPK/LkpLdapConf supported for now
733 s/^\s*UseLPK/## Obsolete &/
734 s/^\s*Lpk/## Obsolete &/
735 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
736 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
737 ' %{_sysconfdir}/sshd_config
738 if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
739 /bin/systemctl try-restart sshd.service || :
740 else
741 %service -q sshd reload
742 fi
743fi
744%systemd_trigger sshd.service
745if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
746%banner %{name}-server -e << EOF
747!!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
748! Native systemd support for sshd has been installed. !
749! Restarting sshd.service with systemctl WILL kill all !
750! active ssh sessions (daemon as such will be started). !
751!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
752EOF
753fi
754
755%post -n openldap-schema-openssh-lpk
756%openldap_schema_register %{schemadir}/openssh-lpk.schema
757%service -q ldap restart
758
759%postun -n openldap-schema-openssh-lpk
760if [ "$1" = "0" ]; then
761 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
762 %service -q ldap restart
763fi
764
765%files
766%defattr(644,root,root,755)
767%doc TODO README OVERVIEW CREDITS Change*
768%attr(755,root,root) %{_bindir}/ssh-key*
769#%attr(755,root,root) %{_bindir}/ssh-vulnkey*
770%{_mandir}/man1/ssh-key*.1*
771#%{_mandir}/man1/ssh-vulnkey*.1*
772%dir %{_sysconfdir}
773%dir %{_libexecdir}
774
775%files clients
776%defattr(644,root,root,755)
777%attr(755,root,root) %{_bindir}/ssh
778%attr(755,root,root) %{_bindir}/sftp
779%attr(755,root,root) %{_bindir}/ssh-agent
780%attr(755,root,root) %{_bindir}/ssh-add
781%attr(755,root,root) %{_bindir}/ssh-copy-id
782%attr(755,root,root) %{_bindir}/scp
783%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
784%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
785%{_mandir}/man1/scp.1*
786%{_mandir}/man1/ssh.1*
787%{_mandir}/man1/sftp.1*
788%{_mandir}/man1/ssh-agent.1*
789%{_mandir}/man1/ssh-add.1*
790%{_mandir}/man1/ssh-copy-id.1*
791%{_mandir}/man5/ssh_config.5*
792%lang(it) %{_mandir}/it/man1/ssh.1*
793%lang(it) %{_mandir}/it/man5/ssh_config.5*
794%lang(pl) %{_mandir}/pl/man1/scp.1*
795%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
796
797# for host-based auth (suid required for accessing private host key)
798#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
799#%{_mandir}/man8/ssh-keysign.8*
800
801%files clients-agent-profile_d
802%defattr(644,root,root,755)
803%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
804%attr(755,root,root) /etc/profile.d/ssh-agent.sh
805
806%files clients-agent-xinitrc
807%defattr(644,root,root,755)
808%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
809
810%files server
811%defattr(644,root,root,755)
812%attr(755,root,root) %{_sbindir}/sshd
813%attr(755,root,root) %{_libexecdir}/sftp-server
814%attr(755,root,root) %{_libexecdir}/ssh-keysign
815%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
816%attr(755,root,root) %{_libexecdir}/sshd-keygen
817%{_mandir}/man8/sshd.8*
818%{_mandir}/man8/sftp-server.8*
819%{_mandir}/man8/ssh-keysign.8*
820%{_mandir}/man8/ssh-pkcs11-helper.8*
821%{_mandir}/man5/sshd_config.5*
822%{_mandir}/man5/moduli.5*
823%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
824%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
825%{_sysconfdir}/moduli
826%attr(754,root,root) /etc/rc.d/init.d/sshd
827%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
828%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
829%{systemdunitdir}/sshd.service
830%{systemdunitdir}/sshd.socket
831%{systemdunitdir}/sshd@.service
832
833%if %{with ldap}
834%files server-ldap
835%defattr(644,root,root,755)
836%doc HOWTO.ldap-keys ldap.conf
837%attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
838%attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
839%{_mandir}/man5/ssh-ldap.conf.5*
840%{_mandir}/man8/ssh-ldap-helper.8*
841%endif
842
843%if %{with gnome} || %{with gtk}
844%files gnome-askpass
845%defattr(644,root,root,755)
846%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
847%dir %{_libexecdir}/ssh
848%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
849%attr(755,root,root) %{_libexecdir}/ssh-askpass
850%endif
851
852%if %{with ldap}
853%files -n openldap-schema-openssh-lpk
854%defattr(644,root,root,755)
855%{schemadir}/openssh-lpk.schema
856%endif
This page took 0.057129 seconds and 4 git commands to generate.