]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- uniformized configs to use system-auth where possible
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without chroot # without chrooted user environment support
4%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
5%bcond_without gtk # without GTK+ (2.x)
6%bcond_with ldap # with ldap support
7%bcond_without libedit # without libedit (editline/history support in sftp client)
8%bcond_without kerberos5 # without kerberos5 support
9%bcond_without selinux # build without SELinux support
10%bcond_with hpn # with High Performance SSH/SCP - HPN-SSH (see patch comment)
11%bcond_with hpn_none # with hpn (above) and '-z' none cipher option
12#
13%if %{with hpn_none}
14%undefine with_hpn
15%endif
16# gtk2-based gnome-askpass means no gnome1-based
17%{?with_gtk:%undefine with_gnome}
18Summary: OpenSSH free Secure Shell (SSH) implementation
19Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
20Summary(es.UTF-8): Implementación libre de SSH
21Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
22Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
23Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
24Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
25Summary(pt_BR.UTF-8): Implementação livre do SSH
26Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
27Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
28Name: openssh
29Version: 4.6p1
30Release: 2%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
31Epoch: 2
32License: BSD
33Group: Applications/Networking
34Source0: ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
35# Source0-md5: 6a7fa99f44d9e1b5b04d15256e1405bb
36Source1: %{name}d.conf
37Source2: %{name}.conf
38Source3: %{name}d.init
39Source4: %{name}d.pamd
40Source5: %{name}.sysconfig
41Source6: passwd.pamd
42Source7: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
43# Source7-md5: 66943d481cc422512b537bcc2c7400d1
44Source11: ssh-agent.sh
45Source12: ssh-agent.conf
46Patch0: %{name}-no_libnsl.patch
47Patch2: %{name}-linux-ipv6.patch
48Patch3: %{name}-pam_misc.patch
49Patch4: %{name}-sigpipe.patch
50# http://www.opendarwin.org/projects/openssh-lpk/
51Patch5: %{name}-lpk-4.3p1-0.3.7.patch
52Patch6: %{name}-heimdal.patch
53Patch7: %{name}-pam-conv.patch
54# http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
55Patch8: %{name}-chroot.patch
56Patch9: %{name}-selinux.patch
57# HPN patches rediffed due sigpipe patch.
58# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
59# http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
60Patch10: %{name}-4.3p1-hpn11.patch
61# Adds HPN (see p11) and an undocumented -z none cipher flag
62# http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
63Patch11: %{name}-4.3p1-hpn11-none.patch
64Patch12: %{name}-include.patch
65URL: http://www.openssh.com/
66BuildRequires: %{__perl}
67BuildRequires: autoconf
68BuildRequires: automake
69%{?with_gnome:BuildRequires: gnome-libs-devel}
70%{?with_gtk:BuildRequires: gtk+2-devel}
71%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
72%{?with_libedit:BuildRequires: libedit-devel}
73%{?with_selinux:BuildRequires: libselinux-devel}
74BuildRequires: libwrap-devel
75%{?with_ldap:BuildRequires: openldap-devel}
76BuildRequires: openssl-devel >= 0.9.7d
77BuildRequires: pam-devel
78%{?with_gtk:BuildRequires: pkgconfig}
79BuildRequires: rpmbuild(macros) >= 1.318
80BuildRequires: zlib-devel
81Requires: filesystem >= 3.0-11
82Requires: pam >= 0.99.7.1
83Obsoletes: ssh
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86%define _sysconfdir /etc/ssh
87%define _libexecdir %{_libdir}/%{name}
88%define _privsepdir /usr/share/empty
89
90%description
91Ssh (Secure Shell) a program for logging into a remote machine and for
92executing commands in a remote machine. It is intended to replace
93rlogin and rsh, and provide secure encrypted communications between
94two untrusted hosts over an insecure network. X11 connections and
95arbitrary TCP/IP ports can also be forwarded over the secure channel.
96
97OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
98it up to date in terms of security and features, as well as removing
99all patented algorithms to seperate libraries (OpenSSL).
100
101This package includes the core files necessary for both the OpenSSH
102client and server. To make this package useful, you should also
103install openssh-clients, openssh-server, or both.
104%if %{with hpn} || %{with hpn_none}
105This release includes High Performance SSH/SCP patches from
106http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
107to increase throughput on fast connections with high RTT (20-150 msec).
108See the website for '-w' values for your connection and /proc/sys TCP
109values. BTW. in a LAN you have got generally RTT < 1 msec.
110%endif
111%if %{with hpn_none}
112It also includes an undocumented '-z' option which switches
113the cipher to none after authentication is completed. Data is
114still secured from tampering and corruption in transit through
115the use of the Message Authentication Code (MAC).
116This option will significantly reduce the number of cpu cycles used
117by the SSH/SCP process. This may allow some users to see significant
118improvement in (sniffable) data tranfer rates.
119%endif
120
121%description -l de.UTF-8
122OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
123ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
124verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
125über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
126andere TCP/IP Ports können ebenso über den sicheren Channel
127weitergeleitet werden.
128
129%description -l es.UTF-8
130SSH es un programa para accesar y ejecutar órdenes en computadores
131remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
132seguro entre dos servidores en una red insegura. Conexiones X11 y
133puertas TCP/IP arbitrárias también pueden ser usadas por el canal
134seguro.
135
136OpenSSH es el resultado del trabajo del equipo de OpenBSD para
137continuar la última versión gratuita de SSH, actualizándolo en
138términos de seguridad y recursos,así también eliminando todos los
139algoritmos patentados y colocándolos en bibliotecas separadas
140(OpenSSL).
141
142Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
143también el paquete openssh-clients u openssh-server o ambos.
144
145%description -l fr.UTF-8
146OpenSSH (Secure Shell) fournit un accès à un système distant. Il
147remplace telnet, rlogin, rexec et rsh, tout en assurant des
148communications cryptées securisées entre deux hôtes non fiabilisés sur
149un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
150arbitraires peuvent également être transmis sur le canal sécurisé.
151
152%description -l it.UTF-8
153OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
154Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
155sicure e crittate tra due host non fidati su una rete non sicura. Le
156connessioni X11 ad una porta TCP/IP arbitraria possono essere
157inoltrate attraverso un canale sicuro.
158
159%description -l pl.UTF-8
160Ssh (Secure Shell) to program służący do logowania się na zdalną
161maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
162zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
163pomiędzy dwoma hostami.
164
165Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
166klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
167co najmniej jeden z pakietów: openssh-clients lub openssh-server.
168%if %{with hpn} || %{with hpn_none}
169Ta wersja zawiera łaty z projektu High Performance SSH/SCP
170http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
171zwiększenie przepustowości transmisji dla szybkich połączeń
172z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
173odpowednie dla danego połączenia wartości parametru '-w' oraz
174opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
175%endif
176%if %{with hpn_none}
177Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
178za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
179Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
180stosowanie Message Authentication Code (MAC).
181Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
182procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
183na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
184%endif
185
186%description -l pt.UTF-8
187OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
188telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
189cifradas entre duas máquinas sem confiança mútua sobre uma rede
190insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
191reenviados pelo canal seguro.
192
193%description -l pt_BR.UTF-8
194SSH é um programa para acessar e executar comandos em máquinas
195remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
196seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
197TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
198
199OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
200última versão gratuita do SSH, atualizando-o em termos de segurança e
201recursos, assim como removendo todos os algoritmos patenteados e
202colocando-os em bibliotecas separadas (OpenSSL).
203
204Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
205também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
206
207%description -l ru.UTF-8
208Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
209машину и для выполнения команд на удаленной машине. Она предназначена
210для замены rlogin и rsh и обеспечивает безопасную шифрованную
211коммуникацию между двумя хостами в сети, являющейся небезопасной.
212Соединения X11 и любые порты TCP/IP могут также быть проведены через
213безопасный канал.
214
215OpenSSH - это переделка командой разработчиков OpenBSD последней
216свободной версии SSH, доведенная до современного состояния в терминах
217уровня безопасности и поддерживаемых возможностей. Все патентованные
218алгоритмы вынесены в отдельные библиотеки (OpenSSL).
219
220Этот пакет содержит файлы, необходимые как для клиента, так и для
221сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
222openssh-server, или оба пакета.
223
224%description -l uk.UTF-8
225Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
226машини та для виконання команд на віддаленій машині. Вона призначена
227для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
228між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
229довільні порти TCP/IP можуть також бути проведені через безпечний
230канал.
231
232OpenSSH - це переробка командою розробників OpenBSD останньої вільної
233версії SSH, доведена до сучасного стану в термінах рівня безпеки та
234підтримуваних можливостей. Всі патентовані алгоритми винесені до
235окремих бібліотек (OpenSSL).
236
237Цей пакет містить файли, необхідні як для клієнта, так і для сервера
238OpenSSH. Вам потрібно буде ще встановити openssh-clients,
239openssh-server, чи обидва пакети.
240
241%package clients
242Summary: OpenSSH Secure Shell protocol clients
243Summary(es.UTF-8): Clientes de OpenSSH
244Summary(pl.UTF-8): Klienci protokołu Secure Shell
245Summary(pt_BR.UTF-8): Clientes do OpenSSH
246Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
247Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
248Group: Applications/Networking
249Requires: %{name} = %{epoch}:%{version}-%{release}
250Provides: ssh-clients
251Obsoletes: ssh-clients
252
253%description clients
254Ssh (Secure Shell) a program for logging into a remote machine and for
255executing commands in a remote machine. It is intended to replace
256rlogin and rsh, and provide secure encrypted communications between
257two untrusted hosts over an insecure network. X11 connections and
258arbitrary TCP/IP ports can also be forwarded over the secure channel.
259
260OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
261it up to date in terms of security and features, as well as removing
262all patented algorithms to seperate libraries (OpenSSL).
263
264This package includes the clients necessary to make encrypted
265connections to SSH servers.
266
267%description clients -l es.UTF-8
268Este paquete incluye los clientes que se necesitan para hacer
269conexiones codificadas con servidores SSH.
270
271%description clients -l pl.UTF-8
272Ssh (Secure Shell) to program służący do logowania się na zdalną
273maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
274zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
275pomiędzy dwoma hostami.
276
277Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
278
279%description clients -l pt_BR.UTF-8
280Esse pacote inclui os clientes necessários para fazer conexões
281encriptadas com servidores SSH.
282
283%description clients -l ru.UTF-8
284Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
285машину и для выполнения команд на удаленной машине.
286
287Этот пакет содержит программы-клиенты, необходимые для установления
288зашифрованных соединений с серверами SSH.
289
290%description clients -l uk.UTF-8
291Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
292машини та для виконання команд на віддаленій машині.
293
294Цей пакет містить програми-клієнти, необхідні для встановлення
295зашифрованих з'єднань з серверами SSH.
296
297%package clients-agent-profile_d
298Summary: OpenSSH Secure Shell agent init script
299Summary(pl.UTF-8): Skrypt
300Summary(pt_BR.UTF-8): Clientes do OpenSSH
301Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
302Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
303Group: Applications/Networking
304Requires: %{name}-clients = %{epoch}:%{version}-%{release}
305
306%description clients-agent-profile_d
307profile.d scripts for starting SSH agent.
308
309%package clients-agent-xinitrc
310Summary: OpenSSH Secure Shell agent init script
311Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
312Group: Applications/Networking
313Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
314Requires: xinitrc
315
316%description clients-agent-xinitrc
317xinitrc scripts for starting SSH agent.
318
319
320%package server
321Summary: OpenSSH Secure Shell protocol server (sshd)
322Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
323Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
324Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
325Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
326Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
327Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
328Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
329Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
330Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
331Group: Networking/Daemons
332Requires(post): chkconfig >= 0.9
333Requires(post): grep
334Requires(post,preun): /sbin/chkconfig
335Requires(postun): /usr/sbin/userdel
336Requires(pre): /bin/id
337Requires(pre): /usr/sbin/useradd
338Requires: %{name} = %{epoch}:%{version}-%{release}
339Requires: /bin/login
340Requires: pam >= 0.99.7.1
341Requires: rc-scripts >= 0.4.0.18
342Requires: util-linux
343Provides: ssh-server
344Provides: user(sshd)
345
346%description server
347Ssh (Secure Shell) a program for logging into a remote machine and for
348executing commands in a remote machine. It is intended to replace
349rlogin and rsh, and provide secure encrypted communications between
350two untrusted hosts over an insecure network. X11 connections and
351arbitrary TCP/IP ports can also be forwarded over the secure channel.
352
353OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
354it up to date in terms of security and features, as well as removing
355all patented algorithms to seperate libraries (OpenSSL).
356
357This package contains the secure shell daemon. The sshd is the server
358part of the secure shell protocol and allows ssh clients to connect to
359your host.
360
361%description server -l de.UTF-8
362Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
363
364%description server -l es.UTF-8
365Este paquete contiene el servidor SSH. sshd es la parte servidor del
366protocolo secure shell y permite que clientes ssh se conecten a su
367servidor.
368
369%description server -l fr.UTF-8
370Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
371
372%description server -l it.UTF-8
373Questo pacchetto installa sshd, il server di OpenSSH.
374
375%description server -l pl.UTF-8
376Ssh (Secure Shell) to program służący do logowania się na zdalną
377maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
378zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
379pomiędzy dwoma hostami.
380
381Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
382ssh).
383
384%description server -l pt.UTF-8
385Este pacote intala o sshd, o servidor do OpenSSH.
386
387%description server -l pt_BR.UTF-8
388Esse pacote contém o servidor SSH. O sshd é a parte servidor do
389protocolo secure shell e permite que clientes ssh se conectem ao seu
390host.
391
392%description server -l ru.UTF-8
393Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
394машину и для выполнения команд на удаленной машине.
395
396Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
397часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
398вашим хостом.
399
400%description server -l uk.UTF-8
401Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
402машини та для виконання команд на віддаленій машині.
403
404Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
405частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
406з вашим хостом.
407
408%package gnome-askpass
409Summary: OpenSSH GNOME passphrase dialog
410Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
411Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
412Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
413Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
414Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
415Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
416Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
417Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
418Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
419Group: Applications/Networking
420Requires: %{name} = %{epoch}:%{version}-%{release}
421Obsoletes: openssh-askpass
422Obsoletes: ssh-askpass
423Obsoletes: ssh-extras
424
425%description gnome-askpass
426Ssh (Secure Shell) a program for logging into a remote machine and for
427executing commands in a remote machine. It is intended to replace
428rlogin and rsh, and provide secure encrypted communications between
429two untrusted hosts over an insecure network. X11 connections and
430arbitrary TCP/IP ports can also be forwarded over the secure channel.
431
432OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
433it up to date in terms of security and features, as well as removing
434all patented algorithms to seperate libraries (OpenSSL).
435
436This package contains the GNOME passphrase dialog.
437
438%description gnome-askpass -l es.UTF-8
439Este paquete contiene un programa que abre una caja de diálogo para
440entrada de passphrase en GNOME.
441
442%description gnome-askpass -l pl.UTF-8
443Ssh (Secure Shell) to program służący do logowania się na zdalną
444maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
445zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
446pomiędzy dwoma hostami.
447
448Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
449
450%description gnome-askpass -l pt_BR.UTF-8
451Esse pacote contém um programa que abre uma caixa de diálogo para
452entrada de passphrase no GNOME.
453
454%description gnome-askpass -l ru.UTF-8
455Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
456машину и для выполнения команд на удаленной машине.
457
458Этот пакет содержит диалог ввода ключевой фразы для использования под
459GNOME.
460
461%description gnome-askpass -l uk.UTF-8
462Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
463машини та для виконання команд на віддаленій машині.
464
465Цей пакет містить діалог вводу ключової фрази для використання під
466GNOME.
467
468%prep
469%setup -q
470%patch0 -p1
471%patch2 -p1
472%patch3 -p1
473%patch4 -p1
474%{?with_ldap:%patch5 -p1}
475%{?with_kerberos5:%patch6 -p1}
476#%patch7 -p1
477%patch8 -p1
478%patch9 -p1
479%{?with_hpn:%patch10 -p1}
480%{?with_hpn_none:%patch11 -p1}
481%patch12 -p1
482
483%build
484cp /usr/share/automake/config.sub .
485%{__aclocal}
486%{__autoconf}
487%{?with_chroot:CPPFLAGS="-DCHROOT"}
488%configure \
489 PERL=%{__perl} \
490 --with-dns \
491 --with-pam \
492 --with-mantype=man \
493 --with-md5-passwords \
494 --with-ipaddr-display \
495 %{?with_libedit:--with-libedit} \
496 --with-4in6 \
497 --disable-suid-ssh \
498 --with-tcp-wrappers \
499 %{?with_ldap:--with-libs="-lldap -llber"} \
500 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
501 %{?with_kerberos5:--with-kerberos5} \
502 --with-privsep-path=%{_privsepdir} \
503 --with-pid-dir=%{_localstatedir}/run \
504 --with-xauth=/usr/bin/xauth \
505 --enable-utmpx \
506 --enable-wtmpx
507
508echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
509
510%{__make}
511
512cd contrib
513%if %{with gnome}
514%{__make} gnome-ssh-askpass1 \
515 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
516%endif
517%if %{with gtk}
518%{__make} gnome-ssh-askpass2 \
519 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
520%endif
521
522%install
523rm -rf $RPM_BUILD_ROOT
524install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
525 $RPM_BUILD_ROOT%{_libexecdir}/ssh
526install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
527
528%{__make} install \
529 DESTDIR=$RPM_BUILD_ROOT
530
531install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
532install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
533install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
534install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
535install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
536install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
537install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d
538ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
539install %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}
540
541bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
542
543%if %{with gnome}
544install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
545%endif
546%if %{with gtk}
547install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
548%endif
549%if %{with gnome} || %{with gtk}
550cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
551#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
552EOF
553cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
554#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
555EOF
556ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
557%endif
558
559rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
560echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
561
562touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
563
564%if "%{_lib}" != "lib"
565find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 sed -i -e 's#%{_prefix}/lib#%{_libdir}#'
566%endif
567
568cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
569#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
570EOF
571
572%clean
573rm -rf $RPM_BUILD_ROOT
574
575%post clients
576%env_update
577
578%postun clients
579%env_update
580
581%post gnome-askpass
582%env_update
583
584%postun gnome-askpass
585%env_update
586
587%pre server
588%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
589
590%post server
591/sbin/chkconfig --add sshd
592%service sshd reload "openssh daemon"
593if ! grep -qs ssh /etc/security/passwd.conf ; then
594 umask 022
595 echo "ssh" >> /etc/security/passwd.conf
596fi
597
598%preun server
599if [ "$1" = "0" ]; then
600 %service sshd stop
601 /sbin/chkconfig --del sshd
602fi
603
604%postun server
605if [ "$1" = "0" ]; then
606 %userremove sshd
607fi
608
609%files
610%defattr(644,root,root,755)
611%doc *.RNG TODO README OVERVIEW CREDITS Change*
612%attr(755,root,root) %{_bindir}/ssh-key*
613%{_mandir}/man1/ssh-key*.1*
614%dir %{_sysconfdir}
615%dir %{_libexecdir}
616
617%files clients
618%defattr(644,root,root,755)
619%attr(755,root,root) %{_bindir}/ssh
620%attr(755,root,root) %{_bindir}/slogin
621%attr(755,root,root) %{_bindir}/sftp
622%attr(755,root,root) %{_bindir}/ssh-agent
623%attr(755,root,root) %{_bindir}/ssh-add
624%attr(755,root,root) %{_bindir}/scp
625%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
626%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
627%{_mandir}/man1/scp.1*
628%{_mandir}/man1/ssh.1*
629%{_mandir}/man1/slogin.1*
630%{_mandir}/man1/sftp.1*
631%{_mandir}/man1/ssh-agent.1*
632%{_mandir}/man1/ssh-add.1*
633%{_mandir}/man5/ssh_config.5*
634%lang(it) %{_mandir}/it/man1/ssh.1*
635%lang(it) %{_mandir}/it/man5/ssh_config.5*
636%lang(pl) %{_mandir}/pl/man1/scp.1*
637%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
638
639# for host-based auth (suid required for accessing private host key)
640#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
641#%{_mandir}/man8/ssh-keysign.8*
642
643%files clients-agent-profile_d
644%defattr(644,root,root,755)
645%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
646%attr(755,root,root) /etc/profile.d/ssh-agent.sh
647
648%files clients-agent-xinitrc
649%defattr(644,root,root,755)
650%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
651
652%files server
653%defattr(644,root,root,755)
654%attr(755,root,root) %{_sbindir}/sshd
655%attr(755,root,root) %{_libexecdir}/sftp-server
656%attr(755,root,root) %{_libexecdir}/ssh-keysign
657%{_mandir}/man8/sshd.8*
658%{_mandir}/man8/sftp-server.8*
659%{_mandir}/man8/ssh-keysign.8*
660%{_mandir}/man5/sshd_config.5*
661%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
662%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
663%attr(640,root,root) %{_sysconfdir}/moduli
664%attr(754,root,root) /etc/rc.d/init.d/sshd
665%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
666%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
667
668%if %{with gnome} || %{with gtk}
669%files gnome-askpass
670%defattr(644,root,root,755)
671%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
672%dir %{_libexecdir}/ssh
673%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
674%attr(755,root,root) %{_libexecdir}/ssh-askpass
675%endif
This page took 0.038803 seconds and 4 git commands to generate.