]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- translated kloczkish into english
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1Summary: OpenSSH free Secure Shell (SSH) implementation
2Name: openssh
3Version: 1.2.2p1
4Release: 1
5License: BSD
6Group: Applications/Networking
7Group(pl): Aplikacje/Sieciowe
8Source0: http://violet.ibs.com.au/openssh/files/%{name}-%{version}.tar.gz
9Source1: opensshd.conf
10Source2: openssh.conf
11Source3: opensshd.init
12Source4: opensshd.pamd
13Source5: openssh.sysconfig
14Source6: passwd.pamd
15Patch0: openssh-PAM_NEW_AUTHTOK.patch
16Patch1: openssh-libwrap.patch
17Patch2: openssh-linux.patch
18BuildRequires: openssl-devel >= 0.9.4-2
19BuildRequires: zlib-devel
20BuildRequires: pam-devel
21BuildRequires: XFree86-devel
22BuildRequires: gnome-libs-devel
23BuildRoot: /tmp/%{name}-%{version}-root
24Obsoletes: ssh < %{version}, ssh > %{version}
25
26%define _sysconfdir /etc/ssh
27
28%description
29Ssh (Secure Shell) a program for logging into a remote machine and for
30executing commands in a remote machine. It is intended to replace rlogin and
31rsh, and provide secure encrypted communications between two untrusted hosts
32over an insecure network. X11 connections and arbitrary TCP/IP ports can
33also be forwarded over the secure channel.
34
35OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
36to date in terms of security and features, as well as removing all patented
37algorithms to seperate libraries (OpenSSL).
38
39This package includes the core files necessary for both the OpenSSH
40client and server. To make this package useful, you should also
41install openssh-clients, openssh-server, or both.
42
43%package clients
44Summary: OpenSSH Secure Shell protocol clients
45Requires: openssh
46Group: Applications/Networking
47Group(pl): Aplikacje/Sieciowe
48Obsoletes: ssh-clients < %{version}, ssh-clients > %{version}
49Requires: %{name} = %{version}
50
51%description clients
52Ssh (Secure Shell) a program for logging into a remote machine and for
53executing commands in a remote machine. It is intended to replace rlogin and
54rsh, and provide secure encrypted communications between two untrusted hosts
55over an insecure network. X11 connections and arbitrary TCP/IP ports can
56also be forwarded over the secure channel.
57
58OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
59to date in terms of security and features, as well as removing all patented
60algorithms to seperate libraries (OpenSSL).
61
62This package includes the clients necessary to make encrypted connections to
63SSH servers.
64
65%package server
66Summary: OpenSSH Secure Shell protocol server (sshd)
67Requires: openssh chkconfig >= 0.9
68Group: Networking/Daemons
69Group(pl): Sieciowe/Serwery
70Obsoletes: ssh-server < %{version}, ssh-server > %{version}
71Requires: rc-scripts
72Requires: /bin/login
73Requires: util-linux
74Prereq: %{name} = %{version}
75
76%description server
77Ssh (Secure Shell) a program for logging into a remote machine and for
78executing commands in a remote machine. It is intended to replace rlogin and
79rsh, and provide secure encrypted communications between two untrusted hosts
80over an insecure network. X11 connections and arbitrary TCP/IP ports can
81also be forwarded over the secure channel.
82
83OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
84to date in terms of security and features, as well as removing all patented
85algorithms to seperate libraries (OpenSSL).
86
87This package contains the secure shell daemon. The sshd is the server part
88of the secure shell protocol and allows ssh clients to connect to your host.
89
90%package gnome-askpass
91Summary: OpenSSH GNOME passphrase dialog
92Group: Applications/Networking
93Group(pl): Aplikacje/Sieciowe
94Requires: %{name} = %{version}
95Obsoletes: ssh-extras < %{version}, ssh-extras > %{version}
96Obsoletes: ssh-askpass < %{version}, ssh-askpass > %{version}
97Obsoletes: openssh-askpass < %{version}, openssh-askpass > %{version}
98
99%description gnome-askpass
100Ssh (Secure Shell) a program for logging into a remote machine and for
101executing commands in a remote machine. It is intended to replace rlogin
102and rsh, and provide secure encrypted communications between two untrusted
103hosts over an insecure network. X11 connections and arbitrary TCP/IP ports
104can also be forwarded over the secure channel.
105
106OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
107to date in terms of security and features, as well as removing all patented
108algorithms to seperate libraries (OpenSSL).
109
110This package contains the GNOME passphrase dialog.
111
112%prep
113%setup -q
114%patch0 -p1
115%patch1 -p1
116%patch2 -p1
117
118%build
119autoconf
120%configure \
121 --with-gnome-askpass \
122 --with-tcp-wrappers \
123 --with-md5-passwords \
124 --with-ipaddr-display \
125 --enable-ipv6 \
126 --enable-log-auth
127
128# with ipv4-default sshd can't listen on IPv6 and IPv4 sockets
129# --with-ipv4-default \
130# broken options
131# --without-kerberos4 \
132# --without-afs \
133# --without-skey
134
135echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
136
137make
138
139%install
140rm -rf $RPM_BUILD_ROOT
141
142install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security}}
143
144make install DESTDIR="$RPM_BUILD_ROOT"
145
146install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
147install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
148install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
149install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
150install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
151install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
152
153mv -f $RPM_BUILD_ROOT%{_libexecdir}/ssh/gnome-ssh-askpass \
154 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
155
156gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
157 $RPM_BUILD_ROOT/%{_mandir}/man*/*
158
159touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
160
161%clean
162rm -rf $RPM_BUILD_ROOT
163
164%post server
165/sbin/chkconfig --add sshd
166if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
167 /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' 1>&2
168fi
169if [ -f /var/lock/subsys/sshd ]; then
170 /etc/rc.d/init.d/sshd restart 1>&2
171fi
172if ! grep ssh /etc/security/passwd.conf >/dev/null 2>&1 ; then
173 echo "ssh" >> /etc/security/passwd.conf
174fi
175
176%preun server
177if [ "$1" = 0 ]; then
178 if [ -f /var/lock/subsys/sshd ]; then
179 /etc/rc.d/init.d/sshd stop 1>&2
180 fi
181 /sbin/chkconfig --del sshd
182fi
183
184%files
185%defattr(644,root,root,755)
186%doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
187%attr(755,root,root) %{_bindir}/ssh-keygen
188%{_mandir}/man1/ssh-keygen.1*
189%dir %{_sysconfdir}
190
191%files clients
192%defattr(644,root,root,755)
193# suid root ?
194#%attr(4755,root,root) %{_bindir}/ssh
195%attr(0755,root,root) %{_bindir}/ssh
196%attr(0755,root,root) %{_bindir}/ssh-agent
197%attr(0755,root,root) %{_bindir}/ssh-add
198#%attr(0755,root,root) %{_bindir}/slogin
199%attr(755,root,root) %{_bindir}/scp
200%{_mandir}/man1/scp.1*
201%{_mandir}/man1/ssh.1*
202%{_mandir}/man1/ssh-agent.1*
203%{_mandir}/man1/ssh-add.1*
204#%{_mandir}/man1/slogin.1
205%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
206
207%files server
208%defattr(644,root,root,755)
209%attr(755,root,root) %{_sbindir}/sshd
210%{_mandir}/man8/sshd.8*
211%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
212%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
213%attr(754,root,root) /etc/rc.d/init.d/sshd
214%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
215%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.sshd
216
217%files gnome-askpass
218%defattr(644,root,root,755)
219%dir %{_libexecdir}/ssh
220%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.038539 seconds and 4 git commands to generate.