]> git.pld-linux.org Git - packages/nginx.git/blame_incremental - nginx.spec
up to 1.26.1 (fixes CVE-2024-32760 CVE-2024-31079 CVE-2024-35200 CVE-2024-34161)
[packages/nginx.git] / nginx.spec
... / ...
CommitLineData
1# TODO
2# - /etc/sysconfig/nginx file
3# - missing perl build/install requires
4# - add njs: https://nginx.org/en/docs/njs/
5#
6# Conditional build for nginx:
7# Features
8%bcond_with debug # enable debug logging: http://nginx.org/en/docs/debugging_log.html
9%bcond_without file_aio # file AIO support
10%bcond_without threads # thread pool support
11# Modules
12%bcond_without addition # http addition module
13%bcond_without auth_request # auth_request module
14%bcond_without dav # WebDAV
15%bcond_without flv # http FLV module
16%bcond_without gd # without http image filter module
17%bcond_without geoip # without http geoip module and stream geoip module
18%bcond_without http2 # HTTP/2 module
19%bcond_without http3 # HTTP/3 module
20%bcond_without mail # don't build imap/mail proxy
21%bcond_without perl # don't build with perl module
22%bcond_without poll # poll module
23%bcond_without realip # real ip (behind proxy)
24%bcond_without select # select module
25%bcond_without ssl # ssl support and http ssl module
26%bcond_without stream # TCP/UDP proxy module
27%bcond_without stub_status # http stub status module
28%bcond_without sub # ngx_http_sub_module
29%bcond_without xslt # without http xslt module
30%bcond_with http_browser # http browser module (header "User-agent" parser)
31%bcond_without modsecurity # modsecurity module
32%bcond_with rtmp # rtmp support
33%bcond_without vts # virtual host traffic status module
34%bcond_without headers_more # headers more module
35
36%ifarch x32
37%undefine with_rtsig
38%endif
39
40%define ssl_version 1.0.2
41%define rtmp_version 1.2.2
42%define vts_version 0.2.2
43%define headers_more_version 0.37
44%define modsecurity_version 1.0.3
45%define http_cache_purge_version 2.5.3
46
47Summary: High perfomance HTTP and reverse proxy server
48Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
49# nginx mainline is recommended by nginx team: https://www.nginx.com/blog/nginx-1-6-1-7-released/
50# http://nginx.org/en/download.html
51Name: nginx
52Version: 1.26.1
53Release: 1
54License: BSD-like
55Group: Networking/Daemons/HTTP
56Source0: https://nginx.org/download/%{name}-%{version}.tar.gz
57# Source0-md5: 56b83c172c7f2fd09d59123bc28ff2b1
58Source1: https://nginx.org/favicon.ico
59# Source1-md5: 72e228c3809db53da8a884b6676ed36a
60Source2: proxy.conf
61Source3: %{name}.logrotate
62Source4: %{name}.mime
63Source6: %{name}.monitrc
64Source7: %{name}.init
65Source14: %{name}.conf
66Source17: %{name}-mime.types.sh
67Source18: %{name}.service
68Source33: https://github.com/SpiderLabs/ModSecurity-nginx/releases/download/v%{modsecurity_version}/modsecurity-%{name}-v%{modsecurity_version}.tar.gz
69# Source33-md5: b85e1996f81b51a06a32e73b3be4709d
70Source101: https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
71# Source101-md5: 9bb7a06aede38d9e36ad13dc1354d8f9
72Source102: https://github.com/vozlt/nginx-module-vts/archive/v%{vts_version}.tar.gz
73# Source102-md5: aeb08aec8dc89e45fb9411be76850d63
74Source103: https://github.com/openresty/headers-more-nginx-module/archive/v%{headers_more_version}.tar.gz
75# Source103-md5: 21782630f592fd2e046df96de30923ad
76# https://github.com/nginx-modules/ngx_cache_purge
77Source104: https://github.com/nginx-modules/ngx_cache_purge/archive/refs/tags/%{http_cache_purge_version}.tar.gz
78# Source104-md5: bf92baae08e4c850825a8543c7d4aaa8
79Patch0: %{name}-no-Werror.patch
80Patch1: modsecurity-gcc14.patch
81URL: https://nginx.org/
82BuildRequires: mailcap
83BuildRequires: pcre2-8-devel
84BuildRequires: rpmbuild(macros) >= 1.644
85BuildRequires: zlib-devel
86%if %{with geoip}
87BuildRequires: GeoIP-devel
88%endif
89%if %{with gd}
90BuildRequires: gd-devel
91%endif
92%if %{with modsecurity}
93BuildRequires: lua-devel
94BuildRequires: libmodsecurity-devel
95%endif
96%if %{with perl}
97BuildRequires: perl-CGI
98BuildRequires: perl-devel
99BuildRequires: python3
100BuildRequires: rpm-perlprov
101%endif
102%if %{with ssl}
103BuildRequires: openssl-devel >= %{ssl_version}
104Requires: openssl >= %{ssl_version}
105%endif
106%if %{with xslt}
107BuildRequires: libxslt-devel
108%endif
109Provides: group(http)
110Provides: group(nginx)
111Provides: user(nginx)
112Provides: webserver
113Provides: webserver(access)
114Provides: webserver(alias)
115Provides: webserver(auth)
116Provides: webserver(expires)
117Provides: webserver(headers)
118Provides: webserver(indexfile)
119Provides: webserver(log)
120Provides: webserver(mime)
121Provides: webserver(reqtimeout)
122Provides: webserver(rewrite)
123Provides: webserver(setenv)
124Conflicts: logrotate < 3.8.0
125Requires(post,preun): /sbin/chkconfig
126Requires(post,preun,postun): systemd-units >= 38
127Requires(postun): /usr/sbin/groupdel
128Requires(postun): /usr/sbin/userdel
129Requires(pre): /bin/id
130Requires(pre): /usr/bin/getgid
131Requires(pre): /usr/sbin/groupadd
132Requires(pre): /usr/sbin/useradd
133Requires: rc-scripts >= 0.2.0
134Requires: systemd-units >= 38
135Suggests: vim-syntax-nginx
136Obsoletes: nginx-common < 1.13.3
137Obsoletes: nginx-light < 1.13.3
138Obsoletes: nginx-standard < 1.13.3
139Conflicts: rpm < 4.4.2-0.2
140BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
141
142%define _sysconfdir /etc/%{name}
143%define _nginxdir /home/services/%{name}
144
145# minimizing restarts logics. we restart webserver:
146#
147# 1. at the end of transaction. (posttrans, feature from rpm 4.4.2)
148# 2. first install of module (post: $1 = 1)
149# 2. uninstall of module (postun: $1 == 0)
150#
151# the strict internal deps between modules and
152# main package are very important for all this to work.
153
154# restart webserver at the end of transaction
155
156%define restart_webserver \
157 %systemd_post %{name}.service \
158 %service %{name} force-reload \
159 %{nil}
160
161# macro called at module post scriptlet
162%define module_post \
163if [ "$1" = "1" ]; then \
164 %restart_webserver \
165fi
166
167# macro called at module postun scriptlet
168%define module_postun \
169if [ "$1" = "0" ]; then \
170 %restart_webserver \
171fi
172
173# it's sooo annoying to write them
174%define module_scripts() \
175%post %1 \
176%module_post \
177\
178%postun %1 \
179%module_postun
180
181%description
182nginx ("engine x") is a high-performance HTTP server and reverse
183proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
184Sysoev for Rambler.ru, Russia's second-most visited website, where it
185has been running in production for over two and a half years. Igor has
186released the source code under a BSD-like license. Although still in
187beta, nginx is known for its stability, rich feature set, simple
188configuration, and low resource consumption.
189
190%description -l pl.UTF-8
191nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
192a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
193potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
194odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
195opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
196fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
197prostej konfiguracji oraz małej "zasobożerności".
198
199%package mod_headers_more
200Summary: Nginx HTTP headers more module
201Group: Daemons
202Requires: %{name} = %{version}-%{release}
203
204%description mod_headers_more
205Set and clear input and output headers...more than "add".
206
207%package mod_http_geoip
208Summary: Nginx HTTP geoip module
209Group: Daemons
210Requires: %{name} = %{version}-%{release}
211Requires: GeoIP
212
213%description mod_http_geoip
214Nginx HTTP geoip module.
215
216%package mod_stream_geoip
217Summary: Nginx stream geoip module
218Group: Daemons
219Requires: %{name} = %{version}-%{release}
220Requires: %{name}-mod_stream = %{version}-%{release}
221Requires: GeoIP
222
223%description mod_stream_geoip
224Nginx stream geoip module.
225
226%package mod_http_image_filter
227Summary: Nginx HTTP image filter module
228Group: Daemons
229Requires: %{name} = %{version}-%{release}
230
231%description mod_http_image_filter
232Nginx HTTP image filter module.
233
234%package mod_http_perl
235Summary: Nginx HTTP Perl module
236Group: Networking/Daemons/HTTP
237Requires: %{name} = %{version}-%{release}
238
239%description mod_http_perl
240Nginx HTTP Perl module.
241
242%package mod_http_xslt_filter
243Summary: Nginx XSLT module
244Group: Daemons
245Requires: %{name} = %{version}-%{release}
246
247%description mod_http_xslt_filter
248Nginx XSLT module.
249
250%package mod_mail
251Summary: Nginx mail module
252Group: Networking/Daemons/HTTP
253Requires: %{name} = %{version}-%{release}
254
255%description mod_mail
256Nginx mail module.
257
258%package mod_vts
259Summary: Nginx virtual host traffic status module
260Group: Networking/Daemons/HTTP
261Requires: %{name} = %{version}-%{release}
262
263%description mod_vts
264Nginx virtual host traffic status module.
265
266%package mod_stream
267Summary: Nginx stream modules
268Group: Daemons
269Requires: %{name} = %{version}-%{release}
270
271%description mod_stream
272Nginx stream modules.
273
274%package mod_http_cache_purge
275Summary: Nginx cache purge module
276Group: Daemons
277Requires: %{name} = %{version}-%{release}
278
279%description mod_http_cache_purge
280`ngx_cache_purge` is `nginx` module which adds ability to purge
281content from `FastCGI`, `proxy`, `SCGI` and `uWSGI` caches.
282
283%package mod_http_modsecurity
284Summary: Nginx modsecurity module
285Group: Daemons
286Requires: %{name} = %{version}-%{release}
287
288%description mod_http_modsecurity
289The ModSecurity-nginx connector takes the form of an nginx module. The
290module simply serves as a layer of communication between nginx and
291ModSecurity.
292
293%package -n monit-rc-nginx
294Summary: nginx support for monit
295Summary(pl.UTF-8): Wsparcie nginx dla monit
296Group: Applications/System
297Requires: %{name} = %{version}-%{release}
298Requires: monit
299
300%description -n monit-rc-nginx
301monitrc file for monitoring nginx webserver.
302
303%description -n monit-rc-nginx -l pl.UTF-8
304Plik monitrc do monitorowania serwera WWW nginx.
305
306%prep
307%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a33} %{?with_vts:-a102} %{?with_headers_more:-a103} -a104
308%patch0 -p0
309%{?with_modsecurity:%patch1 -p1 -d modsecurity-nginx-v%{modsecurity_version}}
310
311%if %{with rtmp}
312mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
313%endif
314
315%if %{with vts}
316mv nginx-module-vts-%{vts_version} nginx-vts-module
317%endif
318
319%if %{with headers_more}
320mv headers-more-nginx-module-%{headers_more_version} nginx-headers-more-module
321%endif
322
323mv ngx_cache_purge-* ngx_cache_purge
324
325# build mime.types.conf
326#sh %{SOURCE17} /etc/mime.types
327
328%build
329# NB: not autoconf generated configure
330cp -f configure auto/
331
332./configure \
333 --prefix=%{_prefix} \
334 --modules-path=%{_libdir}/%{name}/modules \
335 --sbin-path=%{_sbindir}/%{name} \
336 --conf-path=%{_sysconfdir}/%{name}.conf \
337 --error-log-path=%{_localstatedir}/log/%{name}/error.log \
338 --http-log-path=%{_localstatedir}/log/%{name}/access.log \
339 --pid-path=%{_localstatedir}/run/%{name}.pid \
340 --lock-path=%{_localstatedir}/lock/subsys/%{name} \
341 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
342 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
343 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
344 --http-uwsgi-temp-path=%{_localstatedir}/cache/%{name}/uwsgi_temp \
345 --http-scgi-temp-path=%{_localstatedir}/cache/%{name}/scgi_temp \
346 --user=nginx \
347 --group=nginx \
348 --with-compat \
349 %{?with_select:--with-select_module} \
350 %{?with_poll:--with-poll_module} \
351 %{?with_rtsig:--with-rtsig_module} \
352 %{?with_perl:--with-http_perl_module=dynamic} \
353 %{?with_gd:--with-http_image_filter_module=dynamic} \
354 %{?with_xslt:--with-http_xslt_module=dynamic} \
355 %{?with_geoip:--with-http_geoip_module=dynamic} \
356 %{?with_geoip:--with-stream_geoip_module=dynamic} \
357%if %{with mail}
358 --with-mail=dynamic \
359 --with-mail_ssl_module \
360%endif
361%if %{with stream}
362 --with-stream=dynamic \
363 --with-stream_ssl_module \
364%endif
365 --with-cc="%{__cc}" \
366 --with-cc-opt="%{rpmcflags}" \
367 --with-ld-opt="%{rpmldflags}" \
368 %{?with_debug:--with-debug} \
369 %{?with_addition:--with-http_addition_module} \
370 %{?with_dav:--with-http_dav_module} \
371 %{?with_flv:--with-http_flv_module} \
372 %{?with_sub:--with-http_sub_module} \
373 %{?with_realip:--with-http_realip_module} \
374 %{?with_stub_status:--with-http_stub_status_module} \
375 %{?with_ssl:--with-http_ssl_module} \
376 %{!?with_http_browser:--without-http_browser_module} \
377 --add-dynamic-module=./ngx_cache_purge \
378 %{?with_headers_more:--add-dynamic-module=./nginx-headers-more-module} \
379 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
380 %{?with_vts:--add-dynamic-module=./nginx-vts-module} \
381 %{?with_auth_request:--with-http_auth_request_module} \
382 %{?with_threads:--with-threads} \
383 %{?with_http2:--with-http_v2_module} \
384 %{?with_http3:--with-http_v3_module} \
385 %{?with_modsecurity:--add-dynamic-module=modsecurity-nginx-v%{modsecurity_version}} \
386 --with-http_secure_link_module \
387 %{?with_file_aio:--with-file-aio} \
388 %{nil}
389
390%{__make}
391
392%install
393rm -rf $RPM_BUILD_ROOT
394install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
395 $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
396 $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
397 $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
398 $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
399 $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{conf,modules,vhosts,webapps}.d} \
400 $RPM_BUILD_ROOT%{_sysconfdir}/snippets \
401 $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
402 $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
403
404%{__make} install \
405 INSTALLDIRS=vendor \
406 DESTDIR=$RPM_BUILD_ROOT
407
408%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
409
410cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
411cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
412cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
413install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
414
415cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
416cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
417cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
418rm -r $RPM_BUILD_ROOT%{_prefix}/html
419cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
420cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
421cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
422
423load_module() {
424 local module=ngx_${1}_module.so conffile=mod_$1.conf
425 printf 'load_module "%{_libdir}/%{name}/modules/%s";' "$module" \
426 > $RPM_BUILD_ROOT%{_sysconfdir}/modules.d/$conffile
427}
428
429%if %{with perl}
430%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
431%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
432load_module http_perl
433%endif
434
435%if %{with geoip}
436load_module http_geoip
437load_module stream_geoip
438%endif
439%if %{with gd}
440load_module http_image_filter
441%endif
442%if %{with xslt}
443load_module http_xslt_filter
444%endif
445%if %{with mail}
446load_module mail
447%endif
448%{?with_vts:load_module http_vhost_traffic_status}
449%{?with_headers_more:load_module http_headers_more_filter}
450%if %{with stream}
451load_module stream
452%endif
453%if %{with modsecurity}
454load_module http_modsecurity
455%endif
456load_module http_cache_purge
457
458%clean
459rm -rf $RPM_BUILD_ROOT
460
461%pre
462%groupadd -r -g 213 %{name}
463%groupadd -g 51 http
464%useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
465%addusertogroup %{name} http
466
467%post
468for a in access.log error.log; do
469 if [ ! -f /var/log/%{name}/$a ]; then
470 umask 022
471 touch /var/log/%{name}/$a
472 chown nginx:nginx /var/log/%{name}/$a
473 chmod 644 /var/log/%{name}/$a
474 fi
475done
476/sbin/chkconfig --add %{name}
477
478%posttrans
479%restart_webserver
480
481%preun
482if [ "$1" = "0" ];then
483 %service %{name} stop
484 /sbin/chkconfig --del %{name}
485fi
486%systemd_preun %{name}.service
487
488%postun
489if [ "$1" = "0" ]; then
490 %userremove %{name}
491 %groupremove %{name}
492fi
493%systemd_reload
494
495%module_scripts mod_http_geoip
496%module_scripts mod_http_image_filter
497%module_scripts mod_http_perl
498%module_scripts mod_http_xslt_filter
499%module_scripts mod_mail
500%module_scripts mod_vts
501%module_scripts mod_headers_more
502%module_scripts mod_stream
503%module_scripts mod_stream_geoip
504%module_scripts mod_http_cache_purge
505
506%files
507%defattr(644,root,root,755)
508%doc CHANGES LICENSE README html/index.html conf/nginx.conf
509%doc %lang(ru) CHANGES.ru
510%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
511%attr(754,root,root) /etc/rc.d/init.d/%{name}
512%dir %attr(750,root,nginx) %{_sysconfdir}
513%dir %{_sysconfdir}/conf.d
514%dir %{_sysconfdir}/modules.d
515%dir %{_sysconfdir}/snippets
516%dir %{_sysconfdir}/vhosts.d
517%dir %{_sysconfdir}/webapps.d
518%attr(640,root,root) %{_sysconfdir}/mime.types
519%attr(640,root,root) %{_sysconfdir}/koi-utf
520%attr(640,root,root) %{_sysconfdir}/koi-win
521%attr(640,root,root) %{_sysconfdir}/win-utf
522%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.conf
523%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
524%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
525%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
526%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
527%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
528%attr(755,root,root) %{_sbindir}/%{name}
529%dir %{_libdir}/%{name}
530%dir %{_libdir}/%{name}/modules
531%{systemdunitdir}/%{name}.service
532
533%attr(750,nginx,logs) %dir /var/log/archive/%{name}
534%attr(750,nginx,logs) /var/log/%{name}
535%attr(770,root,nginx) /var/cache/%{name}
536
537%dir %{_nginxdir}
538%dir %{_nginxdir}/cgi-bin
539%dir %{_nginxdir}/html
540%dir %{_nginxdir}/errors
541%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
542%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
543
544%if %{with geoip}
545%files mod_http_geoip
546%defattr(644,root,root,755)
547%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_geoip.conf
548%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_geoip_module.so
549
550%files mod_stream_geoip
551%defattr(644,root,root,755)
552%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream_geoip.conf
553%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_geoip_module.so
554%endif
555
556%if %{with gd}
557%files mod_http_image_filter
558%defattr(644,root,root,755)
559%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_image_filter.conf
560%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_image_filter_module.so
561%endif
562
563%if %{with perl}
564%files mod_http_perl
565%defattr(644,root,root,755)
566%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_perl.conf
567%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
568%dir %{perl_vendorarch}/auto/%{name}
569%attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
570%{perl_vendorarch}/%{name}.pm
571%{_mandir}/man3/nginx.3pm*
572%endif
573
574%if %{with xslt}
575%files mod_http_xslt_filter
576%defattr(644,root,root,755)
577%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_xslt_filter.conf
578%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_xslt_filter_module.so
579%endif
580
581%if %{with mail}
582%files mod_mail
583%defattr(644,root,root,755)
584%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_mail.conf
585%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
586%endif
587
588%if %{with headers_more}
589%files mod_headers_more
590%defattr(644,root,root,755)
591%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_headers_more_filter.conf
592%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_headers_more_filter_module.so
593%endif
594
595%if %{with vts}
596%files mod_vts
597%defattr(644,root,root,755)
598%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_vhost_traffic_status.conf
599%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_vhost_traffic_status_module.so
600%endif
601
602%if %{with stream}
603%files mod_stream
604%defattr(644,root,root,755)
605%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream.conf
606%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_module.so
607%endif
608
609%files mod_http_cache_purge
610%defattr(644,root,root,755)
611%doc ngx_cache_purge/{CHANGES,README.md}
612%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_cache_purge.conf
613%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_cache_purge_module.so
614
615%files mod_http_modsecurity
616%defattr(644,root,root,755)
617%doc ngx_cache_purge/{CHANGES,README.md}
618%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_modsecurity.conf
619%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_modsecurity_module.so
620
621%files -n monit-rc-nginx
622%defattr(644,root,root,755)
623%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.03262 seconds and 5 git commands to generate.