]> git.pld-linux.org Git - packages/nginx.git/blame_incremental - nginx.spec
- sufficient optflags come from rpm, no need for -with-cpu-opt
[packages/nginx.git] / nginx.spec
... / ...
CommitLineData
1# TODO
2# - fix sysconfdir duplicates
3# - /etc/sysconfig/nginx file
4# - missing perl build/install requires
5# - nginx should have own group (and work with it) or use http group ?
6#
7# Conditional build for nginx:
8%bcond_without light # don't build light version
9%bcond_without mail # don't build imap/mail proxy
10%bcond_without perl # don't build with perl module
11%bcond_without addition # adds module
12%bcond_without dav # WebDAV
13%bcond_without flv # FLV stream
14%bcond_without sub # ngx_http_sub_module
15%bcond_without poll # poll
16%bcond_without realip # real ip (behind proxy)
17%bcond_without rtsig # rtsig
18%bcond_without select # select
19%bcond_without status # stats module
20%bcond_without ssl # ssl support
21%bcond_with http_browser # header "User-agent" parser
22#
23Summary: High perfomance HTTP and reverse proxy server
24Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
25Name: nginx
26Version: 0.5.33
27Release: 0.8
28License: BSD-like
29Group: Networking/Daemons
30Source0: http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
31# Source0-md5: a78be74b4fd8e009545ef02488fcac86
32Source1: http://www.nginx.eu/favicon.ico
33# Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
34Source2: http://www.nginx.eu/download/proxy.conf
35# Source2-md5: f5263ae01c2edb18f46d5d1df2d3a5cd
36Source3: %{name}.logrotate
37Source4: %{name}.mime
38Source5: %{name}-light.conf
39Source6: %{name}-light.monitrc
40Source7: %{name}-light.init
41Source8: %{name}-mail.conf
42Source9: %{name}-mail.monitrc
43Source10: %{name}-mail.init
44Source11: %{name}-perl.conf
45Source12: %{name}-perl.monitrc
46Source13: %{name}-perl.init
47Source14: %{name}-standard.conf
48Source15: %{name}-standard.monitrc
49Source16: %{name}-standard.init
50Source17: %{name}-mime.types.sh
51Patch0: %{name}-config.patch
52URL: http://nginx.net/
53BuildRequires: mailcap
54BuildRequires: openssl-devel
55BuildRequires: pcre-devel
56%{?with_perl:BuildRequires: perl-CGI}
57%{?with_perl:BuildRequires: perl-devel}
58%{?with_perl:BuildRequires: rpm-perlprov}
59BuildRequires: rpmbuild(macros) >= 1.268
60BuildRequires: zlib-devel
61Requires(post,preun): /sbin/chkconfig
62Requires(postun): /usr/sbin/groupdel
63Requires(postun): /usr/sbin/userdel
64Requires(pre): /bin/id
65Requires(pre): /usr/bin/getgid
66Requires(pre): /usr/sbin/groupadd
67Requires(pre): /usr/sbin/useradd
68Requires: nginx-daemon
69Requires: openssl
70Requires: pcre
71Requires: rc-scripts >= 0.2.0
72Requires: zlib
73Suggests: nginx-standard
74Provides: group(http)
75Provides: group(nginx)
76Provides: user(nginx)
77Provides: webserver
78Conflicts: logrotate < 3.7-4
79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81%define _sysconfdir /etc/%{name}
82%define _nginxdir /home/services/%{name}
83
84%description
85Nginx ("engine x") is a high-performance HTTP server and reverse
86proxy, as well as an IMAP/POP3 proxy server. Nginx was written by Igor
87Sysoev for Rambler.ru, Russia's second-most visited website, where it
88has been running in production for over two and a half years. Igor has
89released the source code under a BSD-like license. Although still in
90beta, Nginx is known for its stability, rich feature set, simple
91configuration, and low resource consumption.
92
93Common files for Nginx daemon.
94
95%description -l pl.UTF-8
96Nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
97a także IMAP/POP3 proxy. Nginx został napisany przez Igora Sysoeva
98na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
99odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
100opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
101w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
102prostej konfiguracji oraz małej "zasobożerności".
103
104Niezbędne pliki dla Nginx.
105
106%package light
107Summary: High perfomance HTTP and reverse proxy server
108Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
109Group: Networking/Daemons
110Requires(post,preun): /sbin/chkconfig
111Requires(postun): /usr/sbin/groupdel
112Requires(postun): /usr/sbin/userdel
113Requires: %{name} = %{version}-%{release}
114Requires: openssl
115Requires: pcre
116Requires: zlib
117Provides: group(http)
118Provides: group(nginx)
119Provides: nginx-daemon
120Provides: user(nginx)
121Provides: webserver
122
123%description light
124The smallest, but also the fastest Nginx edition. No additional
125modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
126
127%description light -l pl.UTF-8
128Najmniejsza i najszybsza wersja Nginx. Bez wsparcia dla Perla, DAV,
129FLV oraz IMAP, POP3, SMTP proxy.
130
131%package perl
132Summary: High perfomance HTTP and reverse proxy server
133Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
134Group: Networking/Daemons
135Requires(post,preun): /sbin/chkconfig
136Requires(postun): /usr/sbin/groupdel
137Requires(postun): /usr/sbin/userdel
138Requires: %{name} = %{version}-%{release}
139Requires: openssl
140Provides: group(http)
141Provides: group(nginx)
142Provides: nginx-daemon
143Provides: user(nginx)
144Provides: webserver
145
146%description perl
147Nginx with Perl support. Mail modules not included.
148
149%description perl -l pl.UTF-8
150Nignx z obsługą Perla. Bez wsparcia dla modułów poczty.
151
152%package mail
153Summary: High perfomance HTTP and reverse proxy server
154Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
155Group: Networking/Daemons
156Requires(post,preun): /sbin/chkconfig
157Requires(postun): /usr/sbin/groupdel
158Requires(postun): /usr/sbin/userdel
159Requires: %{name} = %{version}-%{release}
160Requires: openssl
161Requires: pcre
162Requires: zlib
163Provides: group(http)
164Provides: group(nginx)
165Provides: nginx-daemon
166Provides: user(nginx)
167Provides: webserver
168
169%description mail
170Nginx with mail support. Only mail modules included.
171
172%description mail -l pl.UTF-8
173Nginx ze wsparciem tylko dla modułów poczty.
174
175%package standard
176Summary: Configuration files and documentation for Nginx
177Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla Nginx
178Group: Networking/Daemons
179Requires(post,preun): /sbin/chkconfig
180Requires(postun): /usr/sbin/groupdel
181Requires(postun): /usr/sbin/userdel
182Requires: %{name} = %{version}-%{release}
183Requires: openssl
184Provides: group(http)
185Provides: group(nginx)
186Provides: nginx-daemon
187Conflicts: logrotate < 3.7-4
188
189%description standard
190Nginx ("engine x") is a high-performance HTTP server and reverse
191proxy, as well as an IMAP/POP3 proxy server. Nginx was written by Igor
192Sysoev for Rambler.ru, Russia's second-most visited website, where it
193has been running in production for over two and a half years. Igor has
194released the source code under a BSD-like license. Although still in
195beta, Nginx is known for its stability, rich feature set, simple
196configuration, and low resource consumption.
197
198This is standard Nginx version, without Perl support and IMAP, POP3,
199SMTP proxy.
200
201%description standard -l pl.UTF-8
202Nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
203a także IMAP/POP3 proxy. Nginx został napisany przez Igora Sysoeva
204na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
205odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
206opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
207w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
208prostej konfiguracji oraz małej "zasobożerności".
209
210To jest standardowa wersja Nginx, bez obsługi Perla oraz proxy dla
211IMAP, POP3, SMTP.
212
213%package -n monit-rc-nginx
214Summary: Nginx support for monit
215Summary(pl.UTF-8): Wsparcie Nginx dla monit
216Group: Applications/System
217URL: http://nginx.eu/
218Requires: %{name} = %{version}-%{release}
219Requires: monit
220
221%description -n monit-rc-nginx
222monitrc file for monitoring Nginx webserver server.
223
224%description -n monit-rc-nginx -l pl.UTF-8
225Plik monitrc do monitorowania serwera WWW Nginx.
226
227%prep
228%setup -q
229%patch0 -p0
230
231# build mime.types.conf
232#sh %{SOURCE17} /etc/mime.types
233
234%build
235# NB: not autoconf generated configure
236cp -f configure auto/
237#
238%if %{with perl}
239./configure \
240 --prefix=%{_prefix} \
241 --sbin-path=%{_sbindir}/%{name}-perl \
242 --conf-path=%{_sysconfdir}/%{name}-perl.conf \
243 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_error.log \
244 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_access.log \
245 --pid-path=%{_localstatedir}/run/%{name}-perl.pid \
246 --lock-path=%{_localstatedir}/lock/subsys/%{name}-perl \
247 --user=nginx \
248 --group=nginx \
249 --with-http_perl_module \
250 --without-mail_pop3_module \
251 --without-mail_imap_module \
252 --without-mail_smtp_module \
253 %{?with_addition:--with-http_addition_module} \
254 %{?with_dav:--with-http_dav_module} \
255 %{?with_flv:--with-http_flv_module} \
256 %{?with_sub:--with-http_sub_module} \
257 %{?with_poll:--with-poll_module} \
258 %{?with_realip:--with-http_realip_module} \
259 %{?with_rtsig:--with-rtsig_module} \
260 %{?with_select:--with-select_module} \
261 %{?with_status:--with-http_stub_status_module} \
262 %{?with_ssl:--with-http_ssl_module} \
263 %{!?with_http_browser:--without-http_browser_module} \
264 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
265 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
266 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
267 --with-cc="%{__cc}" \
268 --with-cc-opt="%{rpmcflags}" \
269 --with-ld-opt="%{rpmldflags}"
270%{__make}
271mv -f objs/nginx contrib/nginx-perl
272mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.bs contrib/nginx.bs
273mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so contrib/nginx.so
274mv -f objs/src/http/modules/perl/nginx.pm contrib/nginx.pm
275%endif
276
277%if %{with mail}
278./configure \
279 --prefix=%{_prefix} \
280 --sbin-path=%{_sbindir}/%{name}-mail \
281 --conf-path=%{_sysconfdir}/%{name}-mail.conf \
282 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_error.log \
283 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_access.log \
284 --pid-path=%{_localstatedir}/run/%{name}-mail.pid \
285 --lock-path=%{_localstatedir}/lock/subsys/%{name}-mail \
286 --user=nginx \
287 --group=nginx \
288 --with-imap \
289 --with-mail \
290 --with-mail_ssl_module \
291 --without-http \
292 %{?with_poll:--with-poll_module} \
293 %{?with_rtsig:--with-rtsig_module} \
294 %{?with_select:--with-select_module} \
295 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-mail/client_body_temp \
296 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-mail/proxy_temp \
297 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-mail/fastcgi_temp \
298 --with-cc="%{__cc}" \
299 --with-cc-opt="%{rpmcflags}" \
300 --with-ld-opt="%{rpmldflags}" \
301 %{?debug:--with-debug}
302%{__make}
303mv -f objs/nginx contrib/nginx-mail
304%endif
305
306%if %{with light}
307./configure \
308 --prefix=%{_prefix} \
309 --sbin-path=%{_sbindir}/%{name}-light \
310 --conf-path=%{_sysconfdir}/%{name}-light.conf \
311 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-light_error.log \
312 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-light_access.log \
313 --pid-path=%{_localstatedir}/run/%{name}-light.pid \
314 --lock-path=%{_localstatedir}/lock/subsys/%{name}-light \
315 --user=nginx \
316 --group=nginx \
317 %{?with_poll:--with-poll_module} \
318 %{?with_realip:--with-http_realip_module} \
319 %{?with_rtsig:--with-rtsig_module} \
320 %{?with_select:--with-select_module} \
321 %{?with_status:--with-http_stub_status_module} \
322 %{?with_ssl:--with-http_ssl_module} \
323 --without-http_browser_module \
324 --without-mail_pop3_module \
325 --without-mail_imap_module \
326 --without-mail_smtp_module \
327 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
328 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
329 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
330 --with-cc="%{__cc}" \
331 --with-cc-opt="%{rpmcflags}" \
332 --with-ld-opt="%{rpmldflags}" \
333 %{?debug:--with-debug}
334%{__make}
335mv -f objs/nginx contrib/nginx-light
336%endif
337
338./configure \
339 --prefix=%{_prefix} \
340 --sbin-path=%{_sbindir}/%{name}-standard \
341 --conf-path=%{_sysconfdir}/%{name}-standard.conf \
342 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_error.log \
343 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_access.log \
344 --pid-path=%{_localstatedir}/run/%{name}-standard.pid \
345 --lock-path=%{_localstatedir}/lock/subsys/%{name}-standard \
346 --user=nginx \
347 --group=nginx \
348 %{?with_addition:--with-http_addition_module} \
349 %{?with_dav:--with-http_dav_module} \
350 %{?with_flv:--with-http_flv_module} \
351 %{?with_sub:--with-http_sub_module} \
352 %{?with_poll:--with-poll_module} \
353 %{?with_realip:--with-http_realip_module} \
354 %{?with_rtsig:--with-rtsig_module} \
355 %{?with_select:--with-select_module} \
356 %{?with_status:--with-http_stub_status_module} \
357 %{?with_ssl:--with-http_ssl_module} \
358 %{!?with_http_browser:--without-http_browser_module} \
359 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
360 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
361 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
362 --with-cc="%{__cc}" \
363 --with-cc-opt="%{rpmcflags}" \
364 --with-ld-opt="%{rpmldflags}" \
365 %{?debug:--with-debug}
366%{__make}
367
368
369%install
370rm -rf $RPM_BUILD_ROOT
371install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
372 $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
373 $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
374 $RPM_BUILD_ROOT%{_localstatedir}/cache/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
375 $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
376 $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
377 $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
378
379install conf/* $RPM_BUILD_ROOT%{_sysconfdir}
380install conf/fastcgi_params $RPM_BUILD_ROOT%{_sysconfdir}/fastcgi.params
381install html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
382install html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
383install %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
384install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
385install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
386install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
387install %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-standard.conf
388install %{SOURCE15} $RPM_BUILD_ROOT/etc/monit/%{name}-standard.monitrc
389install %{SOURCE16} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
390install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}-standard
391
392%if %{with light}
393install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-light.conf
394install %{SOURCE6} $RPM_BUILD_ROOT/etc/monit/%{name}-light.monitrc
395install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
396install contrib/nginx-light $RPM_BUILD_ROOT%{_sbindir}/%{name}-light
397%endif
398
399%if %{with mail}
400install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-mail.conf
401install %{SOURCE9} $RPM_BUILD_ROOT/etc/monit/%{name}-mail.monitrc
402install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
403install contrib/nginx-mail $RPM_BUILD_ROOT%{_sbindir}/%{name}-mail
404%endif
405
406%if %{with perl}
407install -d $RPM_BUILD_ROOT{%{perl_vendorarch},%{perl_vendorarch}/auto/%{name}}
408install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-perl.conf
409install %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}-perl.monitrc
410install %{SOURCE13} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
411install contrib/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
412install contrib/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
413install contrib/nginx.bs $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.bs
414install contrib/nginx-perl $RPM_BUILD_ROOT%{_sbindir}/%{name}-perl
415%endif
416
417rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
418rm -rf $RPM_BUILD_ROOT%{_prefix}/html
419
420%clean
421rm -rf $RPM_BUILD_ROOT
422
423%pre
424%groupadd -r -g 213 %{name}
425%groupadd -g 51 http
426%useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
427%addusertogroup %{name} http
428
429%post standard
430for a in access.log error.log; do
431 if [ ! -f /var/log/%{name}/nginx-standard_$a ]; then
432 umask 022
433 touch /var/log/%{name}/nginx-standard_$a
434 chown nginx:nginx /var/log/%{name}/nginx-standard_$a
435 chmod 644 /var/log/%{name}/nginx-standard_$a
436 fi
437done
438/sbin/chkconfig --add %{name}-standard
439%service %{name}-standard restart
440echo 'NOTE: daemon is now using "/etc/nginx/nginx-standard.conf" as config.'
441
442%post light
443for a in access.log error.log; do
444 if [ ! -f /var/log/%{name}/nginx-light_$a ]; then
445 umask 022
446 touch /var/log/%{name}/nginx-light_$a
447 chown nginx:nginx /var/log/%{name}/nginx-light_$a
448 chmod 644 /var/log/%{name}/nginx-light_$a
449 fi
450done
451/sbin/chkconfig --add %{name}-light
452%service %{name}-light restart
453echo 'NOTE: daemon is now using "/etc/nginx/nginx-light.conf" file'
454
455%post perl
456for a in access.log error.log; do
457 if [ ! -f /var/log/%{name}/nginx-perl_$a ]; then
458 umask 022
459 touch /var/log/%{name}/nginx-perl_$a
460 chown nginx:nginx /var/log/%{name}/nginx-perl_$a
461 chmod 644 /var/log/%{name}/nginx-perl_$a
462 fi
463done
464/sbin/chkconfig --add %{name}-perl
465%service %{name}-perl restart
466echo 'NOTE: daemon is now using "/etc/nginx/nginx-perl.conf" file'
467
468%post mail
469for a in access.log error.log; do
470 if [ ! -f /var/log/%{name}/nginx-mail_$a ]; then
471 umask 022
472 touch /var/log/%{name}/nginx-mail_$a
473 chown nginx:nginx /var/log/%{name}/nginx-mail_$a
474 chmod 644 /var/log/%{name}/nginx-mail_$a
475 fi
476done
477/sbin/chkconfig --add %{name}-mail
478%service %{name}-mail restart
479echo 'NOTE: daemon is now using "/etc/nginx/nginx-mail.conf" file'
480
481%preun standard
482if [ "$1" = "0" ];then
483 %service %{name}-standard stop
484 /sbin/chkconfig --del %{name}-standard
485fi
486
487%preun light
488if [ "$1" = "0" ]; then
489 %service %{name}-light stop
490 /sbin/chkconfig --del %{name}-light
491fi
492
493%preun perl
494if [ "$1" = "0" ]; then
495 %service %{name}-perl stop
496 /sbin/chkconfig --del %{name}-perl
497fi
498
499%preun mail
500if [ "$1" = "0" ]; then
501 %service %{name}-mail stop
502 /sbin/chkconfig --del %{name}-mail
503fi
504
505%postun
506if [ "$1" = "0" ]; then
507 %userremove %{name}
508 %groupremove %{name}
509fi
510
511%files
512%defattr(644,root,root,755)
513%doc CHANGES LICENSE README html/index.html conf/nginx.conf
514%doc %lang(ru) CHANGES.ru
515%dir %attr(754,root,root) %{_sysconfdir}
516%dir %{_nginxdir}
517%dir %{_nginxdir}/cgi-bin
518%dir %{_nginxdir}/html
519%dir %{_nginxdir}/errors
520%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
521# XXX: duplicates, don't use such glob here
522%attr(640,root,root) %{_sysconfdir}/*[_-]*
523%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
524%attr(640,root,root) %{_sysconfdir}/mime.types
525%attr(750,root,root) %dir /var/log/archive/%{name}
526%attr(750,%{name},logs) /var/log/%{name}
527%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
528%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
529
530%files standard
531%defattr(644,root,root,755)
532%attr(755,root,root) %{_sbindir}/%{name}-standard
533%attr(770,root,%{name}) /var/cache/%{name}-standard
534%attr(754,root,root) /etc/rc.d/init.d/%{name}-standard
535%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-standard.conf
536
537%if %{with mail}
538%files mail
539%defattr(644,root,root,755)
540%attr(755,root,root) %{_sbindir}/%{name}-mail
541%attr(770,root,%{name}) /var/cache/%{name}-mail
542%attr(754,root,root) /etc/rc.d/init.d/%{name}-mail
543%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-mail.conf
544%endif
545
546%if %{with light}
547%files light
548%defattr(644,root,root,755)
549%attr(755,root,root) %{_sbindir}/%{name}-light
550%attr(770,root,%{name}) /var/cache/%{name}-light
551%attr(754,root,root) /etc/rc.d/init.d/%{name}-light
552%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-light.conf
553%endif
554
555%if %{with perl}
556%files perl
557%defattr(644,root,root,755)
558%attr(755,root,root) %{_sbindir}/%{name}-perl
559%attr(754,root,root) /etc/rc.d/init.d/%{name}-perl
560%attr(770,root,%{name}) /var/cache/%{name}-perl
561%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-perl.conf
562%dir %{perl_vendorarch}/auto/%{name}
563%attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
564%{perl_vendorarch}/auto/%{name}/%{name}.bs
565%{perl_vendorarch}/%{name}.pm
566%endif
567
568%files -n monit-rc-nginx
569%defattr(644,root,root,755)
570%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-standard.monitrc
571%if %{with perl}
572%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-perl.monitrc
573%endif
574%if %{with light}
575%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-light.monitrc
576%endif
577%if %{with mail}
578%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-mail.monitrc
579%endif
This page took 0.243282 seconds and 4 git commands to generate.