]> git.pld-linux.org Git - packages/nginx.git/blame_incremental - nginx.spec
- fix %files
[packages/nginx.git] / nginx.spec
... / ...
CommitLineData
1# TODO
2# - /etc/sysconfig/nginx file
3# - missing perl build/install requires
4# - prepare pld style like nginx.conf
5# - maybe -with-cpu-opt=CPU (pentium, pentiumpro, pentium3, pentium4, athlon, opteron, amd64, sparc32, sparc64, ppc64)
6#
7# Conditional build for nginx:
8%bcond_without light # don't build light version
9%bcond_without mail # don't build imap/mail proxy
10%bcond_without perl # don't build with perl module
11%bcond_without addition # adds module
12%bcond_without dav # WebDAV
13%bcond_without flv # FLV stream
14%bcond_without sub # ngx_http_sub_module
15%bcond_without poll # poll
16%bcond_without realip # real ip (behind proxy)
17%bcond_without rtsig # rtsig
18%bcond_without select # select
19%bcond_without status # stats module
20%bcond_without ssl # ssl support
21%bcond_with http_browser # header "User-agent" parser
22#
23Summary: High perfomance HTTP and reverse proxy server
24Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
25Name: nginx
26Version: 0.5.33
27Release: 0.5
28License: BSD-like
29Group: Networking/Daemons
30Source0: http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
31# Source0-md5: a78be74b4fd8e009545ef02488fcac86
32Source1: http://www.nginx.eu/favicon.ico
33# Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
34Source2: http://www.nginx.eu/download/proxy.conf
35# Source2-md5: f5263ae01c2edb18f46d5d1df2d3a5cd
36Source3: %{name}.logrotate
37Source4: %{name}.mime
38Source5: %{name}-light.conf
39Source6: %{name}-light.monitrc
40Source7: %{name}-mail.conf
41Source8: %{name}-mail.monitrc
42Source9: %{name}-perl.conf
43Source10: %{name}-perl.monitrc
44Source11: %{name}-standard.conf
45Source12: %{name}-standard.monitrc
46Patch0: %{name}-config.patch
47URL: http://nginx.net/
48BuildRequires: mailcap
49BuildRequires: openssl-devel
50BuildRequires: pcre-devel
51%{?with_perl:BuildRequires: perl-CGI}
52%{?with_perl:BuildRequires: perl-devel}
53%{?with_perl:BuildRequires: rpm-perlprov}
54BuildRequires: rpmbuild(macros) >= 1.268
55BuildRequires: zlib-devel
56Requires(post,preun): /sbin/chkconfig
57Requires(postun): /usr/sbin/groupdel
58Requires(postun): /usr/sbin/userdel
59Requires(pre): /bin/id
60Requires(pre): /usr/bin/getgid
61Requires(pre): /usr/sbin/groupadd
62Requires(pre): /usr/sbin/useradd
63Requires: monit
64Requires: openssl
65Requires: pcre
66Requires: rc-scripts >= 0.2.0
67Requires: zlib
68Provides: group(http)
69Provides: group(nginx)
70Provides: user(nginx)
71Provides: webserver
72Conflicts: logrotate < 3.7-4
73BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75%define _sysconfdir /etc/%{name}
76%define _nginxdir /home/services/%{name}
77
78%description
79Nginx ("engine x") is a high-performance HTTP server and reverse
80proxy, as well as an IMAP/POP3 proxy server. Nginx was written by Igor
81Sysoev for Rambler.ru, Russia's second-most visited website, where it
82has been running in production for over two and a half years. Igor has
83released the source code under a BSD-like license. Although still in
84beta, Nginx is known for its stability, rich feature set, simple
85configuration, and low resource consumption.
86
87Common files for Nginx daemon.
88
89%description -l pl.UTF-8
90Nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
91a także IMAP/POP3 proxy. Nginx został napisany przez Igora Sysoev'a
92na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
93odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
94opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
95