]> git.pld-linux.org Git - packages/nginx.git/blame_incremental - nginx.spec
- typos, pl fixes, UTF fixes and other cosmetics
[packages/nginx.git] / nginx.spec
... / ...
CommitLineData
1# TODO
2# - /etc/sysconfig/nginx file
3# - missing perl build/install requires
4# - prepare pld style like nginx.conf
5#
6# Conditional build for nginx:
7%bcond_without light # don't build light version
8%bcond_without mail # don't build imap/mail proxy
9%bcond_without perl # don't build with perl module
10%bcond_without addition # adds module
11%bcond_without dav # WebDAV
12%bcond_without flv # FLV stream
13%bcond_without sub # ngx_http_sub_module
14%bcond_without poll # poll
15%bcond_without realip # real ip (behind proxy)
16%bcond_without rtsig # rtsig
17%bcond_without select # select
18%bcond_without status # stats module
19%bcond_without ssl # ssl support
20%bcond_with http_browser # header "User-agent" parser
21#
22Summary: High perfomance HTTP and reverse proxy server
23Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
24Name: nginx
25Version: 0.5.33
26Release: 0.5
27License: BSD-like
28Group: Networking/Daemons
29Source0: http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
30# Source0-md5: a78be74b4fd8e009545ef02488fcac86
31Source1: %{name}.init
32Source2: %{name}-mime.types.sh
33Source3: http://www.nginx.eu/favicon.ico
34# Source3-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
35Source4: http://www.nginx.eu/download/proxy.conf
36# Source4-md5: f5263ae01c2edb18f46d5d1df2d3a5cd
37Source5: http://www.nginx.eu/download/%{name}.monitrc
38# Source5-md5: 1d3f5eedfd34fe95213f9e0fc19daa88
39Source6: http://www.nginx.eu/download/%{name}.conf
40# Source6-md5: 1c112d6f03d0f365e4acc98c1d96261a
41Source7: %{name}.logrotate
42Patch0: %{name}-config.patch
43URL: http://nginx.net/
44BuildRequires: mailcap
45BuildRequires: openssl-devel
46BuildRequires: pcre-devel
47%{?with_perl:BuildRequires: perl-CGI}
48%{?with_perl:BuildRequires: perl-devel}
49%{?with_perl:BuildRequires: rpm-perlprov}
50BuildRequires: rpmbuild(macros) >= 1.268
51BuildRequires: zlib-devel
52Requires(post,preun): /sbin/chkconfig
53Requires(postun): /usr/sbin/groupdel
54Requires(postun): /usr/sbin/userdel
55Requires(pre): /bin/id
56Requires(pre): /usr/bin/getgid
57Requires(pre): /usr/sbin/groupadd
58Requires(pre): /usr/sbin/useradd
59Requires: %{name}-common = %{version}-%{release}
60Requires: openssl
61Requires: pcre
62Requires: rc-scripts >= 0.2.0
63Requires: zlib
64Provides: group(http)
65Provides: group(nginx)
66Provides: user(nginx)
67Provides: webserver
68Conflicts: logrotate < 3.7-4
69Conflicts: %{name}-light
70Conflicts: %{name}-mail
71Conflicts: %{name}-perl
72BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74%define _sysconfdir /etc/%{name}
75%define _nginxdir /home/services/%{name}
76
77%description
78Nginx ("engine x") is a high-performance HTTP server and reverse
79proxy, as well as an IMAP/POP3 proxy server. Nginx was written by Igor
80Sysoev for Rambler.ru, Russia's second-most visited website, where it
81has been running in production for over two and a half years. Igor has
82released the source code under a BSD-like license. Although still in
83beta, Nginx is known for its stability, rich feature set, simple
84configuration, and low resource consumption.
85
86This is standard nginx version, without perl support and imap, pop3,
87smtp proxy.
88
89%description -l pl.UTF-8
90Nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
91a także IMAP/POP3 proxy. Nginx został napisany przez Igora Sysoev'a
92na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
93odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
94opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
95