]> git.pld-linux.org Git - packages/mplayer.git/blame_incremental - mplayer.spec
- BR: docbook-dtd412-xml
[packages/mplayer.git] / mplayer.spec
... / ...
CommitLineData
1# TODO:
2# - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
3# - update for lzo 2
4# - try to use external lrmi and few other libs:
5# http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
6# - segfaults on amd64:
7# mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8# avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
9#
10# Conditional build:
11%bcond_with directfb # with DirectFB video output
12%bcond_with dxr3 # enable use of DXR3/H+ hardware MPEG decoder
13%bcond_with ggi # with ggi video output
14%bcond_with nas # with NAS audio output
15%bcond_with svga # with svgalib video output
16%bcond_without osd # with osd menu support
17%bcond_without altivec # without altivec support
18%bcond_without x264 # without x264 support
19%bcond_with xmms # with XMMS inputplugin support
20%bcond_without aalib # without aalib video output
21%bcond_without jack # without JACKD support
22%bcond_without alsa # without ALSA audio output
23%bcond_without arts # without arts audio output
24%bcond_without caca # without libcaca video output
25%bcond_without cdparanoia # without cdparanoia support
26%bcond_without enca # disable using ENCA charset oracle library
27%bcond_without esd # disable EsounD sound support
28%bcond_without faad # disable FAAD2 (AAC) support
29%bcond_without gif # disable GIF support
30%bcond_without gui # without GTK+ GUI
31%bcond_without joystick # disable joystick support
32%bcond_without libdts # disable libdts support
33%bcond_without libdv # disable libdv en/decoding support
34%bcond_without lirc # without lirc support
35%bcond_with live # without LIVE555 libraries
36%bcond_without lzo # with LZO support (requires lzo 2.x)
37%bcond_without mad # without mad (audio MPEG) support
38%bcond_without pulseaudio # without pulseaudio output
39%bcond_without quicktime # without binary quicktime dll support
40%bcond_without real # without Real* 8/9 codecs support
41%bcond_without runtime # disable runtime cpu detection, just detect CPU
42 # in compile time (advertised by mplayer authors as working faster); in this case
43 # mplayer may not work on machine other then where it was compiled
44%bcond_without select # disable audio select() support (for example required this option ALSA or Vortex2 driver)
45%bcond_without smb # disable Samba (SMB) input support
46%bcond_without theora # without theora support
47%bcond_without win32 # without win32 codecs support
48%bcond_without vidix # disable vidix
49%bcond_without vorbis # without Ogg-Vorbis audio support
50%bcond_without xvid # disable XviD codec
51%bcond_without mencoder # disable mencoder (a/v encoder) compilation
52%bcond_without sdl # disable SDL
53%bcond_without doc # don't build docs (slow)
54%bcond_with shared # experimental libmplayer.so support
55%bcond_with amr # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
56%bcond_without gnomess # disable controling gnome screensaver
57%bcond_with ssse3 # sse3 optimizations (needs binutils >= 2.16.92)
58%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (needs more work or mplayer snapshot)
59
60%ifnarch %{ix86}
61%undefine with_win32
62%undefine with_quicktime
63%undefine with_vidix
64%endif
65
66%ifnarch %{ix86} %{x8664} ppc ppc64
67%undefine with_runtime
68%endif
69
70%if %{_lib} == "lib64"
71%define _suf 64
72%else
73%define _suf 32
74%endif
75
76%define subver rc2
77%define rel 15
78
79Summary: MPlayer - THE Movie Player for UN*X
80Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
81Summary(es.UTF-8): Otro reproductor de películas
82Summary(ko.UTF-8): 리눅스용 미디어플레이어
83Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
84Summary(pt_BR.UTF-8): Reprodutor de filmes
85Name: mplayer
86Version: 1.0
87Release: 5.%{subver}.%{rel}
88# DO NOT increase epoch unless it's really neccessary!
89# especially such changes like pre7->pre7try2, increase Release instead!
90# PS: $ rpmvercmp pre7try2 pre7
91# pre7try2 > pre7
92Epoch: 3
93License: GPL
94Group: Applications/Multimedia
95Source0: ftp://ftp2.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{subver}.tar.bz2
96# Source0-md5: 7e27e535c2d267637df34898f1b91707
97Source3: ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
98# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
99Source5: g%{name}.desktop
100Source6: ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
101# Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
102Source7: %{name}.png
103Source8: %{name}.desktop
104# http://www.on2.com/gpl/mplayer/
105Source9: http://www.on2.com/gpl/mplayer/2007-10-09-mencoder-on2flixenglinux.tar.bz2
106# Source9-md5: 2361e56b40f52dfc20131e458e2aed38
107Patch1: %{name}-cp1250-fontdesc.patch
108#Patch2: %{name}-codec.patch
109#Patch3: %{name}-home_etc.patch
110Patch4: %{name}-350.patch
111Patch5: %{name}-configure.patch
112# outdated via ffmpeg?
113Patch6: %{name}-system-amr.patch
114Patch8: %{name}-altivec.patch
115#Patch10: %{name}-pcmsplit.patch
116#Patch13: %{name}-mythtv.patch
117Patch14: %{name}-shared.patch
118#http://www.openchrome.org/snapshots/mplayer/
119#Patch15: %{name}-xvmc.patch
120Patch17: %{name}-auto-expand.patch
121# update
122#Patch18: %{name}-gnome-screensaver.patch
123Patch19: %{name}-on2flix.patch
124Patch22: %{name}-ffmpeg.patch
125Patch23: %{name}-live.patch
126Patch24: %{name}-fontconfig_sub.patch
127Patch25: http://www.mplayerhq.hu/MPlayer/patches/stream_cddb_fix_20080120.diff
128Patch26: %{name}-check-byteswap.patch
129Patch27: http://www.mplayerhq.hu/MPlayer/patches/demux_mov_fix_20080129.diff
130Patch28: http://www.ocert.org/patches/2008-013/mplayer_demux_real.patch
131Patch29: %{name}-x264.patch
132URL: http://www.mplayerhq.hu/
133%{?with_directfb:BuildRequires: DirectFB-devel}
134BuildRequires: OpenAL-devel
135BuildRequires: OpenGL-devel
136%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
137%{?with_aalib:BuildRequires: aalib-devel}
138%{?with_alsa:BuildRequires: alsa-lib-devel}
139%if %{with amr}
140BuildRequires: amrnb-devel
141BuildRequires: amrwb-devel >= 5.3.0
142%endif
143%{?with_arts:BuildRequires: artsc-devel}
144%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
145%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
146%{?with_doc:BuildRequires: docbook-style-xsl}
147%{?with_doc:BuildRequires: docbook-dtd412-xml}
148%{?with_dxr3:BuildRequires: em8300-devel}
149%{?with_enca:BuildRequires: enca-devel}
150%{?with_esd:BuildRequires: esound-devel}
151BuildRequires: faac-devel
152%{?with_faad:BuildRequires: faad2-devel >= 2.0}
153%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 0.4.9-3.20070626.1.1}
154BuildRequires: freetype-devel
155BuildRequires: fribidi-devel
156%{?with_vidix:BuildRequires: vidix-devel}
157%ifarch ppc
158%{?with_altivec:BuildRequires: gcc >= 5:3.3.2-3}
159%endif
160%{?with_gif:BuildRequires: giflib-devel}
161%if %{with gui}
162BuildRequires: gtk+2-devel
163%endif
164%{?with_gnomess:BuildRequires: dbus-glib-devel}
165%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
166%{?with_jack:%requires_eq jack-audio-connection-kit-libs}
167BuildRequires: lame-libs-devel
168%{?with_caca:BuildRequires: libcaca-devel}
169%{?with_libdts:BuildRequires: libdts-devel}
170%{?with_libdv:BuildRequires: libdv-devel}
171BuildRequires: libdvdnav-devel
172%{?with_ggi:BuildRequires: libggi-devel}
173BuildRequires: libjpeg-devel
174%{?with_mad:BuildRequires: libmad-devel}
175BuildRequires: libmpcdec-devel >= 1.2.1
176BuildRequires: libpng-devel
177%{?with_smb:BuildRequires: libsmbclient-devel}
178%{?with_theora:BuildRequires: libtheora-devel}
179# tremor is used by default, internal as we don't have system one
180#%{?with_vorbis:BuildRequires: libvorbis-devel}
181%{?with_x264:BuildRequires: libx264-devel >= 0.1.2-1.20081023_2245.1}
182BuildRequires: libxslt-progs
183%{?with_lirc:BuildRequires: lirc-devel}
184%{?with_live:BuildRequires: live}
185%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
186%{?with_nas:BuildRequires: nas-devel}
187BuildRequires: ncurses-devel
188BuildRequires: pkgconfig
189%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
190BuildRequires: speex-devel >= 1.1
191%{?with_svga:BuildRequires: svgalib-devel}
192%{?with_xmms:BuildRequires: xmms-libs}
193BuildRequires: xorg-lib-libX11-devel
194BuildRequires: xorg-lib-libXext-devel
195BuildRequires: xorg-lib-libXinerama-devel
196BuildRequires: xorg-lib-libXv-devel
197BuildRequires: xorg-lib-libXvMC-devel
198BuildRequires: xorg-lib-libXxf86dga-devel
199BuildRequires: xorg-lib-libXxf86vm-devel
200%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
201BuildRequires: zlib-devel
202Requires: %{name}-common = %{epoch}:%{version}-%{release}
203Requires: OpenGL
204BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
205
206%define _noautoreqdep libGL.so.1 libGLU.so.1
207%define specflags_ia32 -fomit-frame-pointer
208%if %{with altivec}
209%define specflags_ppc -maltivec
210%endif
211
212%description
213Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
214AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
215MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
216MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
217devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
218optionally with SHM extension, X11 using overlays with the Xvideo
219extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
220Voodoo2/3 hardware, SDL v1.1.7 driver etc.
221
222If you want to use win32 codecs install w32codec package.
223
224%description -l de.UTF-8
225MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
226Kennzeichnend ist die herausragende Format- und
227Plattform-Kompatibilität.
228
229Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
230plattformexklusive, wodurch etwa Windows Media auch außerhalb von
231Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
232Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
233ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
234Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
235installierte Codecs nicht mit MPlayer kollidieren können.
236
237%description -l es.UTF-8
238Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
239MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
240(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
241de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
242Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
243G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
244overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
245G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
246v1.1.7 etc.
247
248Si quiere usar codecs Win32, instale el paquete w32codec.
249
250%description -l ko.UTF-8
251MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
252파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
253MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
254Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
255(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
256수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
257크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
258있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
259부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
260
261%description -l pl.UTF-8
262Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
263RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
264(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
265Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
266Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
267rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
268G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
269
270Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
271
272%description -l pt_BR.UTF-8
273MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
274áudio. Diferentes mecanismos de reprodução podem também ser
275escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
276
277%package -n gmplayer
278Summary: MPlayer with GTK+ GUI interface
279Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
280Group: X11/Applications/Multimedia
281Requires: %{name}-common = %{epoch}:%{version}-%{release}
282Requires: %{name}-skin
283
284%description -n gmplayer
285MPlayer with GUI GTK+ interface.
286
287%description -n gmplayer -l pl.UTF-8
288MPlayer z graficznym interfejsem GTK+.
289
290%package common
291Summary: Configuration files and documentation for MPlayer
292Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
293Group: Applications/Multimedia
294Obsoletes: mplayer-vidix
295
296%description common
297Configuration files, man page and HTML documentation for MPlayer.
298
299%description common -l pl.UTF-8
300Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
301
302%package -n mencoder
303Summary: MEncoder - a movie encoder for Linux
304Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
305Group: Applications/Multimedia
306Requires: %{name}-common = %{epoch}:%{version}-%{release}
307
308%description -n mencoder
309MEncoder is a movie encoder for Linux and is a part of the MPlayer
310package.
311
312%description -n mencoder -l pl.UTF-8
313MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
314
315%prep
316%setup -q -n MPlayer-%{version}%{subver} -a3 -a6 -a9
317cp -f etc/codecs.conf etc/codecs.win32.conf
318%patch1 -p0
319#%%patch2 -p1 -- still needed?
320##%%patch3 -p1 -- old home_etc behavior
321%patch4 -p1
322%patch5 -p1
323#%%patch6 -p1 # - try ffmpeg
324%patch8 -p1
325#%%patch10 -p1
326#%%patch13 -p1 # TODO
327%if %{with shared}
328%patch14 -p1
329%endif
330#%%patch15 -p0 # TODO
331%patch17 -p1
332%if %{with gnomess}
333#%%patch18 -p1
334%endif
335
336# on2flix
337cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
338rm -f mencoder-on2flixenglinux/version.diff
339%patch19 -p1
340for a in mencoder-on2flixenglinux/*.diff; do
341 patch -p0 < $a
342done
343
344%{?with_system_ffmpeg:%patch22 -p1}
345%patch23 -p1
346%patch24 -p0
347%patch25 -p0
348%patch26 -p1
349%patch27 -p0
350%patch28 -p0
351%patch29 -p1
352
353# recent dvdnav-config doesn't support --minilibs.
354sed -i 's:--minilibs:--libs:g' configure
355
356sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
357rm -f font-*/runme
358
359%if %{with system_ffmpeg}
360# using external ffmpeg, but mplayer adds these to includepath
361rm -rf libavcodec libavdevice libavformat libavutil libpostproc libswscale
362%endif
363
364%build
365%if %{with shared}
366CFLAGS="%{rpmcflags} -fPIC"
367%else
368CFLAGS="%{rpmcflags}"
369%endif
370CC="%{__cc}"
371LDFLAGS="%{rpmldflags}"
372export CC CFLAGS LDFLAGS
373
374build() {
375set -x
376 ./configure \
377 %{?debug:--enable-debug=3} \
378 --prefix=%{_prefix} \
379 --confdir=%{_sysconfdir}/mplayer \
380 --with-extraincdir=%{_includedir}/xvid \
381 --with-extralibdir=%{?_x_libraries}%{!?_x_libraries:%{_libdir}} \
382%if %{with system_ffmpeg}
383 --disable-libavutil_a \
384 --disable-libavcodec_a \
385 --disable-libavformat_a \
386 --disable-libpostproc_a \
387 --enable-libavutil_so \
388 --enable-libavcodec_so \
389 --enable-libavformat_so \
390 --enable-libpostproc_so \
391%endif
392%ifnarch %{ix86} %{x8664}
393 --disable-mmx \
394 --disable-mmxext \
395 --disable-3dnow \
396 --disable-3dnowext \
397 --disable-sse \
398 --disable-sse2 \
399 --disable-fastmemcpy \
400%endif
401 %{!?with_ssse3:--disable-ssse3} \
402%ifarch ppc
403 %{!?with_altivec:--disable-altivec} \
404%endif
405 %{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
406 %{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
407 %{?with_directfb:--enable-directfb} \
408 %{!?with_directfb:--disable-directfb} \
409 %{!?with_dxr3:--disable-dxr3} \
410 %{!?with_ggi:--disable-ggi} \
411 %{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
412 %{!?with_live:--disable-live} \
413 %{!?with_lzo:--disable-liblzo} \
414 %{!?with_nas:--disable-nas} \
415 %{!?with_svga:--disable-svga} \
416 %{!?with_aalib:--disable-aa} \
417 %{!?with_jack:--disable-jack} \
418 %{!?with_alsa:--disable-alsa} \
419 %{?with_alsa:--enable-alsa --disable-select} \
420 %{!?with_arts:--disable-arts} \
421 %{!?with_caca:--disable-caca} \
422 %{!?with_cdparanoia:--disable-cdparanoia} \
423 %{!?with_enca:--disable-enca} \
424 %{!?with_esd:--disable-esd} \
425 %{!?with_faad:--disable-faad-external --disable-faad-internal} \
426 %{?with_faad:--disable-faad-internal} \
427 %{!?with_gif:--disable-gif} \
428 %{?with_joystick:--enable-joystick} \
429 %{!?with_libdv:--disable-libdv} \
430 %{!?with_libdts:--disable-libdts} \
431 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
432 %{!?with_mad:--disable-mad} \
433 %{!?with_pulseaudio:--disable-polyp} \
434 %{!?with_quicktime:--disable-qtx} \
435 %{!?with_real:--disable-real} \
436 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
437 %{!?with_select:--disable-select} \
438 %{!?with_smb:--disable-smb} \
439 %{!?with_win32:--disable-win32dll} \
440 %{!?with_vorbis:--disable-vorbis} \
441 %{?with_osd:--enable-menu} \
442 %{!?with_theora:--disable-theora} \
443 %{!?with_x264:--disable-x264} \
444 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
445 %{!?with_xvid:--disable-xvid} \
446 %{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
447 %{?with_vidix:--disable-vidix-internal} \
448 %{!?with_mencoder:--disable-mencoder} \
449 --enable-dga1 \
450 --enable-dga2 \
451 --enable-dvdnav \
452 --enable-fbdev \
453 --enable-gl \
454 --enable-mga \
455 --enable-radio \
456 --enable-radio-capture \
457 --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
458 --enable-tdfxfb \
459 --enable-vm \
460 --enable-x11 \
461 --enable-xmga \
462 --enable-xv \
463 --enable-xvmc \
464 --enable-dynamic-plugins \
465 --enable-largefiles \
466 --language=all \
467 --codecsdir=%{_libdir}/codecs \
468 --with-xvmclib=XvMCW \
469 "$@"
470
471 %{__make}
472}
473
474%if %{with gui}
475# build GUI version
476build --enable-gui --disable-mencoder
477mv -f mplayer gmplayer
478%{__make} distclean
479%endif
480
481# now build regular version
482build --disable-gui
483
484%if %{with doc}
485%{__make} -j1 -C DOCS/xml
486%endif
487
488%install
489rm -rf $RPM_BUILD_ROOT
490install -d \
491 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
492 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
493 $RPM_BUILD_ROOT%{_datadir}/mplayer/skins \
494 $RPM_BUILD_ROOT%{_desktopdir}
495
496# default config files
497install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
498
499# executables
500%if %{with mencoder}
501install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
502ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
503%endif
504install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
505ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
506%if %{with gui}
507install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
508ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
509%endif
510
511# fonts
512cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
513ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
514
515%if %{with gui}
516touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
517install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
518%endif
519install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
520install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
521
522# man pages
523install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
524install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
525install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
526install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
527install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
528install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
529install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
530install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
531#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
532install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
533
534%clean
535rm -rf $RPM_BUILD_ROOT
536
537%post -n gmplayer
538umask 022
539[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
540
541%postun -n gmplayer
542umask 022
543[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
544
545%files
546%defattr(644,root,root,755)
547%attr(755,root,root) %{_bindir}/mplayer*
548
549%if %{with gui}
550%files -n gmplayer
551%defattr(644,root,root,755)
552%attr(755,root,root) %{_bindir}/gmplayer*
553%{_desktopdir}/gmplayer.desktop
554%dir %{_datadir}/%{name}/skins
555%ghost %{_datadir}/%{name}/skins/default
556%endif
557
558%if %{with mencoder}
559%files -n mencoder
560%defattr(644,root,root,755)
561%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
562%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
563%doc DOCS/tech/colorspaces.txt
564%attr(755,root,root) %{_bindir}/mencoder*
565%endif
566
567%files common
568%defattr(644,root,root,755)
569%doc DOCS/tech
570%if %{with win32}
571%doc etc/codecs.win32.conf
572%endif
573%if %{with doc}
574# HTML and XML-generated docs
575%doc DOCS/HTML/en
576%lang(cs) %doc DOCS/HTML/cs
577%lang(de) %doc DOCS/HTML/de
578%lang(es) %doc DOCS/HTML/es
579%lang(fr) %doc DOCS/HTML/fr
580%lang(hu) %doc DOCS/HTML/hu
581%lang(pl) %doc DOCS/HTML/pl
582%lang(ru) %doc DOCS/HTML/ru
583#%lang(zh_CN) %doc DOCS/zh
584%endif
585%doc AUTHORS README
586
587%dir %{_sysconfdir}/%{name}
588%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
589%{_mandir}/man1/*
590%lang(cs) %{_mandir}/cs/man1/*
591%lang(de) %{_mandir}/de/man1/*
592%lang(es) %{_mandir}/es/man1/*
593%lang(fr) %{_mandir}/fr/man1/*
594%lang(hu) %{_mandir}/hu/man1/*
595%lang(it) %{_mandir}/it/man1/*
596%lang(pl) %{_mandir}/pl/man1/*
597#%lang(sv) %{_mandir}/sv/man1/*
598%lang(zh_CN) %{_mandir}/zh_CN/man1/*
599%{_desktopdir}/mplayer.desktop
600%{_pixmapsdir}/mplayer.png
601%dir %{_datadir}/%{name}
602%{_datadir}/%{name}/font*
This page took 0.070243 seconds and 4 git commands to generate.