]> git.pld-linux.org Git - packages/mplayer.git/blame_incremental - mplayer.spec
- face the truth: lzo 2 and polypaudio 0.8 are not supported yet
[packages/mplayer.git] / mplayer.spec
... / ...
CommitLineData
1#
2# TODO:
3# - update for lzo 2
4# - update for polypaudio 0.8
5# - use external lrmi and few other libs:
6# http://www.gocyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
7#
8# Conditional build:
9%bcond_with directfb # with DirectFB video output
10%bcond_with divx4linux # with divx4linux a/v support (binaries, instead of included OpenDivx)
11%bcond_with dxr3 # enable use of DXR3/H+ hardware MPEG decoder
12%bcond_with ggi # with ggi video output
13%bcond_with nas # with NAS audio output
14%bcond_with svga # with svgalib video output
15%bcond_with osd # with osd menu support
16%bcond_with altivec # with altivec support (altivec code brakes image in mpeg4, and may segfault on others)
17%bcond_with x264 # with x264 support (needs newer libx264 snap)
18%bcond_with xmms # with XMMS inputplugin support
19%bcond_without aalib # without aalib video output
20%bcond_without jack # without JACKD support
21%bcond_without alsa # without ALSA audio output
22%bcond_without arts # without arts audio output
23%bcond_without caca # without libcaca video output
24%bcond_without cdparanoia # without cdparanoia support
25%bcond_without dshow # disable DirectShow support
26%bcond_without enca # disable using ENCA charset oracle library
27%bcond_without esd # disable EsounD sound support
28%bcond_without faad # disable FAAD2 (AAC) support
29%bcond_without gif # disable GIF support
30%bcond_without gui # without GTK+ GUI
31%bcond_without joystick # disable joystick support
32%bcond_without libdts # disable libdts support
33%bcond_without libdv # disable libdv en/decoding support
34%bcond_without lirc # without lirc support
35%bcond_without live # without live.com libraries
36%bcond_with lzo # with LZO support (requires lzo 1.x)
37%bcond_without mad # without mad (audio MPEG) support
38%bcond_with polyp # with polyp audio output (requires polypaudio 0.6 or 0.7)
39%bcond_without quicktime # without binary quicktime dll support
40%bcond_without real # without Real* 8/9 codecs support
41%bcond_without runtime # disable runtime cpu detection, just detect CPU
42 # in compile time (advertised by mplayer authors as working faster); in this case
43 # mplayer may not work on machine other then where it was compiled
44%bcond_without select # disable audio select() support (for example required this option ALSA or Vortex2 driver)
45%bcond_without smb # disable Samba (SMB) input support
46%bcond_without theora # without theora support
47%bcond_without win32 # without win32 codecs support
48%bcond_without vorbis # without Ogg-Vorbis audio support
49%bcond_without xvid # disable XviD codec
50%bcond_without mencoder # disable mencoder (a/v encoder) compilation
51%bcond_without sdl # disable SDL
52%bcond_without doc # don't build docs (slow)
53%bcond_with gtk2 # EXPERIMENTAL support for GTK+ version 2
54%bcond_with shared # experimental libmplayer.so support
55
56%ifnarch %{ix86}
57%undefine with_win32
58%undefine with_quicktime
59%endif
60
61%ifarch %{x8664}
62%undefine with_runtime
63%endif
64
65%if %{_lib} == "lib64"
66%define _suf 64
67%else
68%define _suf 32
69%endif
70
71# set it to 0, or 1
72%define snapshot 0
73
74%define sname MPlayer
75%define snap %{nil}
76
77%define pre pre7try2
78
79Summary: MPlayer - THE Movie Player for UN*X
80Summary(de): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
81