]> git.pld-linux.org Git - packages/mplayer.git/blame_incremental - mplayer.spec
- missing BR
[packages/mplayer.git] / mplayer.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with directfb # with DirectFB video output
4%bcond_with divx4linux # with divx4linux a/v support (binaries, instead
5 # of included OpenDivx)
6
7%bcond_with dxr3 # enable use of DXR3/H+ hardware MPEG decoder
8%bcond_with ggi # with ggi video output
9%bcond_with live # enable use of live.com libraries
10%bcond_with nas # with NAS audio output
11%bcond_with svga # with svgalib video output
12%bcond_with osd # with osd menu support
13
14%bcond_with altivec # with altivec support (won't run w/o altivec
15 # due to instruction used in CPU detection(?))
16
17%bcond_with xmms # with XMMS inputplugin support
18
19%bcond_without aalib # without aalib video output
20%bcond_without jack # without JACKD support
21%bcond_without alsa # without ALSA audio output
22%bcond_without arts # without arts audio output
23%bcond_without caca # without libcaca video output
24%bcond_without dshow # disable DirectShow support
25%bcond_without gui # without GTK+ GUI
26%bcond_without joystick # disable joystick support
27%bcond_without libdv # disable libdv en/decoding support
28%bcond_without lirc # without lirc support
29%bcond_without mad # without mad (audio MPEG) support
30%bcond_without polyp # without polyp audio output
31%bcond_without quicktime # without binary quicktime dll support
32%bcond_without real # without Real* 8/9 codecs support
33%bcond_without runtime # disable runtime cpu detection, just detect CPU
34 # in compile time (advertised by mplayer
35 # authors as working faster); in this case
36 # mplayer may not work on machine other then
37 # where it was compiled
38%bcond_without select # disable audio select() support (for example
39 # required this option ALSA or Vortex2 driver)
40%bcond_without smb # disable Samba (SMB) input support
41%bcond_without theora # without theora support
42%bcond_without win32 # without win32 codecs support
43%bcond_without vorbis # without Ogg-Vorbis audio support
44%bcond_without mencoder # disable mencoder (a/v encoder) compilation
45%bcond_without libdts # disable libdts support
46
47%bcond_with gtk2 # EXPERIMENTAL support for GTK+ version 2
48%bcond_with xlibs
49
50%ifnarch %{ix86}
51%undefine with_win32
52%undefine with_quicktime
53%endif
54
55# set it to 0, or 1
56%define snapshot 0
57
58%define sname MPlayer
59%define snap %{nil}
60
61%define pre pre7
62
63Summary: Yet another movie player
64