]> git.pld-linux.org Git - packages/mplayer.git/blame_incremental - mplayer.spec
- rel 4
[packages/mplayer.git] / mplayer.spec
... / ...
CommitLineData
1# TODO:
2# - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
3# - update for lzo 2
4# - try to use external ffmpeg, lrmi and few other libs:
5# http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
6# - segfaults on amd64:
7# mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8# avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
9#
10# Conditional build:
11%bcond_with directfb # with DirectFB video output
12%bcond_with dxr3 # enable use of DXR3/H+ hardware MPEG decoder
13%bcond_with ggi # with ggi video output
14%bcond_with nas # with NAS audio output
15%bcond_with svga # with svgalib video output
16%bcond_with osd # with osd menu support
17%bcond_without altivec # without altivec support
18%bcond_without x264 # without x264 support
19%bcond_with xmms # with XMMS inputplugin support
20%bcond_without aalib # without aalib video output
21%bcond_without jack # without JACKD support
22%bcond_without alsa # without ALSA audio output
23%bcond_without arts # without arts audio output
24%bcond_without caca # without libcaca video output
25%bcond_without cdparanoia # without cdparanoia support
26%bcond_without dshow # disable DirectShow support
27%bcond_without enca # disable using ENCA charset oracle library
28%bcond_without esd # disable EsounD sound support
29%bcond_without faad # disable FAAD2 (AAC) support
30%bcond_without gif # disable GIF support
31%bcond_without gui # without GTK+ GUI
32%bcond_without joystick # disable joystick support
33%bcond_without libdts # disable libdts support
34%bcond_without libdv # disable libdv en/decoding support
35%bcond_without lirc # without lirc support
36%bcond_without live # without live.com libraries
37%bcond_with lzo # with LZO support (requires lzo 1.x)
38%bcond_without mad # without mad (audio MPEG) support
39%bcond_without pulseaudio # without pulseaudio output
40%bcond_without quicktime # without binary quicktime dll support
41%bcond_without real # without Real* 8/9 codecs support
42%bcond_without runtime # disable runtime cpu detection, just detect CPU
43 # in compile time (advertised by mplayer authors as working faster); in this case
44 # mplayer may not work on machine other then where it was compiled
45%bcond_without select # disable audio select() support (for example required this option ALSA or Vortex2 driver)
46%bcond_without smb # disable Samba (SMB) input support
47%bcond_without theora # without theora support
48%bcond_without win32 # without win32 codecs support
49%bcond_without vidix # disable vidix
50%bcond_without vorbis # without Ogg-Vorbis audio support
51%bcond_without xvid # disable XviD codec
52%bcond_without mencoder # disable mencoder (a/v encoder) compilation
53%bcond_without sdl # disable SDL
54%bcond_without doc # don't build docs (slow)
55%bcond_with shared # experimental libmplayer.so support
56%bcond_with amr # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
57%bcond_without gnomess # disable controling gnome screensaver
58
59%ifnarch %{ix86}
60%undefine with_win32
61%undefine with_quicktime
62%undefine with_vidix
63%endif
64
65%ifarch %{x8664}
66%undefine with_runtime
67%endif
68
69%if %{_lib} == "lib64"
70%define _suf 64
71%else
72%define _suf 32
73%endif
74
75%define sname MPlayer
76%define snap %{nil}
77
78%define _rc rc1
79%define _rel 4
80Summary: MPlayer - THE Movie Player for UN*X
81Summary(de): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
82