]> git.pld-linux.org Git - packages/mplayer.git/blame_incremental - mplayer.spec
- gpm-friendly Source URLs
[packages/mplayer.git] / mplayer.spec
... / ...
CommitLineData
1#
2# TODO:
3# - use external lrmi and few other libs:
4# http://www.gocyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
5#
6# Conditional build:
7%bcond_with directfb # with DirectFB video output
8%bcond_with divx4linux # with divx4linux a/v support (binaries, instead
9 # of included OpenDivx)
10
11%bcond_with dxr3 # enable use of DXR3/H+ hardware MPEG decoder
12%bcond_with ggi # with ggi video output
13%bcond_with live # enable use of live.com libraries
14%bcond_with nas # with NAS audio output
15%bcond_with svga # with svgalib video output
16%bcond_with osd # with osd menu support
17
18%bcond_with altivec # with altivec support (won't run w/o altivec
19 # due to instruction used in CPU detection(?))
20
21%bcond_with xmms # with XMMS inputplugin support
22
23%bcond_without aalib # without aalib video output
24%bcond_without jack # without JACKD support
25%bcond_without alsa # without ALSA audio output
26%bcond_without arts # without arts audio output
27%bcond_without caca # without libcaca video output
28%bcond_without dshow # disable DirectShow support
29%bcond_without gui # without GTK+ GUI
30%bcond_without joystick # disable joystick support
31%bcond_without libdv # disable libdv en/decoding support
32%bcond_without lirc # without lirc support
33%bcond_without mad # without mad (audio MPEG) support
34%bcond_without polyp # without polyp audio output
35%bcond_without quicktime # without binary quicktime dll support
36%bcond_without real # without Real* 8/9 codecs support
37%bcond_without runtime # disable runtime cpu detection, just detect CPU
38 # in compile time (advertised by mplayer
39 # authors as working faster); in this case
40 # mplayer may not work on machine other then
41 # where it was compiled
42%bcond_without select # disable audio select() support (for example
43 # required this option ALSA or Vortex2 driver)
44%bcond_without smb # disable Samba (SMB) input support
45%bcond_without theora # without theora support
46%bcond_without win32 # without win32 codecs support
47%bcond_without vorbis # without Ogg-Vorbis audio support
48%bcond_without mencoder # disable mencoder (a/v encoder) compilation
49%bcond_without libdts # disable libdts support
50
51%bcond_with gtk2 # EXPERIMENTAL support for GTK+ version 2
52%bcond_with xlibs
53
54%ifnarch %{ix86}
55%undefine with_win32
56%undefine with_quicktime
57%endif
58
59# set it to 0, or 1
60%define snapshot 0
61
62%define sname MPlayer
63%define snap %{nil}
64
65%define pre pre7
66
67Summary: Yet another movie player
68