]> git.pld-linux.org Git - packages/mono-debugger.git/blame_incremental - mono-debugger.spec
- updated to 2.6
[packages/mono-debugger.git] / mono-debugger.spec
... / ...
CommitLineData
1%include /usr/lib/rpm/macros.mono
2Summary: Debugger for mono
3Summary(pl.UTF-8): Odpluskiwacz dla mono
4Name: mono-debugger
5Version: 2.6
6Release: 1
7# mono-debugger itself on MIT, but BFD libs enforce GPL
8License: GPL v2+
9Group: Development/Tools
10# latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
11Source0: http://ftp.novell.com/pub/mono/sources/mono-debugger/%{name}-%{version}.tar.bz2
12# Source0-md5: a6cac2d8dc8f788a7b2b35cd3f7204dc
13Patch0: %{name}-termcap.patch
14URL: http://www.mono-project.com/
15BuildRequires: autoconf
16BuildRequires: automake
17BuildRequires: glib2-devel >= 1:2.0.0
18BuildRequires: libtool
19BuildRequires: mono-csharp >= 2.0
20BuildRequires: monodoc
21BuildRequires: pkgconfig
22BuildRequires: readline-devel
23Requires: mono >= 2.0
24ExclusiveArch: %{ix86} %{x8664}
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28Debugger for mono.
29
30%description -l pl.UTF-8
31Odpluskwiacz dla mono.
32
33%package devel
34Summary: Development files for mono debugger
35Summary(pl.UTF-8): Pliki potrzebne programistom korzystajÄ…cym z bibliotek odpluskiwacza mono
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38Obsoletes: mono-debugger-static
39
40%description devel
41Development files for mono debugger.
42
43%description devel -l pl.UTF-8
44Pliki potrzebne programistom korzystajÄ…cym z bibliotek odpluskwiacza
45mono.
46
47%package doc
48Summary: Documentation for mono debugger
49Summary(pl.UTF-8): Dokumentacja odpluskiwacza dla mono
50Group: Documentation
51Requires: monodoc
52
53%description doc
54Documentation for mono debugger.
55
56%description doc -l pl.UTF-8
57Dokumentacja odpluskwiacza dla mono.
58
59%prep
60%setup -q
61%patch0 -p1
62
63%build
64%{__libtoolize}
65%{__aclocal}
66%{__autoheader}
67%{__automake}
68%{__autoconf}
69%configure \
70 --disable-static
71%{__make} -j1
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76%{__make} install \
77 DESTDIR=$RPM_BUILD_ROOT
78
79#cp doc/debugger.source $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
80#cp doc/debugger.tree $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
81#cp doc/debugger.zip $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
82
83# these are used just as DllImport in C# code, so no devel part
84rm $RPM_BUILD_ROOT%{_libdir}/libmonodebugger*.la
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post -p /sbin/ldconfig
90%postun -p /sbin/ldconfig
91
92%files
93%defattr(644,root,root,755)
94%doc AUTHORS COPYING ChangeLog NEWS README doc/*.txt
95%attr(755,root,root) %{_bindir}/mdb
96%attr(755,root,root) %{_bindir}/mdb-symbolreader
97%attr(755,root,root) %{_libdir}/libmonodebuggerreadline.so.*.*.*
98%attr(755,root,root) %ghost %{_libdir}/libmonodebuggerreadline.so.0
99%attr(755,root,root) %{_libdir}/libmonodebuggerreadline.so
100%attr(755,root,root) %{_libdir}/libmonodebuggerserver.so.*.*.*
101%attr(755,root,root) %ghost %{_libdir}/libmonodebuggerserver.so.0
102%attr(755,root,root) %{_libdir}/libmonodebuggerserver.so
103%{_prefix}/lib/mono/2.0/mdb-symbolreader.exe
104%{_prefix}/lib/mono/2.0/mdb.exe
105%{_prefix}/lib/mono/gac/Mono.Debugger
106%{_prefix}/lib/mono/gac/Mono.Debugger.SymbolWriter
107%{_libdir}/mono/gac/Mono.Debugger.Frontend
108
109%files devel
110%defattr(644,root,root,755)
111%dir %{_prefix}/lib/mono/%{name}
112%{_prefix}/lib/mono/%{name}/Mono.Debugger.dll
113%{_prefix}/lib/mono/%{name}/Mono.Debugger.SymbolWriter.dll
114%{_libdir}/mono/mono-debugger/Mono.Debugger.Frontend.dll
115%{_pkgconfigdir}/mono-debugger.pc
116%{_pkgconfigdir}/mono-debugger-frontend.pc
117
118#%files doc
119#%defattr(644,root,root,755)
120#%{_libdir}/monodoc/sources/*
This page took 0.031746 seconds and 4 git commands to generate.