]> git.pld-linux.org Git - packages/libskk.git/blame_incremental - libskk.spec
- updated remaining libgee deps
[packages/libskk.git] / libskk.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4%bcond_without static_libs # don't build static libraries
5%bcond_without fep # fep client
6#
7Summary: Library to deal with Japanese kana-to-kanji conversion method
8Summary(pl.UTF-8): Biblioteka obsługi metody konwersji tekstu japońskiego kana do kanji
9Name: libskk
10Version: 1.0.2
11Release: 2
12License: GPL v3+
13Group: Libraries
14#Source0Download: https://github.com/ueno/libskk/downloads
15Source0: https://github.com/ueno/libskk/releases/download/%{version}/%{name}-%{version}.tar.gz
16# Source0-md5: 26d5fedd29add95faae53dc90487330d
17URL: https://github.com/ueno/libskk/
18BuildRequires: gettext-devel
19BuildRequires: glib2-devel >= 2.0
20BuildRequires: gobject-introspection-devel >= 0.9.0
21BuildRequires: json-glib-devel
22BuildRequires: libgee-devel
23BuildRequires: pkgconfig
24# not needed for releases
25#BuildRequires: vala >= 2:0.14.0
26%{?with_apidocs:BuildRequires: valadoc >= 0.3.1}
27%if %{with fep}
28BuildRequires: libfep-devel >= 0.0.7
29BuildRequires: vala-libfep >= 0.0.7
30%endif
31BuildRequires: vala-libgee
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35libskk is a library to deal with Japanese kana-to-kanji conversion
36method.
37
38%description -l pl.UTF-8
39libskk to biblioteka do obsługi metody konwersji tekstu japońśkiego
40kana do kanji.
41
42%package fep
43Summary: skkfep - Japanese SKK input method on text terminal
44Summary(pl.UTF-8): skkfep - metoda wprowadzania znaków japońskich SKK z terminala tekstowego
45Group: Applications/Text
46Requires: %{name} = %{version}-%{release}
47Requires: libfep >= 0.0.7
48
49%description fep
50skkfep is a tool that allows to use Japanese input method called SKK
51(Simple Kana to Kanji conversion program) on ANSI compliant text
52terminals.
53
54%description fep -l pl.UTF-8
55skkfep to narzędzie pozwalające na używanie metody wprowadzania znaków
56japońskich SKK (Simple Kana to Kanji - konwersja uproszczonego kana do
57kanji) na terminalach tekstowych zgodnych z ANSI.
58
59%package devel
60Summary: Header files for libskk library
61Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libskk
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64Requires: glib2-devel >= 2.0
65Requires: json-glib-devel
66Requires: libgee-devel
67
68%description devel
69Header files for libskk library.
70
71%description devel -l pl.UTF-8
72Pliki nagłówkowe biblioteki libskk.
73
74%package static
75Summary: Static libskk library
76Summary(pl.UTF-8): Statyczna biblioteka libskk
77Group: Development/Libraries
78Requires: %{name}-devel = %{version}-%{release}
79
80%description static
81Static libskk library.
82
83%description static -l pl.UTF-8
84Statyczna biblioteka libskk.
85
86%package -n vala-libskk
87Summary: Vala API for libskk library
88Summary(pl.UTF-8): API języka Vala do biblioteki libskk
89Group: Development/Libraries
90Requires: %{name}-devel = %{version}-%{release}
91Requires: vala >= 2:0.14.0
92Requires: vala-libgee
93
94%description -n vala-libskk
95Vala API for libskk library.
96
97%description -n vala-libskk -l pl.UTF-8
98API języka Vala do biblioteki libskk.
99
100%package apidocs
101Summary: libskk API documentation
102Summary(pl.UTF-8): Dokumentacja API biblioteki libskk
103Group: Documentation
104
105%description apidocs
106API and internal documentation for libskk library.
107
108%description apidocs -l pl.UTF-8
109Dokumentacja API biblioteki libskk.
110
111%prep
112%setup -q
113
114%build
115# pass fake VALADOC_* args to avoid requiring valadoc-devel
116# (only utility is needed here, but configure checks for development package)
117%configure \
118 VALADOC_CFLAGS=fake \
119 VALADOC_LIBS=fake \
120 %{?with_apidocs:--enable-docs} \
121 %{?with_fep:--enable-fep} \
122 %{?with_static_libs:--enable-static}
123%{__make}
124
125%install
126rm -rf $RPM_BUILD_ROOT
127
128%{__make} install \
129 DESTDIR=$RPM_BUILD_ROOT \
130 libskkgtkdocdir=%{_gtkdocdir}/libskk
131
132# obsoleted by pkg-config
133%{__rm} $RPM_BUILD_ROOT%{_libdir}/libskk.la
134
135%find_lang %{name}
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%post -p /sbin/ldconfig
141%postun -p /sbin/ldconfig
142
143%files -f %{name}.lang
144%defattr(644,root,root,755)
145%doc ChangeLog NEWS README
146%attr(755,root,root) %{_bindir}/skk
147%attr(755,root,root) %{_libdir}/libskk.so.*.*.*
148%attr(755,root,root) %ghost %{_libdir}/libskk.so.0
149%{_libdir}/girepository-1.0/Skk-1.0.typelib
150%{_datadir}/libskk
151%{_mandir}/man1/skk.1*
152
153%if %{with fep}
154%files fep
155%defattr(644,root,root,755)
156%attr(755,root,root) %{_bindir}/skkfep
157%attr(755,root,root) %{_libdir}/skkfep-client
158%{_mandir}/man1/skkfep.1*
159%endif
160
161%files devel
162%defattr(644,root,root,755)
163%attr(755,root,root) %{_libdir}/libskk.so
164%{_datadir}/gir-1.0/Skk-1.0.gir
165%{_includedir}/libskk
166%{_pkgconfigdir}/libskk.pc
167
168%if %{with static_libs}
169%files static
170%defattr(644,root,root,755)
171%{_libdir}/libskk.a
172%endif
173
174%files -n vala-libskk
175%defattr(644,root,root,755)
176%{_datadir}/vala/vapi/skk-1.0.deps
177%{_datadir}/vala/vapi/skk-1.0.vapi
178
179%if %{with apidocs}
180%files apidocs
181%defattr(644,root,root,755)
182%{_gtkdocdir}/libskk
183# should it be here?
184%{_datadir}/devhelp/references/libskk
185%endif
This page took 0.055418 seconds and 4 git commands to generate.