]> git.pld-linux.org Git - packages/libdom.git/blame_incremental - libdom.spec
- removed outdated no-Werror patch
[packages/libdom.git] / libdom.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4
5Summary: Implementation of W3C DOM
6Summary(pl.UTF-8): Implementacja W3C DOM
7Name: libdom
8Version: 0.3.0
9Release: 1
10License: MIT
11Group: Libraries
12Source0: http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13# Source0-md5: 269bd1ceb4debfc1c3e3732a26ded992
14URL: http://www.netsurf-browser.org/projects/libdom/
15BuildRequires: expat-devel >= 1.95
16BuildRequires: libhubbub-devel >= 0.3.3
17BuildRequires: libparserutils-devel >= 0.2.3
18BuildRequires: libwapcaplet-devel >= 0.3.0
19BuildRequires: libxml2-devel >= 2.0
20BuildRequires: netsurf-buildsystem >= 1.5
21BuildRequires: pkgconfig
22Requires: libparserutils >= 0.2.3
23Requires: libwapcaplet >= 0.3.0
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27LibDOM is an implementation of the W3C DOM, written in C. It is
28currently in development for use with NetSurf and is intended to be
29suitable for use in other projects too.
30
31%description -l pl.UTF-8
32LibDOM to implementacja W3C DOM, napisana w C. Jest rozwijana do
33wykorzystania w ramach projektu NetSurf, ale także z myślą o
34możliwości użycia w innych projektach.
35
36%package devel
37Summary: libdom library headers
38Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libdom
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41Requires: expat-devel >= 1.95
42Requires: libhubbub-devel >= 0.3.1
43
44%description devel
45This package contains the include files and other resources you can
46use to incorporate libdom into applications.
47
48%description devel -l pl.UTF-8
49Pliki nagłówkowe pozwalające na używanie biblioteki libdom w swoich
50programach.
51
52%package static
53Summary: libdom static library
54Summary(pl.UTF-8): Statyczna biblioteka libdom
55Group: Development/Libraries
56Requires: %{name}-devel = %{version}-%{release}
57
58%description static
59This is package with static libdom library.
60
61%description static -l pl.UTF-8
62Statyczna biblioteka libdom.
63
64%prep
65%setup -q
66
67%build
68export AR="%{__ar}"
69export CC="%{__cc}"
70export CFLAGS="%{rpmcflags}"
71export LDFLAGS="%{rpmldflags}"
72
73%{__make} \
74 Q= \
75 PREFIX=%{_prefix} \
76 LIBDIR=%{_lib} \
77 COMPONENT_TYPE=lib-shared
78
79%if %{with static_libs}
80%{__make} \
81 Q= \
82 PREFIX=%{_prefix} \
83 LIBDIR=%{_lib} \
84 COMPONENT_TYPE=lib-static
85%endif
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90export AR="%{__ar}"
91export CC="%{__cc}"
92export CFLAGS="%{rpmcflags}"
93export LDFLAGS="%{rpmldflags}"
94
95%{__make} install \
96 Q= \
97 PREFIX=%{_prefix} \
98 LIBDIR=%{_lib} \
99 COMPONENT_TYPE=lib-shared \
100 DESTDIR=$RPM_BUILD_ROOT
101
102%if %{with static_libs}
103%{__make} install \
104 Q= \
105 PREFIX=%{_prefix} \
106 LIBDIR=%{_lib} \
107 COMPONENT_TYPE=lib-static \
108 DESTDIR=$RPM_BUILD_ROOT
109%endif
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(644,root,root,755)
119%doc COPYING README
120%attr(755,root,root) %{_libdir}/libdom.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libdom.so.0
122
123%files devel
124%defattr(644,root,root,755)
125%attr(755,root,root) %{_libdir}/libdom.so
126%{_includedir}/dom
127%{_pkgconfigdir}/libdom.pc
128
129%if %{with static_libs}
130%files static
131%defattr(644,root,root,755)
132%{_libdir}/libdom.a
133%endif
This page took 0.078328 seconds and 4 git commands to generate.