]> git.pld-linux.org Git - packages/libcmis.git/blame_incremental - libcmis.spec
- updated to 0.5.0 (note: new library names)
[packages/libcmis.git] / libcmis.spec
... / ...
CommitLineData
1#
2# Conditonal build:
3%bcond_without static_libs # static library
4#
5Summary: A C++ client library for the CMIS interface
6Summary(pl.UTF-8): Biblioteka klienta C++ dla inferfejsu CMIS
7Name: libcmis
8Version: 0.5.0
9Release: 1
10License: GPL v2+ or LGPL v2+ or MPL v1.1
11Group: Libraries
12Source0: http://downloads.sourceforge.net/libcmis/%{name}-%{version}.tar.gz
13# Source0-md5: 5821b806a98e6c38370970e682ce76e8
14URL: http://sourceforge.net/projects/libcmis/
15BuildRequires: autoconf >= 2.63
16BuildRequires: automake
17BuildRequires: boost-devel
18BuildRequires: cppunit-devel >= 1.12
19BuildRequires: curl-devel >= 7.12.3
20BuildRequires: docbook2X >= 0.8.8-4
21BuildRequires: libstdc++-devel
22BuildRequires: libtool >= 2:2
23BuildRequires: libxml2-devel >= 2.0
24BuildRequires: pkgconfig
25BuildRequires: sed >= 4.0
26Requires: curl-libs >= 7.12.3
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30LibCMIS is a C++ client library for the CMIS interface. This allows
31C++ applications to connect to any ECM behaving as a CMIS server like
32Alfresco, Nuxeo for the open source ones.
33
34%description -l pl.UTF-8
35LibCMIS to biblioteka klienta C++ dla interfejsu CMIS. Pozwala ona
36aplikacjom C++ na łączenie się z każdym ECM zachowującym się jako
37serwer CMIS, taki jak Alfresco, Nuxeo (biorąc pod uwagę implementacje
38o otwartych źródłach).
39
40%package devel
41Summary: Development files for CMIS library
42Summary(pl.UTF-8): Pliki nagłówkowe biblioteki CMIS
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: boost-devel
46Requires: curl-devel >= 7.12.3
47Requires: libstdc++-devel
48Requires: libxml2-devel >= 2.0
49
50%description devel
51This package contains the header files for developing applications
52that use CMIS library.
53
54%description devel -l pl.UTF-8
55Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
56bibliotece CMIS
57
58%package static
59Summary: Static CMIS library
60Summary(pl.UTF-8): Statyczna biblioteka CMIS
61Group: Development/Libraries
62Requires: %{name}-devel = %{version}-%{release}
63
64%description static
65Static CMIS library.
66
67%description static -l pl.UTF-8
68Statyczna biblioteka CMIS.
69
70%package tools
71Summary: Command line tool to access CMIS
72Summary(pl.UTF-8): Narzędzie wiersza poleceń dla CMIS
73Group: Applications/Publishing
74Requires: %{name} = %{version}-%{release}
75
76%description tools
77This package contains a tool for accessing CMIS from the command line.
78
79%description tools -l pl.UTF-8
80Ten pakiet zawiera narzędzie do łączenia się do CMIS z wiersza
81poleceń.
82
83%prep
84%setup -q
85
86#%{__sed} -i -e 's/docbook-to-man/docbook2X2man/' configure.ac
87
88%build
89%{__libtoolize}
90%{__aclocal} -I m4
91%{__autoconf}
92%{__automake}
93%configure \
94 DOCBOOK2MAN=/usr/bin/docbook2X2man \
95 --disable-silent-rules \
96 %{!?with_static_libs:--disable-static} \
97 --disable-tests \
98 --disable-werror
99
100%{__make}
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
105%{__make} install \
106 DESTDIR=$RPM_BUILD_ROOT
107
108# obsoleted by pkg-config
109%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(644,root,root,755)
119%doc AUTHORS ChangeLog NEWS README
120%attr(755,root,root) %{_libdir}/libcmis-0.5.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libcmis-0.5.so.5
122%attr(755,root,root) %{_libdir}/libcmis-c-0.5.so.*.*.*
123%attr(755,root,root) %ghost %{_libdir}/libcmis-c-0.5.so.5
124
125%files devel
126%defattr(644,root,root,755)
127%attr(755,root,root) %{_libdir}/libcmis-0.5.so
128%attr(755,root,root) %{_libdir}/libcmis-c-0.5.so
129%{_includedir}/libcmis-0.5
130%{_includedir}/libcmis-c-0.5
131%{_pkgconfigdir}/libcmis-0.5.pc
132%{_pkgconfigdir}/libcmis-c-0.5.pc
133
134%if %{with static_libs}
135%files static
136%defattr(644,root,root,755)
137%{_libdir}/libcmis-0.5.a
138%{_libdir}/libcmis-c-0.5.a
139%endif
140
141%files tools
142%defattr(644,root,root,755)
143%attr(755,root,root) %{_bindir}/cmis-client
144%{_mandir}/man1/cmis-client.1*
This page took 0.152863 seconds and 4 git commands to generate.