]> git.pld-linux.org Git - packages/libcmis.git/blame_incremental - libcmis.spec
boost rebuild
[packages/libcmis.git] / libcmis.spec
... / ...
CommitLineData
1#
2# Conditonal build:
3%bcond_without static_libs # static library
4#
5Summary: A C++ client library for the CMIS interface
6Summary(pl.UTF-8): Biblioteka klienta C++ dla inferfejsu CMIS
7Name: libcmis
8Version: 0.5.2
9Release: 8
10License: GPL v2+ or LGPL v2+ or MPL v1.1
11Group: Libraries
12#Source0Download: https://github.com/tdf/libcmis/releases
13Source0: https://github.com/tdf/libcmis/releases/download/v%{version}/%{name}-%{version}.tar.xz
14# Source0-md5: 3653bc54e1bcd17ae09a1a7086daa38b
15#Source0: http://downloads.sourceforge.net/libcmis/%{name}-%{version}.tar.gz
16URL: http://sourceforge.net/projects/libcmis/
17BuildRequires: autoconf >= 2.63
18BuildRequires: automake >= 1:1.10
19BuildRequires: boost-devel >= 1.36
20BuildRequires: cppunit-devel >= 1.12
21BuildRequires: curl-devel >= 7.12.3
22BuildRequires: docbook2X >= 0.8.8-4
23BuildRequires: libstdc++-devel >= 6:4.7
24BuildRequires: libtool >= 2:2
25BuildRequires: libxml2-devel >= 2.0
26BuildRequires: pkgconfig
27BuildRequires: tar >= 1:1.22
28BuildRequires: xz
29Requires: curl-libs >= 7.12.3
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33LibCMIS is a C++ client library for the CMIS interface. This allows
34C++ applications to connect to any ECM behaving as a CMIS server like
35Alfresco, Nuxeo for the open source ones.
36
37%description -l pl.UTF-8
38LibCMIS to biblioteka klienta C++ dla interfejsu CMIS. Pozwala ona
39aplikacjom C++ na łączenie się z każdym ECM zachowującym się jako
40serwer CMIS, taki jak Alfresco, Nuxeo (biorąc pod uwagę implementacje
41o otwartych źródłach).
42
43%package devel
44Summary: Development files for CMIS library
45Summary(pl.UTF-8): Pliki nagłówkowe biblioteki CMIS
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: boost-devel >= 1.36
49Requires: curl-devel >= 7.12.3
50Requires: libstdc++-devel
51Requires: libxml2-devel >= 2.0
52
53%description devel
54This package contains the header files for developing applications
55that use CMIS library.
56
57%description devel -l pl.UTF-8
58Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
59bibliotece CMIS
60
61%package static
62Summary: Static CMIS library
63Summary(pl.UTF-8): Statyczna biblioteka CMIS
64Group: Development/Libraries
65Requires: %{name}-devel = %{version}-%{release}
66
67%description static
68Static CMIS library.
69
70%description static -l pl.UTF-8
71Statyczna biblioteka CMIS.
72
73%package tools
74Summary: Command line tool to access CMIS
75Summary(pl.UTF-8): Narzędzie wiersza poleceń dla CMIS
76Group: Applications/Publishing
77Requires: %{name} = %{version}-%{release}
78
79%description tools
80This package contains a tool for accessing CMIS from the command line.
81
82%description tools -l pl.UTF-8
83Ten pakiet zawiera narzędzie do łączenia się do CMIS z wiersza
84poleceń.
85
86%prep
87%setup -q
88
89%build
90%{__libtoolize}
91%{__aclocal} -I m4
92%{__autoconf}
93%{__automake}
94%configure \
95 DOCBOOK2MAN=/usr/bin/docbook2X2man \
96 --disable-silent-rules \
97 %{!?with_static_libs:--disable-static} \
98 --disable-tests \
99 --disable-werror
100
101%{__make}
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106%{__make} install \
107 DESTDIR=$RPM_BUILD_ROOT
108
109# obsoleted by pkg-config
110%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post -p /sbin/ldconfig
116%postun -p /sbin/ldconfig
117
118%files
119%defattr(644,root,root,755)
120%doc AUTHORS ChangeLog NEWS
121%attr(755,root,root) %{_libdir}/libcmis-0.5.so.*.*.*
122%attr(755,root,root) %ghost %{_libdir}/libcmis-0.5.so.5
123%attr(755,root,root) %{_libdir}/libcmis-c-0.5.so.*.*.*
124%attr(755,root,root) %ghost %{_libdir}/libcmis-c-0.5.so.5
125
126%files devel
127%defattr(644,root,root,755)
128%attr(755,root,root) %{_libdir}/libcmis-0.5.so
129%attr(755,root,root) %{_libdir}/libcmis-c-0.5.so
130%{_includedir}/libcmis-0.5
131%{_includedir}/libcmis-c-0.5
132%{_pkgconfigdir}/libcmis-0.5.pc
133%{_pkgconfigdir}/libcmis-c-0.5.pc
134
135%if %{with static_libs}
136%files static
137%defattr(644,root,root,755)
138%{_libdir}/libcmis-0.5.a
139%{_libdir}/libcmis-c-0.5.a
140%endif
141
142%files tools
143%defattr(644,root,root,755)
144%attr(755,root,root) %{_bindir}/cmis-client
145%{_mandir}/man1/cmis-client.1*
This page took 0.038794 seconds and 4 git commands to generate.