]> git.pld-linux.org Git - packages/libapreq2.git/blame_incremental - libapreq2.spec
- use conf.d for apache config fragment; rel 5
[packages/libapreq2.git] / libapreq2.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4%bcond_with tests # perform "make test"
5#
6%include /usr/lib/rpm/macros.perl
7%define apxs /usr/sbin/apxs
8%define pdir libapreq2
9Summary: Apache Request Library
10Summary(pl.UTF-8): Biblioteka żądań Apache
11Name: libapreq2
12Version: 2.09
13Release: 5
14License: Apache 2.0
15Group: Libraries
16#Source0: http://www.apache.org/dist/httpd/libapreq/%{name}-%{version}.tar.gz
17Source0: http://people.apache.org/~pgollucci/apreq2/%{name}-%{version}.tar.gz
18# Source0-md5: 3cd98755da8a8431ef35a47461ad67d7
19Source1: apache-mod_apreq2.conf
20URL: http://httpd.apache.org/apreq/
21BuildRequires: %{apxs}
22BuildRequires: apache-base >= 2.0.46
23BuildRequires: apache-devel >= 2.0.46
24BuildRequires: apache-mod_perl-devel >= 1:2
25BuildRequires: apr-devel >= 1.0.0
26BuildRequires: autoconf >= 2.53
27BuildRequires: automake
28BuildRequires: libtool
29BuildRequires: perl-ExtUtils-XSBuilder >= 0.23
30%if %{with tests}
31BuildRequires: apache-mod_mime
32BuildRequires: perl-libwww
33%endif
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%define pkgconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
37%define pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
38
39%description
40libapreq is a safe, standards-compliant, high-performance library used
41for parsing HTTP cookies, query-strings and POST data.
42
43Version 2 of libapreq is an improved codebase designed around APR and
44Apache-2's input filter API.
45
46%description -l pl.UTF-8
47libapreq to bezpieczna, zgodna ze standardami, wysoko wydajna
48biblioteka służąca do przetwarzania ciasteczek HTTP, łańcuchów zapytań
49oraz danych POST.
50
51Wersja 2 libapreq to ulepszony kod opracowany na bazie APR i API
52filtra wejściowego Apache 2.
53
54%package devel
55Summary: libapreq2 header files
56Summary(pl.UTF-8): Pliki nagłówkowe libapreq2
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: apache-devel >= 2.0
60
61%description devel
62libapreq2 header files.
63
64%description devel -l pl.UTF-8
65Pliki nagłówkowe biblioteki libapreq2.
66
67%package static
68Summary: libapreq2 static library
69Summary(pl.UTF-8): Statyczna biblioteka libapreq2
70Group: Development/Libraries
71Requires: %{name}-devel = %{version}-%{release}
72
73%description static
74Static version of libapreq2 library.
75
76%description static -l pl.UTF-8
77Statyczna wersja biblioteki libapreq2.
78
79%package -n perl-%{name}
80Summary: Perl APIs for libapreq2 - Apache2::Request and Apache2::Cookie
81Summary(pl.UTF-8): Perlowe API dla libapreq2 - Apache2::Request i Apache2::Cookie
82Group: Development/Languages/Perl
83
84%description -n perl-%{name}
85Perl APIs for libapreq2 - Apache2::Request and Apache2::Cookie.
86
87%description -n perl-%{name} -l pl.UTF-8
88Perlowe API dla libapreq2 - Apache2::Request i Apache2::Cookie.
89
90%package -n apache-mod_apreq2
91Summary: Apache module mod_apreq2
92Summary(pl.UTF-8): Moduł serwera Apache mod_apreq2
93Group: Networking/Daemons
94Requires: apache(modules-api) = %apache_modules_api
95Obsoletes: apache-mod_libapreq2
96
97%description -n apache-mod_apreq2
98Apache module mod_apreq2.
99
100%description -n apache-mod_apreq2 -l pl.UTF-8
101Moduł mod_apreq2 do serwera Apache.
102
103%prep
104%setup -q
105
106%build
107%{__libtoolize}
108%{__aclocal}
109%{__autoheader}
110%{__autoconf}
111%{__automake}
112%configure \
113 --with-mm-opts="INSTALLDIRS=vendor" \
114 --enable-perl-glue \
115 --with-apache2-apxs=%{apxs} \
116 %{!?with_static_libs:--disable-static}
117
118%{__make}
119
120%{?with_tests:%{__make} test}
121
122%install
123rm -rf $RPM_BUILD_ROOT
124
125%{__make} install \
126 DESTDIR=$RPM_BUILD_ROOT
127
128rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/APR/{Request.pod,Request/*.pod}
129rm -f $RPM_BUILD_ROOT%{pkglibdir}/mod_apreq2.{a,la}
130install -D %{SOURCE1} $RPM_BUILD_ROOT%{pkgconfdir}/76_mod_apreq2.conf
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%post -p /sbin/ldconfig
136%postun -p /sbin/ldconfig
137
138%post -n apache-mod_apreq2
139%service -q httpd restart
140
141%preun -n apache-mod_apreq2
142if [ "$1" = "0" ]; then
143 %service -q httpd restart
144fi
145
146%files
147%defattr(644,root,root,755)
148%doc CHANGES README
149%attr(755,root,root) %{_libdir}/libapreq2.so.*.*
150
151%files devel
152%defattr(644,root,root,755)
153%attr(755,root,root) %{_libdir}/libapreq2.so
154%{_libdir}/libapreq2.la
155%{_includedir}/apreq2
156%attr(755,root,root) %{_bindir}/apreq2-config
157%dir %{_includedir}/apache/apreq2
158%{_includedir}/apache/apreq2/apreq_module_apache2.h
159
160%if %{with static_libs}
161%files static
162%defattr(644,root,root,755)
163%{_libdir}/libapreq2.a
164%endif
165
166%files -n perl-%{name}
167%defattr(644,root,root,755)
168%{perl_vendorarch}/Apache2/*.pm
169%{perl_vendorarch}/APR/*.pm
170%dir %{perl_vendorarch}/APR/Request
171%{perl_vendorarch}/APR/Request/*.pm
172%dir %{perl_vendorarch}/auto/APR/Request
173%dir %{perl_vendorarch}/auto/APR/Request/*
174%{perl_vendorarch}/auto/APR/Request/*/*.bs
175%attr(755,root,root) %{perl_vendorarch}/auto/APR/Request/*/*.so
176
177# TODO: generate these manually; Makefile.PL (and overall logic) is broken
178%{_mandir}/man3/Apache*
179%{_mandir}/man3/APR*
180
181%files -n apache-mod_apreq2
182%defattr(644,root,root,755)
183%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{pkgconfdir}/*_mod_apreq2.conf
184%attr(755,root,root) %{pkglibdir}/mod_apreq2.so
This page took 0.023567 seconds and 4 git commands to generate.