]> git.pld-linux.org Git - packages/lapack.git/blame_incremental - lapack.spec
- equivalence.c does not exist as part of manpages any longer
[packages/lapack.git] / lapack.spec
... / ...
CommitLineData
1Summary: The LAPACK libraries for numerical linear algebra
2Summary(pl.UTF-8): Biblioteki numeryczne LAPACK do algebry liniowej
3Name: lapack
4Version: 3.1.1
5Release: 1
6License: freely distributable
7Group: Development/Libraries
8Source0: http://www.netlib.org/lapack/%{name}-%{version}.tgz
9# Source0-md5: 00b21551a899bcfbaa7b8443e1faeef9
10Source1: http://www.netlib.org/lapack/manpages-%{version}.tgz
11# Source1-md5: e5b46d8915f7cc8a1e50aa3e70c9f86e
12Patch0: %{name}-automake_support.patch
13URL: http://www.netlib.org/lapack/
14BuildRequires: autoconf
15BuildRequires: automake
16BuildRequires: gcc-fortran
17BuildRequires: libtool >= 2:1.5
18Requires: blas = %{version}-%{release}
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22LAPACK (Linear Algebra PACKage) is a standard library for numerical
23linear algebra. LAPACK provides routines for solving systems of
24simultaneous linear equations, least-squares solutions of linear
25systems of equations, eigenvalue problems, and singular value
26problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
27Schur, and generalized Schur) and related computations (i.e.,
28reordering of Schur factorizations and estimating condition numbers)
29are also included. LAPACK can handle dense and banded matrices, but
30not general sparse matrices. Similar functionality is provided for
31real and complex matrices in both single and double precision. LAPACK
32is coded in Fortran77.
33
34%description -l pl.UTF-8
35LAPACK (Linear Algebra PACKage) jest standardową biblioteką numeryczną
36do algebry liniowej. Dostarcza funkcje rozwiązywania: układów równań
37liniowych, układów równań metodą najmniejszych kwadratów, problemów
38własnych. Zawiera algorytmy faktoryzacji macierzy (LU, Cholesky'ego,
39QR, SVD, Schura, uogólnioną Schura) i związanych z tym obliczeń (np.
40przenumerowywanie w faktoryzacji Schura i estymację uwarunkowania).
41LAPACK może obsługiwać macierze blokowe i pasmowe, ale nie rzadkie w
42ogólnym przypadku. Zapewnia funkcjonalność dla macierzy rzeczywistych
43i zespolonych, dla liczb pojedynczej i podwójnej precyzji. LAPACK jest
44napisany w Fortranie 77.
45
46%package devel
47Summary: LAPACK header files
48Summary(pl.UTF-8): Pliki nagłówkowe LAPACK
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51Requires: blas-devel = %{version}-%{release}
52Obsoletes: lapack-man
53
54%description devel
55LAPACK header files.
56
57%description devel -l pl.UTF-8
58Pliki nagłówkowe LAPACK.
59
60%package static
61Summary: Static LAPACK libraries
62Summary(pl.UTF-8): Biblioteki statyczne LAPACK
63Group: Development/Libraries
64Requires: %{name}-devel = %{version}-%{release}
65
66%description static
67Static LAPACK libraries.
68
69%description static -l pl.UTF-8
70Biblioteki statyczne LAPACK.
71
72%package -n blas
73Summary: The BLAS (Basic Linear Algebra Subprograms) library for Linux
74Summary(pl.UTF-8): Biblioteka BLAS (Basic Linear Algebra Subprograms) dla Linuksa
75Group: Development/Libraries
76Obsoletes: lapack-blas
77
78%description -n blas
79BLAS (Basic Linear Algebra Subprograms) is a standard library for
80numerical algebra. BLAS provides a number of basic algorithms for
81linear algebra. BLAS is fast and well-tested, was written in FORTRAN
8277.
83
84Warning: this is a reference implementation from Netlib. If possible,
85use version optimized for your architecture instead.
86
87%description -n blas -l pl.UTF-8
88BLAS (Basic Linear Algebra Subprograms) jest standardową biblioteką
89numeryczną algebry. Dostarcza wiele podstawowych algorytmów dla
90algebry liniowej. Jest szybka i dobrze przetestowana, została napisana
91w Fortranie 77.
92
93Ostrzeżenie: to jest implementacja przykładowa z repozytorium Netlib.
94Jeżeli to możliwe, należy używać zamiast niej wersji zoptymalizowanej
95pod daną architekturę.
96
97%package -n blas-devel
98Summary: BLAS header files
99Summary(pl.UTF-8): Pliki nagłówkowe BLAS
100Group: Development/Libraries
101Requires: blas = %{version}-%{release}
102Obsoletes: blas-man
103
104%description -n blas-devel
105BLAS header files.
106
107%description -n blas-devel -l pl.UTF-8
108Pliki nagłówkowe BLAS.
109
110%package -n blas-static
111Summary: Static BLAS libraries
112Summary(pl.UTF-8): Biblioteki statyczne BLAS
113Group: Development/Libraries
114Requires: blas-devel = %{version}-%{release}
115
116%description -n blas-static
117Static BLAS libraries.
118
119%description -n blas-static -l pl.UTF-8
120Biblioteki statyczne BLAS.
121
122%prep
123%setup -q -a1
124%patch0 -p1
125# directory INSTALL conflicts with file INSTALL needed by automake
126mv -f INSTALL install
127
128%build
129%{__libtoolize}
130%{__aclocal}
131%{__autoheader}
132%{__autoconf}
133%{__automake}
134%configure
135
136%{__make} \
137 LTTAG="--tag=F77"
138
139%install
140rm -rf $RPM_BUILD_ROOT
141
142%{__make} install \
143 DESTDIR=$RPM_BUILD_ROOT
144
145# present both in blas and lapack
146rm -f man/manl/{lsame,xerbla}.l
147
148install -d $RPM_BUILD_ROOT%{_mandir}/man3
149for d in man/manl/*.l blas/man/manl/*.l ; do
150 install $d $RPM_BUILD_ROOT%{_mandir}/man3/`basename $d .l`.3
151done
152
153echo "%defattr(644, root, root, 755)" > blasmans.list
154find blas/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> blasmans.list
155echo "%defattr(644, root, root, 755)" > mans.list
156find man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> mans.list
157
158%clean
159rm -fr $RPM_BUILD_ROOT
160
161%post -p /sbin/ldconfig
162%postun -p /sbin/ldconfig
163
164%post -n blas -p /sbin/ldconfig
165%postun -n blas -p /sbin/ldconfig
166
167%files
168%defattr(644,root,root,755)
169%doc README
170%attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
171
172%files devel -f mans.list
173%defattr(644,root,root,755)
174%attr(755,root,root) %{_libdir}/liblapack.so
175%{_libdir}/liblapack.la
176
177%files static
178%defattr(644,root,root,755)
179%{_libdir}/liblapack.a
180
181%files -n blas
182%defattr(644,root,root,755)
183%attr(755,root,root) %{_libdir}/libblas.so.*.*.*
184
185%files -n blas-devel -f blasmans.list
186%defattr(644,root,root,755)
187%attr(755,root,root) %{_libdir}/libblas.so
188%{_libdir}/libblas.la
189
190%files -n blas-static
191%defattr(644,root,root,755)
192%{_libdir}/libblas.a
This page took 0.03072 seconds and 4 git commands to generate.