]> git.pld-linux.org Git - packages/kmymoney.git/blame_incremental - kmymoney2.spec
- up to 4.6.4
[packages/kmymoney.git] / kmymoney2.spec
... / ...
CommitLineData
1#
2# TODO: - do something with rest of templates
3# - do we really need kmymoney2-devel package?
4# - drop fr_translation.patch when french translation is fixed
5# - consider rename to kmymoney
6#
7# Conditional build:
8%bcond_without kbanking # kbanking support
9#
10%define real_name kmymoney
11Summary: Personal finance application similar to Microsoft Money
12Summary(pl.UTF-8): Program do finansów osobistych, podobny do Microsoft Money
13Name: kmymoney2
14Version: 4.6.4
15Release: 1
16License: GPL v2+
17Group: X11/Applications
18Source0: http://downloads.sourceforge.net/kmymoney2/%{real_name}-%{version}.tar.xz
19# Source0-md5: 0674b9ef7ed5447e6a88b56a834389f8
20URL: http://kmymoney2.sourceforge.net/
21Patch0: %{name}-desktop.patch
22Patch1: %{name}-fr_translation.patch
23%{?with_kbanking:BuildRequires: aqbanking-devel >= 5.0.0}
24BuildRequires: automoc4
25BuildRequires: cmake
26%{?with_kbanking:BuildRequires: gwenhywfar-devel >= 4.0.0}
27%{?with_kbanking:BuildRequires: gwenhywfar-qt-devel >= 4.0.0}
28BuildRequires: kde4-kdelibs-devel
29BuildRequires: kde4-kdepimlibs-devel
30BuildRequires: gpgme-devel
31BuildRequires: libalkimia-devel >= 4.3.1
32BuildRequires: libassuan-devel
33BuildRequires: libical-c++-devel
34BuildRequires: libofx-devel >= 0.9.4
35BuildRequires: libxml++-devel
36BuildRequires: pth-devel
37BuildRequires: qt4-build
38BuildRequires: rpmbuild(macros) >= 1.600
39BuildRequires: soprano-devel
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
43KMyMoney is striving to be a full-featured replacement for your
44Windows-based finance software. We are a full double-entry accounting
45software package, for personal or small-business use.
46
47%description -l pl.UTF-8
48KMyMoney stara się być w pełni funkcjonalnym zamiennikiem dla
49windowsowych programów finansowych. Jest to kompletny system
50podwójnego księgowania przeznaczony do użytku osobistego i dla małych
51firm.
52
53%package devel
54Summary: kmymoney2 - header files
55Summary(pl.UTF-8): kmymoney2 - pliki nagłówkowe
56Summary(pt_BR.UTF-8): Arquivos de inclusão para compilar aplicativos kmymoney2
57Summary(ru.UTF-8): Хедеры для компилляции программ kmymoney2
58Summary(uk.UTF-8): Хедери для компіляції програм kmymoney2
59Group: X11/Development/Libraries
60Requires: %{name} = %{version}-%{release}
61
62%description devel
63This package contains header files for kMyMoney2.
64
65%description devel -l pl.UTF-8
66Pakiet ten zawiera pliki nagłówkowe potrzebne przy pisaniu własnych
67programów wykorzystujących kMyMoney2.
68
69%description devel -l pt_BR.UTF-8
70Este pacote contém os arquivos de inclusão que são necessários para
71compilar aplicativos kMyMoney2.
72
73%description devel -l ru.UTF-8
74Этот пакет содержит хедеры, необходимые для компиляции программ для
75kMyMoney2.
76
77%description devel -l uk.UTF-8
78Цей пакет містить хедери, необхідні для компіляції програм для
79kMyMoney2.
80
81%package kbanking
82Summary: KBanking plugin for KMyMoney2
83Summary(pl.UTF-8): Wtyczka KBanking dla KMyMoney2
84Group: X11/Libraries
85Requires: %{name} = %{version}-%{release}
86
87%description kbanking
88KBanking plugin for KMyMoney2.
89
90%description kbanking -l pl.UTF-8
91Wtyczka KBanking dla KMyMoney2.
92
93%prep
94%setup -q -n kmymoney-%{version}
95%patch0 -p1
96%patch1 -p1
97
98%build
99
100install -d build
101cd build
102%cmake .. \
103 %{?with_kbanking:-DENABLE_KBANKING="on"}
104
105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109install -d $RPM_BUILD_ROOT%{_desktopdir}
110
111%{__make} -C build install \
112 DESTDIR=$RPM_BUILD_ROOT
113
114%find_lang %{real_name} --with-kde
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
122%files -f %{real_name}.lang
123%defattr(644,root,root,755)
124%attr(755,root,root) %{_bindir}/kmymoney
125%attr(755,root,root) %{_libdir}/libkmm_kdchart.so.*.*.*
126%attr(755,root,root) %ghost %{_libdir}/libkmm_kdchart.so.4
127%attr(755,root,root) %{_libdir}/libkmm_mymoney.so.*.*.*
128%attr(755,root,root) %ghost %{_libdir}/libkmm_mymoney.so.4
129%attr(755,root,root) %{_libdir}/libkmm_plugin.so.*.*.*
130%attr(755,root,root) %ghost %{_libdir}/libkmm_plugin.so.4
131%attr(755,root,root) %{_libdir}/libkmm_widgets.so.*.*.*
132%attr(755,root,root) %ghost %{_libdir}/libkmm_widgets.so.4
133%attr(755,root,root) %{_libdir}/kde4/kcm_kmm_icalendarexport.so
134%attr(755,root,root) %{_libdir}/kde4/kcm_kmm_printcheck.so
135%attr(755,root,root) %{_libdir}/kde4/kmm_csvimport.so
136%attr(755,root,root) %{_libdir}/kde4/kmm_icalendarexport.so
137%attr(755,root,root) %{_libdir}/kde4/kmm_ofximport.so
138%attr(755,root,root) %{_libdir}/kde4/kmm_printcheck.so
139%attr(755,root,root) %{_libdir}/kde4/kmm_reconciliationreport.so
140%dir %{_datadir}/apps/kmymoney/
141%{_datadir}/apps/kmymoney/icons
142%{_datadir}/apps/kmymoney/html
143%{_datadir}/apps/kmymoney/misc
144%{_datadir}/apps/kmymoney/pics
145%dir %{_datadir}/apps/kmymoney/templates
146%{_datadir}/apps/kmymoney/templates/C
147%lang(de_AT) %{_datadir}/apps/kmymoney/templates/de_AT
148%lang(de_CH) %{_datadir}/apps/kmymoney/templates/de_CH
149%lang(de_DE) %{_datadir}/apps/kmymoney/templates/de_DE
150%lang(dk) %{_datadir}/apps/kmymoney/templates/dk
151%lang(el_GR) %{_datadir}/apps/kmymoney/templates/el_GR
152%lang(en_CA) %{_datadir}/apps/kmymoney/templates/en_CA
153%lang(en_GB) %{_datadir}/apps/kmymoney/templates/en_GB
154%lang(en_US) %{_datadir}/apps/kmymoney/templates/en_US
155%lang(es_AR) %{_datadir}/apps/kmymoney/templates/es_AR
156%lang(es_ES) %{_datadir}/apps/kmymoney/templates/es_ES
157%lang(es_MX) %{_datadir}/apps/kmymoney/templates/es_MX
158%lang(fr_CA) %{_datadir}/apps/kmymoney/templates/fr_CA
159%lang(fr_CH) %{_datadir}/apps/kmymoney/templates/fr_CH
160%lang(fr_FR) %{_datadir}/apps/kmymoney/templates/fr_FR
161%lang(gl_ES) %{_datadir}/apps/kmymoney/templates/gl_ES
162%lang(hu_HU) %{_datadir}/apps/kmymoney/templates/hu_HU
163%lang(it) %{_datadir}/apps/kmymoney/templates/it
164%lang(ja) %{_datadir}/apps/kmymoney/templates/jp
165%lang(nl_NL) %{_datadir}/apps/kmymoney/templates/nl_NL
166%lang(pt_PT) %{_datadir}/apps/kmymoney/templates/pt_PT
167%lang(pt_BR) %{_datadir}/apps/kmymoney/templates/pt_BR
168%lang(sk) %{_datadir}/apps/kmymoney/templates/sk
169%lang(ro_RO) %{_datadir}/apps/kmymoney/templates/ro_RO
170%lang(ru_RU) %{_datadir}/apps/kmymoney/templates/ru_RU
171%lang(tr_TR) %{_datadir}/apps/kmymoney/templates/tr_TR
172%lang(uk_UA) %{_datadir}/apps/kmymoney/templates/uk_UA
173%lang(zh_CN) %{_datadir}/apps/kmymoney/templates/zh_CN
174%lang(zh_HK) %{_datadir}/apps/kmymoney/templates/zh_HK
175%lang(zh_TW) %{_datadir}/apps/kmymoney/templates/zh_TW
176%{_datadir}/apps/kmymoney/tips
177%{_datadir}/apps/kmymoney/kmymoneyui.rc
178%dir %{_datadir}/apps/kmm_csvimport
179%{_datadir}/apps/kmm_csvimport/kmm_csvimport.rc
180%dir %{_datadir}/apps/kmm_icalendarexport
181%{_datadir}/apps/kmm_icalendarexport/kmm_icalendarexport.rc
182%dir %{_datadir}/apps/kmm_ofximport
183%{_datadir}/apps/kmm_ofximport/kmm_ofximport.rc
184%dir %{_datadir}/apps/kmm_printcheck
185%{_datadir}/apps/kmm_printcheck/check_template.html
186%{_datadir}/apps/kmm_printcheck/check_template_green_linen.html
187%{_datadir}/apps/kmm_printcheck/kmm_printcheck.rc
188%{_datadir}/config.kcfg/kmymoney.kcfg
189%{_datadir}/config/csvimporterrc
190%{_datadir}/mime/packages/x-kmymoney.xml
191%dir %{_iconsdir}/*
192%dir %{_iconsdir}/*/*
193%dir %{_iconsdir}/*/*/*
194%{_iconsdir}/*/*/*/*.png
195%{_desktopdir}/kde4/kmymoney.desktop
196%{_datadir}/kde4/services/*.desktop
197%{_datadir}/kde4/servicetypes/*.desktop
198%{_mandir}/man1/kmymoney.1*
199
200%files devel
201%defattr(644,root,root,755)
202%attr(755,root,root) %{_libdir}/libkmm_kdchart.so
203%attr(755,root,root) %{_libdir}/libkmm_mymoney.so
204%attr(755,root,root) %{_libdir}/libkmm_plugin.so
205%attr(755,root,root) %{_libdir}/libkmm_widgets.so
206%dir %{_includedir}/kmymoney
207%{_includedir}/kmymoney/*.h
208
209%if %{with kbanking}
210%files kbanking
211%defattr(644,root,root,755)
212%attr(755,root,root) %{_libdir}/kde4/kmm_kbanking.so
213%dir %{_datadir}/apps/kmm_kbanking
214%{_datadir}/apps/kmm_kbanking/kmm_kbanking.rc
215%endif
This page took 0.115146 seconds and 4 git commands to generate.