]> git.pld-linux.org Git - packages/kf5-attica.git/blame_incremental - kf5-attica.spec
- updated to 5.101.0
[packages/kf5-attica.git] / kf5-attica.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
5# TODO:
6# - runtime Requires if any
7
8%define kdeframever 5.101
9%define qtver 5.15.2
10%define kfname attica
11Summary: A Qt library that implements the Open Collaboration Services API
12Name: kf5-%{kfname}
13Version: 5.101.0
14Release: 1
15License: GPL v2+/LGPL v2.1+
16Group: X11/Libraries
17Source0: https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18# Source0-md5: a4c2e458aa82077a801ec5cb82594df9
19URL: http://www.kde.org/
20BuildRequires: Qt5Core-devel >= %{qtver}
21BuildRequires: Qt5Network-devel >= %{qtver}
22%if %{with tests}
23BuildRequires: Qt5Test-devel >= %{qtver}
24%endif
25BuildRequires: cmake >= 3.16
26BuildRequires: kf5-extra-cmake-modules >= %{version}
27BuildRequires: ninja
28BuildRequires: qt5-build >= %{qtver}
29BuildRequires: rpmbuild(macros) >= 1.736
30BuildRequires: tar >= 1:1.22
31BuildRequires: xz
32Requires: Qt5Core >= %{qtver}
33Requires: Qt5Network >= %{qtver}
34Requires: kf5-dirs
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38Attica is a Qt library that implements the Open Collaboration Services
39API version 1.6. The REST API is defined here:
40<http://freedesktop.org/wiki/Specifications/open-collaboration-services-draft/>.
41
42It grants easy access to the services such as querying information
43about persons and contents. The library is used in KNewStuff3 as
44content provider. In order to integrate with KDE's Plasma Desktop, a
45platform plugin exists in kdebase.
46
47%package devel
48Summary: Header files for %{kfname} development
49Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kfname}
50Group: X11/Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: Qt5Core-devel >= %{qtver}
53Requires: Qt5Network-devel >= %{qtver}
54
55%description devel
56Header files for %{kfname} development.
57
58%description devel -l pl.UTF-8
59Pliki nagłówkowe dla programistów używających %{kfname}.
60
61%prep
62%setup -q -n %{kfname}-%{version}
63
64%build
65install -d build
66cd build
67%cmake -G Ninja \
68 %{!?with_tests:-DBUILD_TESTING=OFF} \
69 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
70 ..
71%ninja_build
72
73%{?with_tests:%ninja_build test}
74
75
76%install
77rm -rf $RPM_BUILD_ROOT
78%ninja_install -C build
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%post -p /sbin/ldconfig
84%postun -p /sbin/ldconfig
85
86%files
87%defattr(644,root,root,755)
88%doc AUTHORS README.md
89%attr(755,root,root) %{_libdir}/libKF5Attica.so.*.*.*
90%ghost %{_libdir}/libKF5Attica.so.5
91%{_datadir}/qlogging-categories5/attica.categories
92%{_datadir}/qlogging-categories5/attica.renamecategories
93
94%files devel
95%defattr(644,root,root,755)
96%{_libdir}/libKF5Attica.so
97%{_includedir}/KF5/Attica
98%{_libdir}/cmake/KF5Attica
99%{_pkgconfigdir}/libKF5Attica.pc
100%{_libdir}/qt5/mkspecs/modules/qt_Attica.pri
This page took 0.052395 seconds and 4 git commands to generate.