]> git.pld-linux.org Git - packages/ka5-kblocks.git/blame_incremental - ka5-kblocks.spec
- bcond_with tests
[packages/ka5-kblocks.git] / ka5-kblocks.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # build with tests
4%define kdeappsver 21.12.3
5%define kframever 5.56.0
6%define qtver 5.9.0
7%define kaname kblocks
8Summary: Kblocks
9Name: ka5-%{kaname}
10Version: 21.12.3
11Release: 1
12License: GPL v2+/LGPL v2.1+
13Group: X11/Applications/Games
14Source0: http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15# Source0-md5: 59948ed58c17791b0c34e52a8ee39136
16URL: http://www.kde.org/
17BuildRequires: Qt5Core-devel >= %{qtver}
18BuildRequires: Qt5Gui-devel >= 5.11.1
19BuildRequires: Qt5Network-devel
20BuildRequires: Qt5Qml-devel >= 5.11.1
21BuildRequires: Qt5Quick-devel >= 5.11.1
22BuildRequires: Qt5Svg-devel
23BuildRequires: Qt5Widgets-devel
24BuildRequires: cmake >= 2.8.12
25BuildRequires: gettext-devel
26BuildRequires: ka5-libkdegames-devel >= %{kdeappsver}
27BuildRequires: kf5-extra-cmake-modules >= %{kframever}
28BuildRequires: kf5-kconfig-devel >= %{kframever}
29BuildRequires: kf5-kconfigwidgets-devel >= %{kframever}
30BuildRequires: kf5-kcoreaddons-devel >= %{kframever}
31BuildRequires: kf5-kcrash-devel >= %{kframever}
32BuildRequires: kf5-kdbusaddons-devel >= %{kframever}
33BuildRequires: kf5-kdoctools-devel >= %{kframever}
34BuildRequires: kf5-ki18n-devel >= %{kframever}
35BuildRequires: kf5-kwidgetsaddons-devel >= %{kframever}
36BuildRequires: kf5-kxmlgui-devel >= %{kframever}
37BuildRequires: ninja
38BuildRequires: qt5-build >= %{qtver}
39BuildRequires: rpmbuild(macros) >= 1.164
40BuildRequires: shared-mime-info
41BuildRequires: tar >= 1:1.22
42BuildRequires: xz
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45%description
46KBlocks is the classic falling blocks game. The idea is to stack the
47falling blocks to create horizontal lines without any gaps. When a
48line is completed it is removed, and more space is available in the
49play area. When there is not enough space for blocks to fall, the game
50is over.
51
52%description -l pl.UTF-8
53KBlocks jest klasyczną grą w spadające bloki. Ideą gry jest
54układać spadające bloki tak, aby tworzyły poziome linie bez przerw.
55Kompletne linie są usuwane i robi się więcej miejsca w obszarze gry.
56Gdy nie ma już miejsca na spadające bloki, gra się kończy.
57
58%prep
59%setup -q -n %{kaname}-%{version}
60
61%build
62install -d build
63cd build
64%cmake \
65 -G Ninja \
66 %{!?with_tests:-DBUILD_TESTING=OFF} \
67 -DHTML_INSTALL_DIR=%{_kdedocdir} \
68 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
69 ..
70%ninja_build
71
72%if %{with tests}
73ctest
74%endif
75
76
77%install
78rm -rf $RPM_BUILD_ROOT
79%ninja_install -C build
80
81%find_lang %{kaname} --all-name --with-kde
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%files -f %{kaname}.lang
87%defattr(644,root,root,755)
88%attr(755,root,root) %{_bindir}/kblocks
89%{_desktopdir}/org.kde.kblocks.desktop
90%{_datadir}/config.kcfg/kblocks.kcfg
91%{_iconsdir}/hicolor/128x128/apps/kblocks.png
92%{_iconsdir}/hicolor/16x16/apps/kblocks.png
93%{_iconsdir}/hicolor/22x22/apps/kblocks.png
94%{_iconsdir}/hicolor/32x32/apps/kblocks.png
95%{_iconsdir}/hicolor/48x48/apps/kblocks.png
96%{_iconsdir}/hicolor/64x64/apps/kblocks.png
97%{_datadir}/kblocks
98%{_datadir}/kxmlgui5/kblocks
99%{_datadir}/metainfo/org.kde.kblocks.appdata.xml
100%{_datadir}/qlogging-categories5/kblocks.categories
101%{_datadir}/knsrcfiles/kblocks.knsrc
This page took 0.05048 seconds and 4 git commands to generate.