]> git.pld-linux.org Git - packages/gtk-webkit.git/blame_incremental - gtk-webkit.spec
build fixes from arch
[packages/gtk-webkit.git] / gtk-webkit.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without introspection # disable introspection
4#
5# it's not possible to build this with debuginfo on 32bit archs due to
6# memory constraints during linking
7%ifarch %{ix86} x32
8%define _enable_debug_packages 0
9%endif
10Summary: Port of WebKit embeddable web component to GTK+ 2
11Summary(pl.UTF-8): Port osadzalnego komponentu WWW WebKit do GTK+ 2
12Name: gtk-webkit
13# note: 2.4.x is the last series with webkitgtk-1 API and GTK+ 2.x support
14Version: 2.4.11
15Release: 8
16License: BSD-like
17Group: X11/Libraries
18Source0: http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
19# Source0-md5: 24a25ccc30a7914ae50922aedf24b7bc
20Patch0: x32.patch
21Patch1: abs.patch
22Patch2: %{name}-icu59.patch
23Patch3: %{name}-icu65.patch
24Patch4: glib2.68.patch
25Patch5: icu68.patch
26Patch6: grammar.patch
27Patch7: volatile.patch
28URL: http://webkitgtk.org/
29BuildRequires: /usr/bin/ld.gold
30BuildRequires: EGL-devel
31BuildRequires: OpenGL-GLX-devel
32BuildRequires: at-spi2-core-devel >= 2.6.0
33BuildRequires: autoconf >= 2.60
34BuildRequires: automake
35BuildRequires: bison >= 1.875
36BuildRequires: cairo-devel >= 1.10
37BuildRequires: enchant-devel >= 0.22
38BuildRequires: flex >= 2.5.33
39BuildRequires: fontconfig-devel >= 2.5.0
40BuildRequires: freetype-devel >= 1:2.1.8
41BuildRequires: gcc-c++ >= 6:4.7
42BuildRequires: geoclue2-devel >= 2.1.5
43BuildRequires: gettext-tools
44BuildRequires: glib2-devel >= 1:2.36.0
45BuildRequires: glibc-misc
46%{?with_introspection:BuildRequires: gobject-introspection-devel >= 1.32.0}
47BuildRequires: gperf
48BuildRequires: gstreamer-devel >= 1.0.3
49BuildRequires: gstreamer-plugins-base-devel >= 1.0.3
50BuildRequires: libstdc++-devel >= 6:4.7
51BuildRequires: gtk+2-devel >= 2:2.24.10
52BuildRequires: gtk-doc >= 1.10
53BuildRequires: harfbuzz-devel >= 0.9.7
54BuildRequires: harfbuzz-icu-devel >= 0.9.7
55BuildRequires: libicu-devel >= 59
56BuildRequires: libjpeg-devel
57BuildRequires: libpng-devel
58BuildRequires: libsecret-devel
59BuildRequires: libsoup-devel >= 2.42.0
60BuildRequires: libstdc++-devel
61# libtool with -fuse-ld= gcc option support
62BuildRequires: libtool >= 2:2.4.2-13
63BuildRequires: libwebp-devel
64BuildRequires: libxml2-devel >= 1:2.6.30
65BuildRequires: libxslt-devel >= 1.1.7
66BuildRequires: pango-devel >= 1:1.32.0
67BuildRequires: perl-base
68BuildRequires: pkgconfig
69BuildRequires: python
70BuildRequires: rpmbuild(macros) >= 1.592
71BuildRequires: ruby
72BuildRequires: sqlite3-devel >= 3
73BuildRequires: tar >= 1:1.22
74BuildRequires: udev-glib-devel
75BuildRequires: xorg-lib-libXcomposite-devel
76BuildRequires: xorg-lib-libXdamage-devel
77BuildRequires: xorg-lib-libXrender-devel
78BuildRequires: xorg-lib-libXt-devel
79BuildRequires: xz
80BuildRequires: zlib-devel
81Requires: cairo >= 1.10
82Requires: enchant >= 0.22
83Requires: fontconfig-libs >= 2.5.0
84Requires: freetype >= 1:2.1.8
85Requires: glib2 >= 1:2.36.0
86Requires: gstreamer >= 1.0.3
87Requires: gstreamer-plugins-base >= 1.0.3
88Requires: gtk+2 >= 2:2.24.10
89Requires: harfbuzz >= 0.9.7
90Requires: libsoup >= 2.42.0
91Requires: libxml2 >= 1:2.6.30
92Requires: libxslt >= 1.1.7
93Requires: pango >= 1:1.32.0
94%{?with_introspection:Conflicts: gir-repository < 0.6.5-7}
95BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97# __once_call, __once_called non-function symbols from libstdc++
98%define skip_post_check_so lib.*gtk-1.0.*
99
100%description
101gtk-webkit is a port of the WebKit embeddable web component to GTK+ 2.
102
103%description -l pl.UTF-8
104gtk-webkit to port osadzalnego komponentu WWW WebKit do GTK+ 2.
105
106%package devel
107Summary: Development files for WebKit for GTK+ 2
108Summary(pl.UTF-8): Pliki programistyczne komponentu WebKit dla GTK+ 2
109Group: X11/Development/Libraries
110Requires: %{name} = %{version}-%{release}
111Requires: glib2-devel >= 1:2.36.0
112Requires: gtk+2-devel >= 2:2.24.10
113Requires: libsoup-devel >= 2.42.0
114Requires: libstdc++-devel
115
116%description devel
117Development files for WebKit for GTK+ 2.
118
119%description devel -l pl.UTF-8
120Pliki programistyczne komponentu WebKit dla GTK+ 2.
121
122%prep
123%setup -q -n webkitgtk-%{version}
124%patch0 -p1
125%patch1 -p1
126%patch2 -p1
127%patch3 -p1
128%patch4 -p1
129%patch5 -p1
130%patch6 -p1
131%patch7 -p1
132
133%build
134%{__libtoolize}
135%{__aclocal} -I Source/autotools
136%{__autoconf}
137%{__autoheader}
138%{__automake}
139%if "%{cxx_version}" >= "4.9"
140CXXFLAGS="%{rpmcxxflags} -fno-delete-null-pointer-checks"
141%endif
142%configure \
143%ifarch %{x8664}
144 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
145%else
146 LDFLAGS="%{rpmldflags} -fuse-ld=bfd -Wl,--no-keep-memory" \
147%endif
148 --disable-gtk-doc \
149 --disable-silent-rules \
150 --disable-webkit2 \
151 --enable-geolocation \
152 --enable-glx \
153 %{__enable_disable introspection} \
154 --enable-webgl \
155 --with-gtk=2.0 \
156 --with-html-dir=%{_gtkdocdir}
157
158%{__make} -j1
159
160%install
161rm -rf $RPM_BUILD_ROOT
162
163%{__make} install \
164 DESTDIR=$RPM_BUILD_ROOT
165
166# obsoleted by pkg-config
167%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*-1.0.la
168# packaged in gtk-webkit3
169%{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/{webkitgtk,webkitdomgtk}
170
171%find_lang WebKitGTK-2.0
172
173%clean
174rm -rf $RPM_BUILD_ROOT
175
176%post -p /sbin/ldconfig
177%postun -p /sbin/ldconfig
178
179%files -f WebKitGTK-2.0.lang
180%defattr(644,root,root,755)
181%doc ChangeLog NEWS
182%attr(755,root,root) %{_bindir}/jsc-1
183%attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so.*.*.*
184%attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-1.0.so.0
185%attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so.*.*.*
186%attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-1.0.so.0
187%if %{with introspection}
188%{_libdir}/girepository-1.0/JavaScriptCore-1.0.typelib
189%{_libdir}/girepository-1.0/WebKit-1.0.typelib
190%endif
191%dir %{_datadir}/webkitgtk-1.0
192%{_datadir}/webkitgtk-1.0/images
193%{_datadir}/webkitgtk-1.0/resources
194
195%files devel
196%defattr(644,root,root,755)
197%attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so
198%attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so
199%if %{with introspection}
200%{_datadir}/gir-1.0/JavaScriptCore-1.0.gir
201%{_datadir}/gir-1.0/WebKit-1.0.gir
202%endif
203%{_includedir}/webkitgtk-1.0
204%{_pkgconfigdir}/javascriptcoregtk-1.0.pc
205%{_pkgconfigdir}/webkit-1.0.pc
This page took 0.023724 seconds and 4 git commands to generate.