]> git.pld-linux.org Git - packages/gpac.git/blame_incremental - gpac.spec
- disable javascript, gpac is the last and only package that requires js < 1.8.5
[packages/gpac.git] / gpac.spec
... / ...
CommitLineData
1# TODO:
2# - Platinum UPnP: http://www.plutinosoft.com/platinum
3# - AVCap: http://libavcap.sourceforge.net/
4# - OpenSVCDecoder: http://opensvcdecoder.sourceforge.net/
5# - libfreenect: http://openkinect.org/wiki/Main_Page
6#
7# Conditional build:
8%bcond_with amr # AMR-NB and AMR-WB (floating-point) support
9%bcond_without directfb # DirectFB support
10%bcond_without faad # AAC decoding support
11%bcond_without ffmpeg # ffmpeg support
12%bcond_without freetype # freetype support
13%bcond_without jpeg # JPEG support
14%bcond_with js # JavaScript support
15%bcond_without mad # MP3 support
16%bcond_without png # PNG support
17%bcond_without xvid # xvid support
18%bcond_without wx # wxWidgets support
19#
20Summary: GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
21Summary(pl.UTF-8): GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
22Name: gpac
23Version: 0.5.0
24Release: 7
25License: LGPL v2+
26Group: Applications/Multimedia
27Source0: http://downloads.sourceforge.net/gpac/%{name}-%{version}.tar.gz
28# Source0-md5: 19f7bb7c16913c22bdd453db1e653ca0
29Patch0: %{name}-install.patch
30Patch1: %{name}-xulrunner.patch
31Patch2: %{name}-amr.patch
32Patch3: %{name}-install-is-not-clean.patch
33Patch4: %{name}-flags.patch
34Patch5: %{name}-idl_uuid.patch
35Patch6: %{name}-js.patch
36Patch7: %{name}-apps.patch
37Patch8: %{name}-export.patch
38URL: http://gpac.sourceforge.net/
39%{?with_directfb:BuildRequires: DirectFB-devel}
40BuildRequires: OpenGL-GLU-devel
41BuildRequires: SDL-devel
42BuildRequires: a52dec-libs-devel
43BuildRequires: alsa-lib-devel >= 0.9
44%{?with_amr:BuildRequires: amrnb-devel}
45%{?with_amr:BuildRequires: amrwb-devel}
46%{?with_faad:BuildRequires: faad2-devel}
47%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.6}
48%{?with_freetype:BuildRequires: freetype-devel}
49%{?with_wx:BuildRequires: gtk+2-devel >= 2:2.20.1}
50BuildRequires: jack-audio-connection-kit-devel
51%{?with_js:BuildRequires: js-devel < 2:1.8.5}
52%{?with_jpeg:BuildRequires: libjpeg-devel}
53%{?with_mad:BuildRequires: libmad-devel}
54BuildRequires: libogg-devel
55%{?with_png:BuildRequires: libpng-devel}
56BuildRequires: libtheora-devel
57BuildRequires: libvorbis-devel
58BuildRequires: libxml2-devel
59BuildRequires: openjpeg-devel
60BuildRequires: openssl-devel
61BuildRequires: pkgconfig
62BuildRequires: pulseaudio-devel
63BuildRequires: rpmbuild(macros) >= 1.357
64BuildRequires: sed >= 4.0
65BuildRequires: unzip
66%{?with_wx:BuildRequires: wxGTK2-unicode-devel >= 2.6.0}
67BuildRequires: xmlrpc-c-server-devel
68BuildRequires: xorg-lib-libXext-devel
69BuildRequires: xorg-lib-libXv-devel
70BuildRequires: xulrunner-devel >= 2:9.0.0
71%{?with_xvid:BuildRequires: xvid-devel}
72BuildRequires: zlib-devel
73BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75%description
76GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
7714496-1) developed from scratch in ANSI C.
78
79The main development goal is to provide a clean (a.k.a. readable by as
80many people as possible), small and flexible alternative to the MPEG-4
81Systems reference software (known as IM1 and distributed in ISO/IEC
8214496-5). The MPEG-4 Reference software is indeed a very large piece
83of software, designed to verify the standard rather than provide a
84small, production-stable software. GPAC is written in ANSI C for
85portability reasons (embedded platforms and DSPs) with a simple goal:
86keep the memory footprint as low as possible. The project will at term
87provide player(s), systems encoders and publishing tools for content
88distribution.
89
90%description -l pl.UTF-8
91GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
92stworzona od zera w ANSI C.
93
94Głównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
95dla jak największej liczby ludzi), małej i elastycznej alternatywy dla
96wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
97rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
98jest bardzo dużą porcją kodu, zaprojektowaną raczej do zweryfikowania
99standardu niż dostarczenia małej, stabilnej wersji produkcyjnej. GPAC
100jest pisany w ANSI C ze względu na przenośność (platformy wbudowane i
101DSP) z prostym celem: wymagać tak mało pamięci, jak to tylko możliwe.
102Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzędzia
103do publikacji w celu dystrybucji materiałów.
104
105%package devel
106Summary: Header files for GPAC library
107Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GPAC
108Group: Development/Libraries
109Requires: %{name} = %{version}-%{release}
110
111%description devel
112Header files for GPAC library.
113
114%description devel -l pl.UTF-8
115Pliki nagłówkowe biblioteki GPAC.
116
117%package static
118Summary: Static GPAC library
119Summary(pl.UTF-8): Statyczna biblioteka GPAC
120Group: Development/Libraries
121Requires: %{name}-devel = %{version}-%{release}
122
123%description static
124Static GPAC library.
125
126%description static -l pl.UTF-8
127Statyczna biblioteka GPAC.
128
129%package gui
130Summary: wxWidgets-based GUI for GPAC
131Summary(pl.UTF-8): Oparty na wxWidgets graficzny interfejs do GPAC
132Group: X11/Applications/Multimedia
133Requires: %{name} = %{version}-%{release}
134
135%description gui
136Osmo4 - wxWidgets-based GUI for GPAC.
137
138%description gui -l pl.UTF-8
139Osmo4 - oparty na wxWidgets graficzny interfejs do GPAC.
140
141%package -n browser-plugin-%{name}
142Summary: GPAC browser plugin
143Summary(pl.UTF-8): Wtyczka GPAC do przegląderek WWW
144Group: X11/Libraries
145Requires: %{name} = %{version}-%{release}
146Requires: browser-plugins >= 2.0
147Requires: browser-plugins(%{_target_base_arch})
148
149%description -n browser-plugin-%{name}
150GPAC plugin for Netscape-compatible WWW browsers.
151
152%description -n browser-plugin-%{name} -l pl.UTF-8
153Wtyczka GPAC dla przeglądarek WWW zgodnych z Netscape.
154
155%prep
156%setup -q -n %{name}
157%patch0 -p1
158%patch1 -p1
159%patch2 -p1
160%patch3 -p1
161%patch4 -p1
162%patch5 -p1
163%patch6 -p1
164%patch7 -p1
165%patch8 -p1
166
167sed -i -e 's/wx-config/wx-gtk2-unicode-config/' configure
168chmod a+x configure
169
170%build
171# not autoconf configure
172./configure \
173 --prefix=%{_prefix} \
174 --libdir=%{_lib} \
175 --mandir=%{_mandir} \
176 --X11-path=/usr \
177 --cc="%{__cc}" \
178 --cpp="%{__cxx}" \
179 --disable-opt \
180 %{!?with_wx:--disable-wx} \
181 %{?with_amr:--enable-amr} \
182 --enable-joystick \
183 --enable-pic \
184 --extra-cflags="%{rpmcflags}" \
185 --extra-ldflags="%{rpmldflags}" \
186 --mozdir=%{_browserpluginsdir} \
187 %{!?with_faad:--use-faad=no} \
188 %{!?with_ffmpeg:--use-ffmpeg=no} \
189 %{!?with_freetype:--use-ft=no} \
190 %{!?with_jpeg:--use-jpeg=no} \
191 %{!?with_js:--use-js=no} \
192 %{!?with_mad:--use-mad=no} \
193 %{!?with_png:--use-png=no} \
194 %{!?with_xvid:--use-xvid=no} \
195 --xulsdk-path="/usr/include/xulrunner -I/usr/include/nspr"
196
197%{!?with_directfb: sed -i 's/CONFIG_DIRECTFB.*/CONFIG_DIRECTFB=no/' config.mak}
198
199%{__make} -j1
200
201%install
202rm -rf $RPM_BUILD_ROOT
203install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
204
205%{__make} install install-lib \
206 DESTDIR=$RPM_BUILD_ROOT
207
208%{__make} -C applications install \
209 DESTDIR=$RPM_BUILD_ROOT \
210 MOZILLA_DIR=$RPM_BUILD_ROOT%{_browserpluginsdir}
211
212%clean
213rm -rf $RPM_BUILD_ROOT
214
215%post -p /sbin/ldconfig
216%postun -p /sbin/ldconfig
217
218%post -n browser-plugin-%{name}
219%update_browser_plugins
220
221%postun -n browser-plugin-%{name}
222if [ "$1" = 0 ]; then
223 %update_browser_plugins
224fi
225
226%files
227%defattr(644,root,root,755)
228%doc AUTHORS BUGS Changelog README TODO
229%attr(755,root,root) %{_bindir}/MP4Box
230%attr(755,root,root) %{_bindir}/MP4Client
231%attr(755,root,root) %{_libdir}/libgpac.so.*.*.*
232%attr(755,root,root) %ghost %{_libdir}/libgpac.so.2
233%dir %{_libdir}/gpac
234%attr(755,root,root) %{_libdir}/gpac/gm_*.so
235%{_datadir}/gpac
236%{_mandir}/man1/gpac.1*
237%{_mandir}/man1/mp4box.1*
238%{_mandir}/man1/mp4client.1*
239
240%files devel
241%defattr(644,root,root,755)
242%attr(755,root,root) %{_libdir}/libgpac.so
243%{_includedir}/gpac
244%{_pkgconfigdir}/gpac.pc
245
246%files static
247%defattr(644,root,root,755)
248%{_libdir}/libgpac_static.a
249
250%if %{with wx}
251%files gui
252%defattr(644,root,root,755)
253%attr(755,root,root) %{_bindir}/Osmo4
254%endif
255
256%files -n browser-plugin-%{name}
257%defattr(644,root,root,755)
258%attr(755,root,root) %{_browserpluginsdir}/nposmozilla.so
259%{_browserpluginsdir}/nposmozilla.xpt
This page took 0.074852 seconds and 4 git commands to generate.