]> git.pld-linux.org Git - packages/gpac.git/blame_incremental - gpac.spec
- tabs in preamble
[packages/gpac.git] / gpac.spec
... / ...
CommitLineData
1# TODO
2# - soname for libm4systems(?)
3# - use system mozilla includes
4# - ./configure[692]: wx-config: not found
5# - ./configure[693]: wx-config: not found
6# - CC, CFLAGS
7# - Xiph Theora: no
8#
9# Conditional build:
10%bcond_with amr
11%bcond_without faad
12%bcond_without ffmpeg
13%bcond_without freetype
14%bcond_without jpeg
15%bcond_without js
16%bcond_without mad
17%bcond_without png
18%bcond_without xvid
19%bcond_with wx
20#
21Summary: GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
22Summary(pl.UTF-8): GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
23Name: gpac
24Version: 0.4.0
25Release: 4
26License: LGPL
27Group: Applications
28Source0: http://dl.sourceforge.net/gpac/%{name}-%{version}.tar.gz
29# Source0-md5: a8b4b3206cabda946850240f1e7aea93
30Source1: http://www.3gpp.org/ftp/Specs/archive/26_series/26.073/26073-530.zip
31# Source1-md5: 705f6993fbf890e92eb7a331e7c716d1
32Patch0: %{name}-install.patch
33Patch1: %{name}-wxWidgets.patch
34Patch2: %{name}-amd64.patch
35Patch3: %{name}-libdir.patch
36URL: http://gpac.sourceforge.net/
37BuildRequires: SDL-devel
38%{?with_faad:BuildRequires: faad2-devel}
39%{?with_ffmpeg:BuildRequires: ffmpeg-devel}
40%{?with_freetype:BuildRequires: freetype-devel}
41%{?with_js:BuildRequires: js-devel}
42%{?with_jpeg:BuildRequires: libjpeg-devel}
43%{?with_mad:BuildRequires: libmad-devel}
44%{?with_png:BuildRequires: libpng-devel}
45BuildRequires: libxml2-devel
46BuildRequires: rpmbuild(macros) >= 1.357
47%{?with_wx:BuildRequires: wxGTK2-devel >= 2.5.4}
48%{?with_xvid:BuildRequires: xvid-devel}
49Requires: SDL
50%{?with_faad:Requires: faad2}
51%{?with_ffmpeg:Requires: ffmpeg}
52%{?with_freetype:Requires: freetype}
53%{?with_js:Requires: js}
54%{?with_jpeg:Requires: libjpeg}
55%{?with_mad:Requires: libmad}
56%{?with_png:Requires: libpng}
57%{?with_xvid:Requires: xvid}
58BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60%define _noautoreq libm4systems.so
61
62%description
63GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
6414496-1) developed from scratch in ANSI C.
65
66The main development goal is to provide a clean (a.k.a. readable by as
67many people as possible), small and flexible alternative to the MPEG-4
68Systems reference software (known as IM1 and distributed in ISO/IEC
6914496-5). The MPEG-4 Reference software is indeed a very large piece
70of software, designed to verify the standard rather than provide a
71small, production-stable software. GPAC is written in ANSI C for
72portability reasons (embedded platforms and DSPs) with a simple goal:
73keep the memory footprint as low as possible. The project will at term
74provide player(s), systems encoders and publishing tools for content
75distribution.
76
77%description -l pl.UTF-8
78GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
79stworzona od zera w ANSI C.
80
81Głównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
82dla jak największej liczby ludzi), małej i elastycznej alternatywy dla
83wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
84rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
85jest bardzo dużą porcją kodu, zaprojektowaną raczej do zweryfikowania
86standardu niż dostarczenia małej, stabilnej wersji produkcyjnej. GPAC
87jest pisany w ANSI C ze względu na przenośność (platformy wbudowane i
88DSP) z prostym celem: wymagać tak mało pamięci, jak to tylko możliwe.
89Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzędzia
90do publikacji w celu dystrybucji materiałów.
91
92%package -n browser-plugin-%{name}
93Summary: GPAC browser plugin
94Summary(pl.UTF-8): Wtyczka GPAC do przegląderek WWW
95Group: X11/Libraries
96Requires: %{name} = %{version}-%{release}
97Requires: browser-plugins >= 2.0
98Requires: browser-plugins(%{_target_base_arch})
99
100%description -n browser-plugin-%{name}
101GPAC plugin for Netscape-compatible WWW browsers.
102
103%description -n browser-plugin-%{name} -l pl.UTF-8
104Wtyczka GPAC dla przeglądarek WWW zgodnych z Netscape.
105
106%prep
107%setup -q -n %{name}
108%patch0 -p1
109%{?with_wx:%patch1 -p1}
110%patch2 -p1
111%patch3 -p1
112%if %{with amr}
113mkdir -p Plugins/amr_dec/AMR_NB
114cd Plugins/amr_dec/AMR_NB
115unzip -j %{SOURCE1}
116unzip -j 26073-530_ANSI_C_source_code.zip
117cd ../../..
118%endif
119chmod a+x configure
120
121# files for w32 and Linux were swapped
122rm -rf applications/osmozilla/nsIOsmozilla.xpt_linux
123mv applications/osmozilla/nsIOsmozilla.xpt_w32 applications/osmozilla/nsIOsmozilla.xpt_linux
124
125%build
126%configure \
127 --extra-cflags="-fPIC" \
128 --extra-ldflags="-fPIC" \
129 --enable-oss-audio \
130 %{?with_amr:--enable-amr-nb} \
131 %{!?with_faad:--disable-faad} \
132 %{!?with_ffmpeg:--disable-ffmpeg} \
133 %{!?with_freetype:--disable-ft} \
134 %{!?with_jpeg:--disable-jpeg} \
135 %{!?with_js:--disable-js} \
136 %{!?with_mad:--disable-mad} \
137 %{!?with_png:--disable-png} \
138 %{!?with_xvid:--disable-xvid}
139
140%{__make} -j1 \
141 XLIBDIR="/usr/X11R6/%{_lib}" \
142 DESTDIR=$RPM_BUILD_ROOT
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147%{__make} install \
148 bindir=$RPM_BUILD_ROOT%{_bindir} \
149 libdir=$RPM_BUILD_ROOT%{_libdir} \
150 mandir=$RPM_BUILD_ROOT%{_mandir} \
151 plugdir=$RPM_BUILD_ROOT%{_libdir}/gpac \
152 real_plugdir=%{_libdir}/gpac \
153 prefix=$RPM_BUILD_ROOT%{_prefix} \
154 MOZILLA_DIR=$RPM_BUILD_ROOT%{_browserpluginsdir}
155
156%clean
157rm -rf $RPM_BUILD_ROOT
158
159%post -p /sbin/ldconfig
160%postun -p /sbin/ldconfig
161
162%post -n browser-plugin-%{name}
163%update_browser_plugins
164
165%postun -n browser-plugin-%{name}
166if [ "$1" = 0 ]; then
167 %update_browser_plugins
168fi
169
170%files
171%defattr(644,root,root,755)
172%doc AUTHORS BUGS Changelog README TODO
173%attr(755,root,root) %{_bindir}/*
174%attr(755,root,root) %{_libdir}/lib*.so
175%dir %{_libdir}/gpac
176%attr(755,root,root) %{_libdir}/gpac/*.so
177%{_mandir}/man1/*
178
179%files -n browser-plugin-%{name}
180%defattr(644,root,root,755)
181%attr(755,root,root) %{_browserpluginsdir}/nposmozilla.so
182%{_browserpluginsdir}/nposmozilla.xpt
This page took 0.055092 seconds and 4 git commands to generate.