]> git.pld-linux.org Git - packages/gnome-shell.git/blame_incremental - gnome-shell.spec
- updated to 46.2
[packages/gnome-shell.git] / gnome-shell.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # API documentation
4
5%define clutter_ver 1.21.5
6# max(ecal_req, eds_req)
7%define evolution_data_server_ver 3.33.1
8%define gcr_ver 3.90.0
9%define gjs_ver 1.73.1
10%define glib_ver 1:2.57.2
11%define gnome_bluetooth_ver 3.9.0
12%define gnome_desktop_ver 40
13%define gsettings_desktop_schemas_ver 46
14%define gtk_ver 4.0
15%define ibus_ver 1.5.19
16%define json_glib_ver 0.13.90
17%define libsecret_ver 0.18
18%define mutter_ver 46.0
19%define NetworkManager_ver 1.10.4
20%define polkit_ver 0.100
21%define pulseaudio_ver 13
22%define startup_notification_ver 0.11
23%define systemd_ver 1:246
24
25Summary: Window manager and application launcher for GNOME
26Summary(pl.UTF-8): Zarządca okien i uruchamiania aplikacji dla GNOME
27Name: gnome-shell
28Version: 46.2
29Release: 1
30License: GPL v2+
31Group: X11/Window Managers
32Source0: https://download.gnome.org/sources/gnome-shell/46/%{name}-%{version}.tar.xz
33# Source0-md5: ebb54596ebd8b65552cb63bb56d3226a
34Patch0: %{name}-no-update.patch
35URL: https://wiki.gnome.org/Projects/GnomeShell
36BuildRequires: NetworkManager-devel >= %{NetworkManager_ver}
37BuildRequires: asciidoc
38BuildRequires: at-spi2-atk-devel
39BuildRequires: bash-completion-devel >= 1:2.0
40BuildRequires: clutter-devel >= %{clutter_ver}
41BuildRequires: evolution-data-server-devel >= %{evolution_data_server_ver}
42BuildRequires: gcr4-devel >= %{gcr_ver}
43BuildRequires: gdk-pixbuf2-devel >= 2.0
44BuildRequires: gettext-tools >= 0.19.6
45%{?with_apidocs:BuildRequires: gi-docgen}
46BuildRequires: gjs-devel >= %{gjs_ver}
47BuildRequires: glib2-devel >= %{glib_ver}
48BuildRequires: gnome-autoar-devel
49BuildRequires: gnome-bluetooth3-devel >= %{gnome_bluetooth_ver}
50BuildRequires: gnome-control-center-devel
51BuildRequires: gnome-desktop4-devel >= %{gnome_desktop_ver}
52BuildRequires: gobject-introspection-devel >= 1.50.0
53BuildRequires: gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_ver}
54BuildRequires: gstreamer-devel >= 1.0.0
55BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
56BuildRequires: gtk4-devel >= %{gtk_ver}
57BuildRequires: ibus-devel >= %{ibus_ver}
58BuildRequires: json-glib-devel >= %{json_glib_ver}
59BuildRequires: libsecret-devel >= %{libsecret_ver}
60# or libsoup 2.4 with -Dsoup2=true, must be in sync with libgweather
61BuildRequires: libsoup3-devel >= 3.0
62BuildRequires: libxml2-devel >= 2.0
63BuildRequires: libxslt-progs
64BuildRequires: meson >= 0.58.0
65BuildRequires: mutter-devel >= %{mutter_ver}
66BuildRequires: ninja >= 1.5
67BuildRequires: pipewire-devel >= 0.3.49
68BuildRequires: pkgconfig >= 1:0.22
69BuildRequires: polkit-devel >= %{polkit_ver}
70BuildRequires: pulseaudio-devel >= %{pulseaudio_ver}
71BuildRequires: python3 >= 1:3
72BuildRequires: python3-pygobject3 >= 3
73BuildRequires: rpm-build >= 4.6
74BuildRequires: rpm-pythonprov
75BuildRequires: rpmbuild(macros) >= 2.029
76BuildRequires: sassc
77BuildRequires: sed >= 4.0
78BuildRequires: startup-notification-devel >= %{startup_notification_ver}
79BuildRequires: systemd-devel >= %{systemd_ver}
80BuildRequires: systemd-units >= %{systemd_ver}
81BuildRequires: tar >= 1:1.22
82BuildRequires: xorg-lib-libX11-devel
83BuildRequires: xorg-lib-libXfixes-devel
84BuildRequires: xz
85Requires(post,postun): glib2 >= %{glib_ver}
86# gjs->gi->NMA.gir
87Requires: NetworkManager-libs >= %{NetworkManager_ver}
88Requires: adwaita-icon-theme
89Requires: at-spi2-atk >= 2.4.0
90Requires: clutter >= %{clutter_ver}
91Requires: evolution-data-server >= %{evolution_data_server_ver}
92Requires: gcr4 >= %{gcr_ver}
93Requires: gjs >= %{gjs_ver}
94Requires: glib2 >= %{glib_ver}
95Requires: gnome-bluetooth3-libs >= %{gnome_bluetooth_ver}
96Requires: gnome-desktop4 >= %{gnome_desktop_ver}
97Requires: gnome-settings-daemon >= 3.8.0
98Requires: gsettings-desktop-schemas >= %{gsettings_desktop_schemas_ver}
99Requires: gtk4 >= %{gtk_ver}
100Requires: ibus >= %{ibus_ver}
101Requires: json-glib >= %{json_glib_ver}
102Requires: libsecret >= %{libsecret_ver}
103Requires: mutter >= %{mutter_ver}
104Requires: nautilus >= 3.8.0
105Requires: polkit >= %{polkit_ver}
106Requires: pulseaudio-libs >= %{pulseaudio_ver}
107Requires: startup-notification >= %{startup_notification_ver}
108# gjs->gir->TelepathyGLib
109Requires: telepathy-glib >= 0.17.5
110# gjs->gir->TelepathyLogger
111Requires: telepathy-logger-libs >= 0.2
112Requires: telepathy-mission-control
113Suggests: gnome-contacts >= 3.2.0
114Suggests: gnome-icon-theme-symbolic >= 3.8.0
115Provides: gdm-wm = 3.8.0
116Obsoletes: browser-plugin-gnome-shell < 3.32.2-1
117BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119%define apiver 14
120
121%description
122GNOME Shell is the defining technology of the GNOME 3 desktop user
123experience. It provides core interface functions like switching to
124windows and launching applications. GNOME Shell takes advantage of the
125capabilities of modern graphics hardware and introduces innovative
126user interface concepts to provide a delightful and easy to use
127experience.
128
129%description -l pl.UTF-8
130GNOME Shell to technologia definiująca doznania użytkownika środowiska
131graficznego GNOME 3. Zapewnia podstawowe funkcje interfejsu, takie jak
132przełączanie między oknami czy uruchamianie aplikacji. GNOME Shell
133wykorzystuje mozliwości współczesnego sprzętu graficznego i wprowadza
134innowacyjne koncepcje interfejsu użytkownika, zapewniające przyjemne
135doznania i łatwość użycia.
136
137%package -n bash-completion-gnome-shell
138Summary: Bash completion for GNOME Shell commands
139Summary(pl.UTF-8): Bashowe dopełnianie parametrów poleceń GNOME Shell
140Group: Applications/Shells
141Requires: %{name} = %{version}-%{release}
142Requires: bash-completion >= 1:2.0
143BuildArch: noarch
144
145%description -n bash-completion-gnome-shell
146Bash completion for GNOME Shell commands.
147
148%description -n bash-completion-gnome-shell -l pl.UTF-8
149Bashowe dopełnianie parametrów poleceń GNOME Shell.
150
151%package devel
152Summary: Development files for GNOME Shell
153Summary(pl.UTF-8): Pliki programistyczne dla GNOME Shell
154Group: Development/Libraries
155BuildArch: noarch
156
157%description devel
158This package provides development files for GNOME Shell.
159
160%description devel -l pl.UTF-8
161Ten pakiet dostarcza pliki programistyczne dla GNOME Shell.
162
163%package apidocs
164Summary: GNOME Shell API documentation
165Summary(pl.UTF-8): Dokumentacja API GNOME Shell
166Group: Documentation
167Requires: gtk-doc-common
168BuildArch: noarch
169
170%description apidocs
171This package provides GNOME Shell API documentation.
172
173%description apidocs -l pl.UTF-8
174Ten pakiet dostarcza dokumentację API GNOME Shell.
175
176%prep
177%setup -q
178%patch0 -p1
179
180%{__sed} -i -e '/^libshew =/ s/ library/ shared_library/' subprojects/shew/src/meson.build
181
182%build
183%meson build \
184 %{?with_apidocs:-Dgtk_doc=true} \
185 -Dtests=false
186
187%meson_build -C build
188
189%install
190rm -rf $RPM_BUILD_ROOT
191install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/{extensions,search-providers}
192
193%meson_install -C build
194
195%if %{with apidocs}
196install -d $RPM_BUILD_ROOT%{_gidocdir}
197%{__mv} $RPM_BUILD_ROOT%{_docdir}/{shell,st} $RPM_BUILD_ROOT%{_gidocdir}
198%endif
199
200# useless
201%{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/lib*.a
202
203# not supported by glibc (as of 2.37)
204%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
205
206%find_lang %{name}
207
208%clean
209rm -rf $RPM_BUILD_ROOT
210
211%post
212%glib_compile_schemas
213
214%postun
215if [ "$1" = "0" ]; then
216 %glib_compile_schemas
217fi
218
219%files -f %{name}.lang
220%defattr(644,root,root,755)
221%doc NEWS README.md
222%attr(755,root,root) %{_bindir}/gnome-extensions
223%attr(755,root,root) %{_bindir}/gnome-extensions-app
224%attr(755,root,root) %{_bindir}/gnome-shell
225%attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
226%attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
227%attr(755,root,root) %{_bindir}/gnome-shell-test-tool
228%attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
229%attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
230%attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
231%attr(755,root,root) %{_libexecdir}/gnome-shell-portal-helper
232%dir %{_libdir}/gnome-shell
233%attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-menu.so
234%attr(755,root,root) %{_libdir}/gnome-shell/libgvc.so
235%attr(755,root,root) %{_libdir}/gnome-shell/libshell-%{apiver}.so
236%attr(755,root,root) %{_libdir}/gnome-shell/libshew-0.so
237%attr(755,root,root) %{_libdir}/gnome-shell/libst-%{apiver}.so
238%{_libdir}/gnome-shell/Gvc-1.0.typelib
239%{_libdir}/gnome-shell/Shell-%{apiver}.typelib
240%{_libdir}/gnome-shell/St-%{apiver}.typelib
241%dir %{_libdir}/gnome-shell/girepository-1.0
242%{_libdir}/gnome-shell/girepository-1.0/Shew-0.typelib
243%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Introspect.xml
244%{_datadir}/dbus-1/services/org.gnome.Extensions.service
245%{_datadir}/dbus-1/services/org.gnome.ScreenSaver.service
246%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
247%{_datadir}/dbus-1/services/org.gnome.Shell.Extensions.service
248%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
249%{_datadir}/dbus-1/services/org.gnome.Shell.Notifications.service
250%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
251%{_datadir}/dbus-1/services/org.gnome.Shell.Screencast.service
252%{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
253%{_datadir}/glib-2.0/schemas/org.gnome.Extensions.gschema.xml
254%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
255%{_datadir}/gnome-control-center/keybindings/*.xml
256%{_datadir}/gnome-shell
257%{_datadir}/metainfo/org.gnome.Extensions.metainfo.xml
258%{_desktopdir}/org.gnome.Extensions.desktop
259%{_desktopdir}/org.gnome.Shell.desktop
260%{_desktopdir}/org.gnome.Shell.Extensions.desktop
261%{_desktopdir}/org.gnome.Shell.PortalHelper.desktop
262%{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.Devel.svg
263%{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.svg
264%{_iconsdir}/hicolor/scalable/apps/org.gnome.Shell.Extensions.svg
265%{_iconsdir}/hicolor/symbolic/apps/org.gnome.Extensions-symbolic.svg
266%{_iconsdir}/hicolor/symbolic/apps/org.gnome.Shell.Extensions-symbolic.svg
267%{_mandir}/man1/gnome-extensions.1*
268%{_mandir}/man1/gnome-shell.1*
269%{systemduserunitdir}/org.gnome.Shell.target
270%{systemduserunitdir}/org.gnome.Shell-disable-extensions.service
271%{systemduserunitdir}/org.gnome.Shell@wayland.service
272%{systemduserunitdir}/org.gnome.Shell@x11.service
273
274%files -n bash-completion-gnome-shell
275%defattr(644,root,root,755)
276%{bash_compdir}/gnome-extensions
277
278%files devel
279%defattr(644,root,root,755)
280%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
281%{_datadir}/dbus-1/interfaces/org.gnome.Shell.PadOsd.xml
282%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
283%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
284%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
285%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
286
287%if %{with apidocs}
288%files apidocs
289%defattr(644,root,root,755)
290%{_gidocdir}/shell
291%{_gidocdir}/st
292%endif
This page took 0.373836 seconds and 5 git commands to generate.