]> git.pld-linux.org Git - packages/gnome-shell.git/blame_incremental - gnome-shell.spec
Update to 3.6.3
[packages/gnome-shell.git] / gnome-shell.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without systemd # by default use systemd for session tracking instead of ConsoleKit (fallback to ConsoleKit on runtime)
4#
5Summary: Window manager and application launcher for GNOME
6Name: gnome-shell
7Version: 3.6.3
8Release: 1
9License: GPL v2+
10Group: X11/Window Managers
11Source0: http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.6/%{name}-%{version}.tar.xz
12# Source0-md5: 5e3a0cf840d79f944cf8c7afc1c72431
13URL: http://live.gnome.org/GnomeShell
14BuildRequires: NetworkManager-devel >= 0.8.999
15BuildRequires: autoconf >= 2.63
16BuildRequires: automake >= 1:1.11
17BuildRequires: clutter-devel >= 1.11.11
18BuildRequires: dbus-glib-devel
19BuildRequires: evolution-data-server-devel >= 3.5.3
20BuildRequires: gcr-devel >= 3.3.90
21BuildRequires: gettext-devel >= 0.17
22BuildRequires: gjs-devel >= 1.33.2
23BuildRequires: glib2-devel >= 1:2.31.6
24BuildRequires: gnome-bluetooth-devel >= 3.1.0
25BuildRequires: gnome-desktop-devel >= 3.5.1
26BuildRequires: gnome-menus-devel >= 3.5.3
27BuildRequires: gobject-introspection-devel >= 0.10.1
28BuildRequires: gsettings-desktop-schemas-devel >= 3.5.4
29BuildRequires: gstreamer-devel >= 1.0.0
30BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
31BuildRequires: gtk+3-devel >= 3.3.9
32BuildRequires: gtk-doc >= 1.15
33BuildRequires: intltool >= 0.40
34BuildRequires: json-glib-devel >= 0.13.90
35BuildRequires: libcanberra-devel
36BuildRequires: libcroco-devel >= 0.6.2
37BuildRequires: libgnome-keyring-devel
38BuildRequires: libsoup-devel
39BuildRequires: libtool >= 2:2.2.6
40BuildRequires: libxml2-devel
41BuildRequires: libxslt-progs
42BuildRequires: mutter-devel >= 3.6.2
43BuildRequires: pkgconfig >= 1:0.22
44BuildRequires: polkit-devel >= 0.100
45BuildRequires: pulseaudio-devel
46BuildRequires: rpm-pythonprov
47BuildRequires: rpmbuild(macros) >= 1.601
48BuildRequires: startup-notification-devel >= 0.11
49%{?with_systemd:BuildRequires: systemd-devel}
50BuildRequires: tar >= 1:1.22
51BuildRequires: telepathy-glib-devel >= 0.17.5
52BuildRequires: telepathy-logger-devel >= 0.2.4
53BuildRequires: xorg-lib-libXfixes-devel
54BuildRequires: xz
55Requires(post,postun): glib2 >= 1:2.26.0
56Requires: at-spi2-atk >= 2.4.0
57Requires: caribou >= 0.3.5
58Requires: evolution-data-server >= 3.5.3
59Requires: gjs >= 1.33.2
60Requires: glib2 >= 1:2.31.6
61Requires: gnome-bluetooth-libs >= 3.1.0
62Requires: gnome-menus >= 3.5.3
63Requires: gnome-settings-daemon >= 3.1.90
64Requires: gsettings-desktop-schemas >= 3.5.4
65Requires: gtk+3 >= 3.3.9
66Requires: mutter >= 3.6.2
67Requires: nautilus >= 3.2.0
68Requires: telepathy-logger >= 0.2.4
69Requires: telepathy-mission-control
70Suggests: gnome-contacts >= 3.2.0
71Suggests: gnome-icon-theme-symbolic >= 3.0.0
72Provides: gdm-wm = 3.6.0
73BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75%description
76GNOME Shell is the defining technology of the GNOME 3 desktop user
77experience. It provides core interface functions like switching to
78windows and launching applications. GNOME Shell takes advantage of the
79capabilities of modern graphics hardware and introduces innovative
80user interface concepts to provide a delightful and easy to use
81experience.
82
83%package apidocs
84Summary: GNOME Shell API documentation
85Summary(pl.UTF-8): Dokumentacja API GNOME Shell
86Group: Documentation
87Requires: gtk-doc-common
88
89%description apidocs
90This package provides GNOME Shell API documentation.
91
92%description apidocs -l pl.UTF-8
93Ten pakiet dostarcza dokumentację API GNOME Shell.
94
95%package -n browser-plugin-%{name}
96Summary: gnome-shell plugin for WWW browsers
97Summary(pl.UTF-8): Wtyczka gnome-shell do przeglądarek WWW
98Group: X11/Libraries
99Requires: %{name} = %{version}-%{release}
100Requires: browser-plugins >= 2.0
101Requires: browser-plugins(%{_target_base_arch})
102Provides: mozilla-firefox-plugin-gnome-shell = %{version}-%{release}
103Provides: mozilla-plugin-gnome-shell = %{version}-%{release}
104Obsoletes: mozilla-firefox-plugin-gnome-shell < %{version}-%{release}
105Obsoletes: mozilla-plugin-gnome-shell < %{version}-%{release}
106
107%description -n browser-plugin-%{name}
108gnome-shell plugin for WWW browsers.
109
110%description -n browser-plugin-%{name} -l pl.UTF-8
111Wtyczka gnome-shell do przeglądarek WWW.
112
113%prep
114%setup -q
115
116%build
117%{__intltoolize}
118%{__libtoolize}
119%{__aclocal} -I m4
120%{__autoconf}
121%{__autoheader}
122%{__automake}
123%configure \
124 --with-ca-certificates=/etc/certs/ca-certificates.crt \
125 --enable-gtk-doc \
126 --disable-silent-rules \
127 --disable-static \
128 %{__enable_disable systemd systemd} \
129 --with-html-dir=%{_gtkdocdir}
130%{__make} -j1
131
132%install
133rm -rf $RPM_BUILD_ROOT
134install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/{extensions,search-providers}
135
136%{__make} install \
137 INSTALL="install -p" \
138 install_sh="install -p" \
139 DESTDIR=$RPM_BUILD_ROOT \
140 mozillalibdir=%{_browserpluginsdir}
141
142%{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/*.la \
143 $RPM_BUILD_ROOT%{_browserpluginsdir}/*.la
144# evolution already ships this file
145%{__rm} $RPM_BUILD_ROOT%{_desktopdir}/evolution-calendar.desktop
146
147%find_lang %{name}
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%post
153%glib_compile_schemas
154
155%postun
156if [ "$1" = "0" ]; then
157 %glib_compile_schemas
158fi
159
160%post -n browser-plugin-%{name}
161%update_browser_plugins
162
163%postun -n browser-plugin-%{name}
164if [ "$1" = 0 ]; then
165 %update_browser_plugins
166fi
167
168%files -f %{name}.lang
169%defattr(644,root,root,755)
170%attr(755,root,root) %{_bindir}/gnome-shell
171%attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
172%attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
173%attr(755,root,root) %{_bindir}/gnome-shell-perf-tool
174%attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
175%attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
176%attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
177%dir %{_libdir}/gnome-shell
178%attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
179%attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-js.so
180%{_libdir}/gnome-shell/Gvc-1.0.typelib
181%{_libdir}/gnome-shell/Shell-0.1.typelib
182%{_libdir}/gnome-shell/ShellJS-0.1.typelib
183%{_libdir}/gnome-shell/St-1.0.typelib
184%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
185%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
186%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
187%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
188%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
189%{_datadir}/gnome-control-center/keybindings/*.xml
190%{_datadir}/gnome-shell
191%{_desktopdir}/gnome-shell.desktop
192%{_desktopdir}/gnome-shell-extension-prefs.desktop
193%{_mandir}/man1/gnome-shell.1*
194
195%files apidocs
196%defattr(644,root,root,755)
197%{_gtkdocdir}/shell
198%{_gtkdocdir}/st
199
200%files -n browser-plugin-%{name}
201%defattr(644,root,root,755)
202%attr(755,root,root) %{_browserpluginsdir}/libgnome-shell-browser-plugin.so
This page took 0.046343 seconds and 4 git commands to generate.