]> git.pld-linux.org Git - packages/flowd.git/blame_incremental - flowd.spec
- rebuild with perl 5.30.0
[packages/flowd.git] / flowd.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # build without tests
4#
5%include /usr/lib/rpm/macros.perl
6Summary: The flowd NetFlow collector daemon
7Summary(pl.UTF-8): flowd - demon zbierania danych NetFlow
8Name: flowd
9Version: 0.9.1
10Release: 14
11License: BSD
12Group: Applications/Networking
13Source0: http://www.mindrot.org/files/flowd/%{name}-%{version}.tar.gz
14# Source0-md5: a3d0512b5e6d9c7d9e749d9894376ea4
15Patch0: %{name}-username.patch
16Patch1: format-error.patch
17URL: http://www.mindrot.org/flowd.html
18BuildRequires: byacc
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: python-devel
21BuildRequires: python-modules
22BuildRequires: rpm-perlprov >= 4.1-13
23BuildRequires: rpm-pythonprov
24BuildRequires: rpmbuild(macros) >= 1.710
25Requires(post,preun): /sbin/chkconfig
26Requires(postun): /usr/sbin/groupdel
27Requires(postun): /usr/sbin/userdel
28Requires(pre): /bin/id
29Requires(pre): /usr/bin/getgid
30Requires(pre): /usr/sbin/groupadd
31Requires(pre): /usr/sbin/useradd
32Requires: rc-scripts
33Provides: group(flowd)
34Provides: user(flowd)
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38This is flowd, a NetFlow collector daemon intended to be small, fast
39and secure.
40
41It features some basic filtering to limit or tag the flows that are
42recorded and is privilege separated, to limit security exposure from
43bugs in flowd itself.
44
45%description -l pl.UTF-8
46Ten pakiet zawiera program flowd - demona zbierającego dane NetFlow,
47mającego być małym, szybkim i bezpiecznym.
48
49Obsługuje podstawowe filtrowanie w celu ograniczania lub znakowania
50zapisywanych przepływów, ma rozdzielenie uprawnień w celu ograniczenia
51wpływu własnych błedów na bezpieczeństwo.
52
53%package -n perl-Flowd
54Summary: Perl API to access flowd logfiles
55Summary(pl.UTF-8): Perlowe API do dostępu do plików logów flowd
56Group: Development/Languages/Perl
57Obsoletes: flowd-perl
58
59%description -n perl-Flowd
60This is a Perl API to the binary flowd network flow log format and an
61example reader application.
62
63%description -n perl-Flowd -l pl.UTF-8
64Ten pakiet zawiera API Perla dla binarnego formatu plików logów
65przepływów sieciowych flowd oraz przykładowy program czytający.
66
67%package -n python-flowd
68Summary: Python API to access flowd logfiles
69Summary(pl.UTF-8): Pythonowe API do dostępu do plików logów flowd
70Group: Applications/Networking
71Obsoletes: flowd-python
72
73%description -n python-flowd
74This is a Python API to the binary flowd network flow log format and
75an example reader application.
76
77%description -n python-flowd -l pl.UTF-8
78Ten pakiet zawiera API Pythona dla binarnego formatu plików logów
79przepływów sieciowych flowd oraz przykładowy program czytający.
80
81%package tools
82Summary: Collection of example flowd tools
83Summary(pl.UTF-8): Zbiór przykładowych narzędzi dla flowd
84Group: Applications/Networking
85
86%description tools
87A collection of tools for use with flowd.
88
89%description tools -l pl.UTF-8
90Zbiór narzędzi do używania z flowd.
91
92%package devel
93Summary: C API to access flowd logfiles
94Summary(pl.UTF-8): API C do dostępu do plików logów flowd
95Group: Development/Libraries
96
97%description devel
98This is a C API to the binary flowd network flow log format.
99
100%description devel -l pl.UTF-8
101Ten pakiet zawiera API C dla binarnego formatu plików logów przepływów
102sieciowych flowd.
103
104%prep
105%setup -q
106%patch0 -p1
107%patch1 -p1
108
109%build
110%configure
111%{__make}
112
113%py_build
114
115cd Flowd-perl
116%{__perl} Makefile.PL \
117 INSTALLDIRS=vendor
118%{__make}
119%{?with_tests:%{__make} test}
120
121%install
122rm -rf $RPM_BUILD_ROOT
123
124%{__make} install \
125 DESTDIR=$RPM_BUILD_ROOT
126
127# Misc stuff
128install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
129install -p flowd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/flowd
130
131# Perl module
132%{__make} -C Flowd-perl pure_install \
133 DESTDIR=$RPM_BUILD_ROOT
134
135rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Flowd/.packlist
136
137# Python module
138%py_install
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%pre
144%groupadd -g 198 flowd
145%useradd -u 198 -d /usr/share/empty -s /bin/false -c "flowd user" -g flowd flowd
146
147%post
148/sbin/chkconfig --add flowd
149%service flowd restart "flowd daemon"
150
151%preun
152if [ "$1" = "0" ]; then
153 %service flowd stop
154 /sbin/chkconfig --del flowd
155fi
156
157%postun
158if [ "$1" = "0" ]; then
159 %userremove flowd
160 %groupremove flowd
161fi
162
163%files
164%defattr(644,root,root,755)
165%doc ChangeLog LICENSE README TODO
166%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/flowd.conf
167%attr(754,root,root) /etc/rc.d/init.d/flowd
168%attr(755,root,root) %{_bindir}/flowd-reader
169%attr(755,root,root) %{_sbindir}/flowd
170%{_mandir}/man5/flowd.conf.5*
171%{_mandir}/man8/flowd.8*
172%{_mandir}/man8/flowd-reader.8*
173
174%files -n perl-Flowd
175%defattr(644,root,root,755)
176%doc reader.pl
177%{perl_vendorarch}/Flowd.pm
178%dir %{perl_vendorarch}/auto/Flowd
179%attr(755,root,root) %{perl_vendorarch}/auto/Flowd/Flowd.so
180%{_mandir}/man3/Flowd.3pm*
181
182%files -n python-flowd
183%defattr(644,root,root,755)
184%doc reader.py
185%attr(755,root,root) %{py_sitedir}/flowd.so
186%if "%{py_ver}" > "2.4"
187%{py_sitedir}/flowd-*.egg-info
188%endif
189
190%files tools
191%defattr(644,root,root,755)
192%doc tools/*
193
194%files devel
195%defattr(644,root,root,755)
196%{_includedir}/flowd
197%{_libdir}/libflowd.a
This page took 0.050732 seconds and 4 git commands to generate.