]> git.pld-linux.org Git - packages/ffcall.git/blame_incremental - ffcall.spec
- rel. 2, fix build, cleaning
[packages/ffcall.git] / ffcall.spec
... / ...
CommitLineData
1Summary: Libraries for building foreign function call interfaces
2Summary(pl.UTF-8): Biblioteki do tworzenia interfejsów wywołań obcych funkcji
3Name: ffcall
4Version: 1.10
5Release: 2
6Epoch: 1
7License: GPL
8Group: Libraries
9Source0: ftp://ftp.santafe.edu/pub/gnu/%{name}-%{version}.tar.gz
10# Source0-md5: 2db95007e901f3bc2ae7e5a9fe9ebea4
11Patch0: %{name}-make-jN.patch
12URL: http://www.haible.de/bruno/packages-ffcall.html
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15%description
16This is a collection of four libraries which can be used to build
17foreign function call interfaces in embedded interpreters.
18
19The four packages are:
20- avcall - calling C functions with variable arguments
21- vacall - C functions accepting variable argument prototypes
22- trampoline - closures as first-class C functions
23- callback - closures with variable arguments as first-class C
24 functions (a reentrant combination of vacall and trampoline)
25
26This version B includes some minor configuration changes so that files
27are installed in the proper place. Also it compiles on cygwin and
28mingw32.
29
30%description -l pl.UTF-8
31To jest zestaw czterech bibliotek, których można użyć do tworzenia
32interfejsów wywołań obcych procedur we wbudowanych interpreterach.
33
34Te cztery pakiety to:
35- avcall - wywoływanie funkcji w C ze zmiennymi argumentami
36- vacall - funkcje w C akceptujące prototypy ze zmiennymi argumentami
37- trampoline - domknięcia jako funkcje C pierwszej klasy
38- callback - domknięcia ze zmiennymi argumentami jako funkcje C
39 pierwszej klasy (zagnieżdżalna kombinacja vacall i trampoline)
40
41Ta wersja B zawiera trochę małych zmian w konfiguracji, dzięki którym
42pliki instalują się we właściwych miejscach. A także kompiluje się pod
43cygwinem i mingw32.
44
45%package devel
46Summary: Development files for ffcall libraries
47Summary(pl.UTF-8): Pliki dla programistów używających bibliotek ffcall
48Group: Development/Libraries
49Requires: %{name} = %{epoch}:%{version}-%{release}
50
51%description devel
52Development files for ffcall libraries: headers and static trampoline
53and vacall libraries.
54
55%description devel -l pl.UTF-8
56Pliki dla programistów używających bibliotek ffcall: nagłówki i
57statyczne biblioteki trampoline oraz vacall.
58
59%package static
60Summary: Static versions of avcall and callback libraries
61Summary(pl.UTF-8): Statyczne wersje bibliotek avcall i callback
62Group: Development/Libraries
63Requires: %{name}-devel = %{epoch}:%{version}-%{release}
64
65%description static
66Static versions of avcall and callback libraries.
67
68%description static -l pl.UTF-8
69Statyczne wersje bibliotek avcall i callback.
70
71%prep
72%setup -q
73%patch0 -p1
74
75%build
76%configure \
77 --enable-shared
78
79%{__make}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83install -d $RPM_BUILD_ROOT%{_mandir}
84
85%{__make} install \
86 DESTDIR=$RPM_BUILD_ROOT
87
88# don't need those since we have man pages
89%{__rm} $RPM_BUILD_ROOT/usr/share/html/*.html
90
91%clean
92rm -fr $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%files
98%defattr(644,root,root,755)
99%doc NEWS README
100%attr(755,root,root) %{_libdir}/lib*.so.*.*
101
102%files devel
103%defattr(644,root,root,755)
104%doc */*.html
105%attr(755,root,root) %{_libdir}/lib*.so*
106%{_libdir}/lib*.la
107%{_libdir}/libtrampoline.a
108%{_libdir}/libvacall.a
109%{_includedir}/*
110%{_mandir}/man?/*
111
112%files static
113%defattr(644,root,root,755)
114%{_libdir}/libavcall.a
115%{_libdir}/libcallback.a
This page took 0.06635 seconds and 4 git commands to generate.