]> git.pld-linux.org Git - packages/domoticz.git/blame_incremental - domoticz.spec
missed tinyxpath patch update; rel 2
[packages/domoticz.git] / domoticz.spec
... / ...
CommitLineData
1Summary: Open source Home Automation System
2Name: domoticz
3Version: 2024.1
4Release: 2
5License: GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6Group: Base
7URL: http://www.domoticz.com
8Source0: https://github.com/domoticz/domoticz/archive/%{version}/%{name}-%{version}.tar.gz
9# Source0-md5: 35b60b24ab2e1cf6d721d6720ae8a670
10Source1: %{name}.service
11Source2: %{name}.conf
12# Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
13Patch0: %{name}-tinyxpath.patch
14# Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
15Patch1: %{name}-python.patch
16Patch2: no-git.patch
17Patch3: %{name}-no_updates.patch
18Patch4: config.patch
19BuildRequires: boost-devel >= 1.66.0
20BuildRequires: cereal-devel
21BuildRequires: cmake >= 3.16.0
22BuildRequires: curl-devel
23BuildRequires: jsoncpp-devel
24BuildRequires: libmosquitto-devel
25BuildRequires: libstdc++-devel >= 6:4.9
26BuildRequires: libusb-compat-devel
27BuildRequires: linux-libc-headers
28BuildRequires: lua53-devel
29BuildRequires: minizip-devel
30BuildRequires: openssl-devel
31BuildRequires: pkgconfig
32BuildRequires: python3 >= 1:3.4
33BuildRequires: python3-devel >= 1:3.4
34BuildRequires: rpmbuild(macros) >= 1.644
35BuildRequires: sqlite3-devel
36BuildRequires: tinyxml-devel
37BuildRequires: tinyxpath-devel
38BuildRequires: zlib-devel
39Requires(pre): /usr/sbin/groupadd
40Requires(pre): /usr/sbin/useradd
41Requires(post,preun,postun): systemd-units >= 38
42Requires: fonts-TTF-Google-Droid
43Requires: fonts-TTF-OpenSans
44Requires: setup >= 2.10.1
45Suggests: python3-libs
46Provides: group(domoticz)
47Provides: user(domoticz)
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51Domoticz is a Home Automation System that lets you monitor and
52configure various devices like: Lights, Switches, various
53sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
54and much more. Notifications/Alerts can be sent to any mobile device
55
56%prep
57%setup -q
58%patch0 -p1
59%patch1 -p1
60%patch2 -p1
61%patch3 -p1
62%patch4 -p1
63
64APPVERSION="%{version}"
65echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
66echo '#define APPHASH "%{snap}"' >> appversion.h
67APPDATE=$(date --date="%{date}" "+%s")
68echo "#define APPDATE ${APPDATE}" >> appversion.h
69
70%{__rm} -r extern tinyxpath
71
72%build
73install -d build && cd build
74export CXXFLAGS="%{rpmcxxflags} -DPYTHON_LIBDIR=\\\"%{_libdir}\\\""
75%cmake \
76 -DUSE_BUILTIN_JSONCPP=NO \
77 -DUSE_BUILTIN_MINIZIP=NO \
78 -DUSE_BUILTIN_MQTT=NO \
79 -DUSE_BUILTIN_SQLITE=NO \
80 -DUSE_BUILTIN_TINYXPATH=NO \
81 -DUSE_LUA_STATIC=NO \
82 -DUSE_OPENSSL_STATIC=NO \
83 -DUSE_STATIC_BOOST=NO \
84 -DUSE_STATIC_LIBSTDCXX=NO \
85 -DFORCE_WITH_GPIO:BOOL=TRUE \
86 -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
87 ..
88
89%{__make}
90
91%install
92rm -rf $RPM_BUILD_ROOT
93
94%{__make} -C build install \
95 DESTDIR=$RPM_BUILD_ROOT
96
97install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/{domoticz,sysconfig},%{systemdunitdir},%{_sharedstatedir}/%{name}}
98
99# remove docs, we grab them in files below
100%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
101
102# move binary to standard directory
103mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}
104
105sed -e 's#@DOMOTICZ_DIR@#%{_datadir}/%{name}#g' %{SOURCE1} > $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
106sed -e 's#@DOMOTICZ_DIR@#%{_datadir}/%{name}#g' scripts/domoticz.conf > $RPM_BUILD_ROOT%{_sysconfdir}/domoticz/domoticz.conf
107sed -e 's#@DOMOTICZ_CONF_DIR@#%{_sysconfdir}/%{name}#' %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
108
109# Unbundle DroidSans.ttf
110%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element{al,-light,-dark}/fonts/{Droid,Open}Sans.ttf
111ln -s %{_fontsdir}/TTF/DroidSans.ttf \
112 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts
113ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
114 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/OpenSans.ttf
115ln -s %{_fontsdir}/TTF/DroidSans.ttf \
116 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts
117ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
118 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/OpenSans.ttf
119ln -s %{_fontsdir}/TTF/DroidSans.ttf \
120 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts
121ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
122 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/OpenSans.ttf
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%pre
128%groupadd -g 342 domoticz
129%useradd -u 342 -r -d %{_datadir} -s /bin/false -c "Domoticz Home Automation Server" -G dialout,i2c -g domoticz domoticz
130
131%post
132%systemd_post %{name}.service
133
134%preun
135%systemd_preun %{name}.service
136
137%postun
138if [ "$1" = "0" ]; then
139 %userremove domoticz
140 %groupremove domoticz
141fi
142%systemd_reload
143
144%triggerpostun -- domoticz < 2022.1
145if [ -f /etc/sysconfig/domoticz.rpmnew ] && [ -f /etc/sysconfig/domoticz ] && ! grep -q '^DOMOTICZ_CONF=' /etc/sysconfig/domoticz; then
146 (
147 . /etc/sysconfig/domoticz
148 for c in WWW_PORT:http_port SSL_PORT:ssl_port SSLCERT:ssl_cert SSLPASS:ssl_pass SSLMETHOD:ssl_method SSLOPTIONS:ssl_options SSLDHPARAM:ssl_dhparam WWW_ROOT:http_root DBASE:dbase_file USERDATA:userdata_path LOG:log_file; do
149 cn_before=${c%:*}
150 cn_after=${c#*:}
151 eval cn_value=\"\$$cn_before\"
152 test -n "$cn_value" && sed -i -e "s|^[[:space:]#]*$cn_after=.*|$cn_after=$cn_value|" %{_sysconfdir}/%{name}/%{name}.conf
153 done
154 )
155 mv -f /etc/sysconfig/domoticz{,.rpmsave}
156 mv /etc/sysconfig/domoticz{.rpmnew,}
157fi
158
159%files
160%defattr(644,root,root,755)
161%doc License.txt README.md History.txt
162%attr(755,root,root) %{_bindir}/%{name}
163%dir %attr(750,domoticz,domoticz) %{_sysconfdir}/%{name}
164%attr(640,domoticz,domoticz) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
165%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
166%{_datadir}/%{name}
167%dir %attr(750,domoticz,domoticz) %{_sharedstatedir}/%{name}
168%{systemdunitdir}/%{name}.service
This page took 0.073258 seconds and 4 git commands to generate.