]> git.pld-linux.org Git - packages/dar.git/blame_incremental - dar.spec
- updated to 2.5.9
[packages/dar.git] / dar.spec
... / ...
CommitLineData
1# TODO: libthreadar
2#
3# Conditional build:
4%bcond_without ea # support for Linux extented attributes
5%bcond_without static # dar_static program
6%bcond_without static_libs # don't build static libraries
7#
8%if %{with static}
9%define with_static_libs 1
10%endif
11#
12Summary: dar makes backup of a directory tree and files
13Summary(pl.UTF-8): dar - narzędzie do tworzenia kopii zapasowych drzew katalogów i plików
14Name: dar
15Version: 2.5.9
16Release: 1
17License: GPL v2+
18Group: Applications/Archiving
19Source0: http://downloads.sourceforge.net/dar/%{name}-%{version}.tar.gz
20# Source0-md5: 6448517104fc3afda1e245307a6905a9
21Patch0: %{name}-opt.patch
22URL: http://dar.linux.free.fr/
23%{?with_ea:BuildRequires: attr-devel >= 2.4.16-3}
24BuildRequires: autoconf >= 2.69
25BuildRequires: automake
26BuildRequires: bzip2-devel
27BuildRequires: doxygen >= 1:1.3
28BuildRequires: e2fsprogs-devel
29BuildRequires: gettext-tools
30BuildRequires: gpgme-devel >= 1.2.0
31BuildRequires: groff
32BuildRequires: libcap-devel
33BuildRequires: libgcrypt-devel >= 1.6.0
34BuildRequires: libgpg-error-devel
35BuildRequires: libstdc++-devel >= 6:4.7
36BuildRequires: libtool >= 2:1.4d
37BuildRequires: lzo-devel >= 2
38BuildRequires: xz-devel
39BuildRequires: zlib-devel
40%if %{with static}
41%{?with_ea:BuildRequires: attr-static}
42BuildRequires: bzip2-static
43BuildRequires: glibc-static
44BuildRequires: libgcrypt-static
45BuildRequires: libgpg-error-static
46BuildRequires: libstdc++-static
47BuildRequires: lzo-static
48BuildRequires: zlib-static
49%endif
50Requires: %{name}-libs = %{version}-%{release}
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53# don't generate `Requires' for sample scripts
54%define _noautoreq bash perl
55
56%description
57dar is a shell command, that makes backup of a directory tree and
58files.
59
60FILTERS: dar is able to backup from total file system to a single
61file. Additionally a mechanism of filters permits, based on the
62filename, to exclude or include some files while backing up or
63restoring a directory tree. In the other side, a secondary filter
64mechanism permits to exclude some branches of a directory tree, or to
65only include some branches.
66
67DIFFERENTIAL BACKUP: When making a backup with dar, you have the
68possibility to make a full backup or a differential backup. A full
69backup, as expected makes backup of all files as specified on the
70command line (with or without filters). Instead, a differential
71backup, (over filter mechanism), saves only files that have changed
72since a given reference backup. Additionally, files that existed in
73the reference backup and which do no more exist at the time of the
74differential backup are recorded in the backup. At recovery time,
75(unless you deactivate it), restoring a differential backup will
76update changed files and new files, but also remove files that have
77been recorded as deleted. Note that the reference backup can be a full
78backup or another differential backup. This way you can make a first
79full backup, then many differential backup, each taking as reference
80the last backup made.
81
82SLICES: Dar stands for Disk ARchive. From the beginning it was
83designed to be able to split an archive over several removable media
84whatever their number is and whatever their size is. Thus dar is able
85to save over old floppy disk, CD-R, DVD-R, CD-RW, DVD-RW, Zip, Jazz,
86etc... Dar is not concerned by un/mounting a removable medium, instead
87it is independent of hardware. Given the size, it will split the
88archive in several files (called SLICES), eventually pausing before
89creating the next one, allowing this way, the user to un/mount a
90medium, burn the file on CD-R, send it by email (if your mail system
91does not allow huge file in emails, dar can help you here also). By
92default, (no size specified), dar will make one slice whatever its
93size is. Additionally, the size of the first slice can be specified
94separately, if for example you want first to fulfil a partially filled
95disk before starting using empty ones. Last, at restoration time, dar
96will just pause and prompt the user asking a slice only if it is
97missing.
98
99COMPRESSION: last, dar can use compression. By default no compression
100is used. Actually only gzip algorithm is implemented, but some room
101has been done for bzip2 and any other compression algorithm. Note
102that, compression is made before slices, which means that using
103compression with slices, will not make slices smaller, but will
104probably make less slices in the backup.
105
106DIRECT ACCESS: even using compression dar has not to read the whole
107backup to extract one file. This way if you just want to restore one
108file from a huge backup, the process will be much faster than using
109tar. Dar first reads the catalogue (i.e. the contents of the backup),
110then it goes directly to the location of the saved file(s) you want to
111restore and proceed to restoration. In particular using slices dar
112will ask only for the slice(s) containing the file(s) to restore.
113
114HARD LINK CONSIDERATION: hard links are now properly saved. They are
115properly restored if possible. If for example restoring across a
116mounted filesystem, hard linking will fail, but dar will then
117duplicate the inode and file content, issuing a warning.
118
119EXTENDED ATTRIBUTES: support for extended attributes have to be
120activated at compilation time (see INSTALL). Dar is able to save and
121restore EA, all or just those of a given namespace (system or user).
122If no EA have been saved and restoration occurs over a file that has
123EA, they will be preserved. But if they have been saved empty for a
124given file, any existing EA for that file will be removed at
125restoration time, unless -u and/or -U is given on command-line.
126
127ARCHIVE TESTING thanks to CRC (cyclic redundancy checks), dar is able
128to detect data corruption in the archive. Only the file where data
129corruption occurred will not be possible to restore, but dar will
130restore the other even when compression is used.
131
132USING PIPES dar is now able to produce an archive to its standard
133output or named pipe. it is also able to read an archive through a
134pair of pipes, to take a remote archive as reference, or even to
135restore data from a remote archive. This way it is now possible to
136store an archive remotely and in total security (if using encrypted
137means)
138
139ISOLATION the catalogue (i.e.: the contents of an archive), can be
140extracted (this operation is called isolation) to a small file, that
141can in turn be used as reference for differential archive. There is no
142more need to provide an archive to be able to create a differential
143backup over it, just its catalogue is necessary.
144
145RE-SHAPE SLICES OF AN EXISTING ARCHIVE the external program named
146"dar_xform" is able to change the size of slices of a given archive.
147The resulting archive is totally identical to archives directly
148created by dar. Source archive can be taken from a set of slice, from
149standard input or even a named pipe.
150
151%description -l pl.UTF-8
152dar jest poleceniem powłoki, które tworzy kopie zapasowe drzew
153katalogów i plików. Możliwości:
154- Filtry: dar może tworzyć kopię zapasową całego systemu plików do
155 pojedynczego pliku; mechanizm filtrów pozwala wyłączać lub dołączać
156 pliki przy tworzeniu kopii lub odtwarzaniu z niej.
157- Backup różnicowy: dar może tworzyć kopie pełne lub różnicowe
158 (zawierające tylko te pliki, które zmieniły się od innego backupu)
159- Części (slices): dar oznacza "Disk ARchive". Od początku ma
160 możliwość dzielenia archiwów na różne nośniki wymienialne,
161 niezależnie od ich liczby i rozmiaru (można tworzyć kopie na CD-R,
162 DVD-R, CD-RW, Zip, Jazz...).
163- Kompresja: domyślnie dar nie kompresuje danych; ma zaimplementowany
164 algorytm gzip, jest przygotowywany do bzip2 i innych. Kompresja jest
165 wykonywana przed podziałem na części.
166- Bezpośredni dostęp: nawet w przypadku użycia kompresji, dar nie musi
167 czytać całej kopii aby odtworzyć jeden plik. Najpierw odczytuje
168 katalog, następnie skacze od razu do właściwego miejsca.
169- Obsługa twardych dowiązań: dar zachowuje i odtwarza je w miarę
170 możliwości; w przypadku niemożliwości wykonania dowiązania, powiela
171 plik i wypisuje ostrzeżenie.
172- Obsługa rozszerzonych atrybutów (zależnie od opcji kompilacji): dar
173 potrafi zachowywać i odtwarzać rozszerzone atrybuty - wszystkie lub
174 tylko dotyczące danej przestrzeni nazw (systemowej lub użytkownika).
175- Testowanie archiwów: dzięki użyciu CRC dar wykrywa uszkodzone dane;
176 tylko uszkodzone pliki nie zostaną odtworzone, reszta tak - nawet w
177 przypadku użycia kompresji.
178- Użycie rurek - dar może wyprodukować archiwum na standardowe wyjście
179 lub do nazwanej rurki. Może także czytać archiwum z pary rurek, a
180 nawet odtwarzać ze zdalnego archiwum.
181- Rozdzielenie: katalog (zawartość archiwum) może być wyciągnięty do
182 małego pliku, który może być używany jako odniesienie dla
183 różnicowego backupu.
184- Przekształcanie części istniejącego archiwum: zewnętrzny program o
185 nazwie dar_xform jest w stanie zmieniać rozmiary części podanego
186 archiwum. Może czytać z zestawu kawałków, standardowego wejścia lub
187 nazwanej rurki.
188
189%package static
190Summary: Static version of dar backup tool
191Summary(pl.UTF-8): Statyczna wersja archiwizatora dar
192Group: Applications
193
194%description static
195Static version of dar backup tool.
196
197%description static -l pl.UTF-8
198Statyczna wersja archiwizatora dar.
199
200%package libs
201Summary: Shared version of dar library
202Summary(pl.UTF-8): Współdzielona wersja biblioteki dar
203Group: Libraries
204%{?with_ea:Requires: attr >= 2.4.16-3}
205Requires: gpgme >= 1.2.0
206Requires: libgcrypt >= 1.6.0
207
208%description libs
209Shared version of dar library.
210
211%description libs -l pl.UTF-8
212Współdzielona wersja biblioteki dar.
213
214%package devel
215Summary: Header files to develop dar software
216Summary(pl.UTF-8): Pliki nagłówkowe biblioteki dar
217Group: Development/Libraries
218Requires: %{name}-libs = %{version}-%{release}
219%{?with_ea:Requires: attr-devel >= 2.4.16-3}
220Requires: bzip2-devel
221Requires: gpgme-devel
222Requires: libcap-devel
223Requires: libgcrypt-devel >= 1.6.0
224Requires: libgpg-error-devel
225Requires: libstdc++-devel
226Requires: lzo-devel >= 2
227Requires: xz-devel
228Requires: zlib-devel
229
230%description devel
231Header files to develop software which operates on dar.
232
233%description devel -l pl.UTF-8
234Pliki nagłówkowe potrzebne do rozwoju oprogramowania korzystającego z
235dara.
236
237%package libs-static
238Summary: Static version of dar library
239Summary(pl.UTF-8): Statyczna wersja biblioteki dar
240Group: Development/Libraries
241Requires: %{name}-devel = %{version}-%{release}
242
243%description libs-static
244Static version of dar library.
245
246%description libs-static -l pl.UTF-8
247Statyczna wersja biblioteki dar.
248
249%package doc
250Summary: dar - documentation
251Summary(pl.UTF-8): dar - dokumentacja
252Group: Documentation
253Requires: %{name} = %{version}-%{release}
254
255%description doc
256Dar ducumentation.
257
258%description doc -l pl.UTF-8
259Dokumentacja dla dar.
260
261%prep
262%setup -q
263%patch0 -p1
264
265%build
266%{__gettextize}
267%{__libtoolize}
268%{__aclocal}
269%{__autoconf}
270%{__autoheader}
271%{__automake}
272%configure \
273 %{!?with_ea:--disable-ea-support} \
274 %{!?with_static:--disable-dar-static} \
275 --enable-static%{!?with_static_libs:=no} \
276 --enable-mode=64 \
277 --disable-upx
278%{__make}
279
280%install
281rm -rf $RPM_BUILD_ROOT
282%{?with_static:install -d $RPM_BUILD_ROOT/bin}
283
284%{__make} install \
285 DESTDIR=$RPM_BUILD_ROOT
286
287%{?with_static:%{__mv} $RPM_BUILD_ROOT{%{_bindir},/bin}/dar_static}
288
289ln -sf %{_datadir}/%{name} misc/doc
290
291# obsoleted by pkg-config
292%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdar64.la
293
294%find_lang %{name}
295
296%clean
297rm -rf $RPM_BUILD_ROOT
298
299%post libs -p /sbin/ldconfig
300%postun libs -p /sbin/ldconfig
301
302%files -f %{name}.lang
303%defattr(644,root,root,755)
304%doc AUTHORS ChangeLog NEWS README THANKS TODO misc/doc
305%attr(755,root,root) %{_bindir}/dar*
306%dir %{_datadir}/%{name}
307%{_mandir}/man1/dar*.1*
308%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/darrc
309
310%if %{with static}
311%files static
312%defattr(644,root,root,755)
313%attr(755,root,root) /bin/dar_static
314%endif
315
316%files libs
317%defattr(644,root,root,755)
318%attr(755,root,root) %{_libdir}/libdar64.so.*.*.*
319%attr(755,root,root) %ghost %{_libdir}/libdar64.so.5000
320
321%files devel
322%defattr(644,root,root,755)
323%attr(755,root,root) %{_libdir}/libdar64.so
324%{_includedir}/dar
325%{_pkgconfigdir}/libdar64.pc
326
327%if %{with static_libs}
328%files libs-static
329%defattr(644,root,root,755)
330%{_libdir}/libdar64.a
331%endif
332
333%files doc
334%defattr(644,root,root,755)
335%{_datadir}/%{name}/html
336%{_datadir}/%{name}/man
337%{_datadir}/%{name}/mini-howto
338%{_datadir}/%{name}/samples
339%{_datadir}/%{name}/*.dtd
340%{_datadir}/%{name}/*.jpg
341%{_datadir}/%{name}/*.html
342%{_datadir}/%{name}/*.txt
343%{_datadir}/%{name}/README
This page took 0.059132 seconds and 4 git commands to generate.