]> git.pld-linux.org Git - packages/createrepo_c.git/blame_incremental - createrepo_c.spec
up to 1.0.0 (new soname)
[packages/createrepo_c.git] / createrepo_c.spec
... / ...
CommitLineData
1# TODO:
2# - drpm support?
3#
4# Conditional build:
5%bcond_with rpm5 # build with rpm5, tests may fail (rpm.org vs rpm5 compat problems?)
6%bcond_without tests # make tests
7
8Summary: Creates a common metadata repository
9Summary(pl.UTF-8): Tworzenie wspólnego repozytorium metadanych
10Name: createrepo_c
11Version: 1.0.0
12Release: 1
13License: GPL v2+
14Group: Applications/System
15#Source0Download: https://github.com/rpm-software-management/createrepo_c/releases
16Source0: https://github.com/rpm-software-management/createrepo_c/archive/%{version}/%{name}-%{version}.tar.gz
17# Source0-md5: 253bb04c65351f4e4137661155bca11e
18Patch0: %{name}-rpm5.patch
19URL: https://github.com/rpm-software-management/createrepo_c
20BuildRequires: bash-completion-devel >= 1:2.0
21BuildRequires: bzip2-devel
22BuildRequires: cmake >= 2.8.12
23BuildRequires: curl-devel
24BuildRequires: doxygen
25#BuildRequires: drpm-devel
26BuildRequires: glib2-devel >= 1:2.22.0
27BuildRequires: libmagic-devel >= 5.40-2
28BuildRequires: libmodulemd-devel
29BuildRequires: libxml2-devel >= 2
30BuildRequires: openssl-devel
31BuildRequires: pkgconfig
32%{?with_tests:BuildRequires: python-nose}
33BuildRequires: python3-devel >= 1:3.2
34BuildRequires: python3-modules
35%{?with_tests:BuildRequires: python3-nose}
36BuildRequires: rpm-build >= 4.6
37BuildRequires: rpm-devel
38BuildRequires: rpm-pythonprov
39BuildRequires: rpmbuild(macros) >= 1.673
40BuildRequires: sphinx-pdg
41BuildRequires: sqlite3-devel >= 3
42BuildRequires: xz-devel
43BuildRequires: zchunk-devel
44BuildRequires: zlib-devel
45BuildRequires: zstd-devel
46%{?with_tests:BuildRequires: zchunk}
47Requires: %{name}-libs = %{version}-%{release}
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51C implementation of Createrepo. This utility will generate a common
52metadata repository from a directory of RPM packages.
53
54%description -l pl.UTF-8
55Implementacja w C programu Createrepo. To narzędzie generuje wspólne
56repozytorium metadanych z katalogu pakietów RPM.
57
58%package libs
59Summary: Library for repodata manipulation
60Summary(pl.UTF-8): Biblioteka do operacji na danych repozytorium
61Group: Libraries
62Requires: glib2 >= 1:2.22.0
63
64%description libs
65This package contains the createrepo_c library for applications to
66easy manipulate with a repodata.
67
68%description libs -l pl.UTF-8
69Ten pakiet zawiera bibliotekę createrepo_c, pozwalającą aplikacjom na
70łatwe operowanie na danych repozytorium (repodata).
71
72%package devel
73Summary: Header files for createrepo_c library
74Summary(pl.UTF-8): Pliki nagłówkowe biblioteki createrepo_c
75Group: Development/Libraries
76Requires: %{name}-libs = %{version}-%{release}
77Requires: bzip2-devel
78Requires: curl-devel
79Requires: expat-devel
80Requires: glib2-devel >= 1:2.22.0
81Requires: libmagic-devel
82Requires: libxml2-devel >= 2
83Requires: rpm-devel
84Requires: sqlite3-devel >= 3
85Requires: xz-devel
86Requires: zlib-devel
87Requires: zstd-devel
88
89%description devel
90This package contains the createrepo_c C header files. These
91development files are for easy manipulation with a repodata.
92
93%description devel -l pl.UTF-8
94Ten pakiet zawiera pliki nagłówkowe C biblioteki createrepo_c. Mają na
95celu łatwe operowanie na danych repozytorium (repodata).
96
97%package apidocs
98Summary: API documentation for createrepo_c library
99Summary(pl.UTF-8): Dokumentacja API biblioteki createrepo_c
100Group: Documentation
101BuildArch: noarch
102
103%description apidocs
104API documentation for createrepo_c library.
105
106%description apidocs -l pl.UTF-8
107Dokumentacja API biblioteki createrepo_c.
108
109%package -n python3-createrepo_c
110Summary: Python 3 bindings for the createrepo_c library
111Summary(pl.UTF-8): Wiązania Pythona 3 do biblioteki createrepo_c
112Group: Development/Languages/Python
113Requires: %{name}-libs = %{version}-%{release}
114Obsoletes: python-createrepo_c < 0.17.6
115
116%description -n python3-createrepo_c
117Python 3 bindings for the createrepo_c library.
118
119%description -n python3-createrepo_c -l pl.UTF-8
120Wiązania Pythona 3 do biblioteki createrepo_c.
121
122%package -n bash-completion-createrepo_c
123Summary: Bash completion for createrepo_c commands
124Summary(pl.UTF-8): Bashowe uzupełnianie dla poleceń createrepo_c
125Group: Applications/Shells
126Requires: %{name} = %{version}-%{release}
127Requires: bash-completion >= 1:2.0
128BuildArch: noarch
129
130%description -n bash-completion-createrepo_c
131Bash completion for createrepo_c commands (createrepo_c, mergerepo_c,
132modifyrepo_c).
133
134%description -n bash-completion-createrepo_c -l pl.UTF-8
135Bashowe uzupełnianie dla poleceń createrepo_c (createrepo_c,
136mergerepo_c, modifyrepo_c).
137
138%prep
139%setup -q
140%{?with_rpm5:%patch0 -p1}
141
142%build
143install -d build
144cd build
145%cmake .. \
146 -DBASHCOMP_DIR=%{bash_compdir} \
147 -DPYTHON_DESIRED=3
148
149%{__make}
150%{__make} doc
151
152%if %{with tests}
153%{__make} tests
154%{__make} test \
155 ARGS="-V"
156%endif
157
158%install
159rm -rf $RPM_BUILD_ROOT
160
161%{__make} -C build install \
162 DESTDIR=$RPM_BUILD_ROOT
163
164%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/createrepo_c
165%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/createrepo_c
166
167%clean
168rm -rf $RPM_BUILD_ROOT
169
170%post libs -p /sbin/ldconfig
171%postun libs -p /sbin/ldconfig
172
173%files
174%defattr(644,root,root,755)
175%attr(755,root,root) %{_bindir}/createrepo_c
176%attr(755,root,root) %{_bindir}/mergerepo_c
177%attr(755,root,root) %{_bindir}/modifyrepo_c
178%attr(755,root,root) %{_bindir}/sqliterepo_c
179%{_mandir}/man8/createrepo_c.8*
180%{_mandir}/man8/mergerepo_c.8*
181%{_mandir}/man8/modifyrepo_c.8*
182%{_mandir}/man8/sqliterepo_c.8*
183
184%files libs
185%defattr(644,root,root,755)
186%doc AUTHORS README.md
187%attr(755,root,root) %{_libdir}/libcreaterepo_c.so.*.*.*
188%attr(755,root,root) %ghost %{_libdir}/libcreaterepo_c.so.1
189
190%files devel
191%defattr(644,root,root,755)
192%attr(755,root,root) %{_libdir}/libcreaterepo_c.so
193%{_pkgconfigdir}/createrepo_c.pc
194%{_includedir}/createrepo_c
195
196%files apidocs
197%defattr(644,root,root,755)
198%doc build/doc/html
199
200%files -n python3-createrepo_c
201%defattr(644,root,root,755)
202%dir %{py3_sitedir}/createrepo_c
203%attr(755,root,root) %{py3_sitedir}/createrepo_c/_createrepo_c.so
204%{py3_sitedir}/createrepo_c/__init__.py
205%{py3_sitedir}/createrepo_c/__pycache__
206%{py3_sitedir}/createrepo_c-%{version}-py*.egg-info
207
208%files -n bash-completion-createrepo_c
209%defattr(644,root,root,755)
210%{bash_compdir}/createrepo_c
211%{bash_compdir}/mergerepo_c
212%{bash_compdir}/modifyrepo_c
213%{bash_compdir}/sqliterepo_c
This page took 0.071168 seconds and 4 git commands to generate.